summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2012-11-04 21:48:59 +0000
committerDane Smith <c1pher@gentoo.org>2012-11-04 21:48:59 +0000
commit73a89ebdbc97eb48ded6057cd597c9dc74a31631 (patch)
tree116999790cd82d07bf387f111d42101f60f9b7c9 /app-crypt/xca
parentVersion bump, bug #437178. (diff)
downloadgentoo-2-73a89ebdbc97eb48ded6057cd597c9dc74a31631.tar.gz
gentoo-2-73a89ebdbc97eb48ded6057cd597c9dc74a31631.tar.bz2
gentoo-2-73a89ebdbc97eb48ded6057cd597c9dc74a31631.zip
Version bump wrt bug 409987. Fix LDFLAGS respect. EAPI bump.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key E27104B3)
Diffstat (limited to 'app-crypt/xca')
-rw-r--r--app-crypt/xca/ChangeLog8
-rw-r--r--app-crypt/xca/files/xca-0.9.1-ldflags.patch11
-rw-r--r--app-crypt/xca/xca-0.9.1.ebuild52
3 files changed, 70 insertions, 1 deletions
diff --git a/app-crypt/xca/ChangeLog b/app-crypt/xca/ChangeLog
index 4d5eff2220fe..6fdb9166ae8b 100644
--- a/app-crypt/xca/ChangeLog
+++ b/app-crypt/xca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/xca
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.35 2012/09/18 04:47:33 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/ChangeLog,v 1.36 2012/11/04 21:48:59 c1pher Exp $
+
+*xca-0.9.1 (04 Nov 2012)
+
+ 04 Nov 2012; Dane Smith <c1pher@gentoo.org> +xca-0.9.1.ebuild,
+ +files/xca-0.9.1-ldflags.patch:
+ Version bump wrt bug 409987. Fix LDFLAGS respect. EAPI bump.
18 Sep 2012; Tim Harder <radhermit@gentoo.org> metadata.xml:
Remove redundant maintainer from metadata.
diff --git a/app-crypt/xca/files/xca-0.9.1-ldflags.patch b/app-crypt/xca/files/xca-0.9.1-ldflags.patch
new file mode 100644
index 000000000000..175e1edef195
--- /dev/null
+++ b/app-crypt/xca/files/xca-0.9.1-ldflags.patch
@@ -0,0 +1,11 @@
+--- configure 2011-11-07 01:09:32.000000000 -0500
++++ configure.new 2012-11-04 15:23:20.572917111 -0500
+@@ -42,7 +42,7 @@
+ prefix=${prefix:=/usr/local}
+ CFLAGS=${CFLAGS:=-Wall -ggdb -O2}
+ CC=${CC:=gcc}
+-LDFLAGS=""
++LDFLAGS="${LDFLAGS}"
+ LIBS="-lstdc++"
+ LDIRS=
+ MOC=moc
diff --git a/app-crypt/xca/xca-0.9.1.ebuild b/app-crypt/xca/xca-0.9.1.ebuild
new file mode 100644
index 000000000000..96c7bb0cb0e4
--- /dev/null
+++ b/app-crypt/xca/xca-0.9.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/xca/xca-0.9.1.ebuild,v 1.1 2012/11/04 21:48:59 c1pher Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests and revokation lists"
+HOMEPAGE="http://www.hohnstaedt.de/xca.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/openssl-0.9.8[-bindist]
+ x11-libs/qt-gui:4"
+DEPEND="${RDEPEND}
+ doc? ( app-text/linuxdoc-tools )"
+
+src_prepare() {
+ # http://sourceforge.net/tracker/index.php?func=detail&aid=1800298&group_id=62274&atid=500028
+ epatch "${FILESDIR}"/${PN}-0.9.0-qt_detection.patch
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_configure() {
+ local LINUXDOC
+ use doc || LINUXDOC='touch $@ && true'
+
+ QTDIR="${EPREFIX}/usr" \
+ STRIP="true" \
+ LINUXDOC="${LINUXDOC}" \
+ CC="$(tc-getCXX)" \
+ LD="$(tc-getLD)" \
+ CFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ prefix="${EPREFIX}/usr" \
+ docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ ./configure || die "configure failed"
+}
+
+src_install() {
+ emake destdir="${D}" mandir="share/man" install
+
+ dodoc AUTHORS
+
+ insinto /etc/xca
+ doins misc/*.txt
+}