summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-05-14 08:53:16 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-05-14 08:53:16 +0000
commit08c3ba310d0e18f25b5a2c08ef98db6a922e8985 (patch)
treede550cf7d8768ca4bfea6599493e683d1a7394a1 /app-crypt
parentFix my e-mail as well. (diff)
downloadgentoo-2-08c3ba310d0e18f25b5a2c08ef98db6a922e8985.tar.gz
gentoo-2-08c3ba310d0e18f25b5a2c08ef98db6a922e8985.tar.bz2
gentoo-2-08c3ba310d0e18f25b5a2c08ef98db6a922e8985.zip
Bump to 2.26.1, mostly bugfixes, crash fixes, annoying issues etc.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse/ChangeLog10
-rw-r--r--app-crypt/seahorse/seahorse-2.26.1.ebuild73
2 files changed, 81 insertions, 2 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index b5e7426a727c..2f6fb5f30bb5 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/seahorse
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.114 2009/03/20 03:14:02 jmbsvicetto Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.115 2009/05/14 08:53:16 nirbheek Exp $
+
+*seahorse-2.26.1 (14 May 2009)
+
+ 14 May 2009; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +seahorse-2.26.1.ebuild:
+ Bump to 2.26.1, mostly bugfixes, crash fixes, annoying issues etc.
20 Mar 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
metadata.xml:
diff --git a/app-crypt/seahorse/seahorse-2.26.1.ebuild b/app-crypt/seahorse/seahorse-2.26.1.ebuild
new file mode 100644
index 000000000000..ff8827feee74
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-2.26.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-2.26.1.ebuild,v 1.1 2009/05/14 08:53:16 nirbheek Exp $
+
+EAPI="1"
+
+inherit gnome2
+
+DESCRIPTION="A GNOME application for managing encryption keys"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi debug doc ldap libnotify test"
+
+RDEPEND=">=gnome-base/libglade-2.0
+ >=gnome-base/gconf-2.0
+ >=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.10
+ >=dev-libs/dbus-glib-0.72
+ >=gnome-base/gnome-keyring-2.25.5
+ net-libs/libsoup:2.4
+ x11-misc/shared-mime-info
+
+ net-misc/openssh
+ >=app-crypt/gpgme-1.0.0
+ || (
+ =app-crypt/gnupg-1.4*
+ =app-crypt/gnupg-2.0* )
+
+ avahi? ( >=net-dns/avahi-0.6 )
+ ldap? ( net-nds/openldap )
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-pgp
+ --enable-ssh
+ --enable-pkcs11
+ --disable-scrollkeeper
+ --disable-update-mime-database
+ --enable-hkp
+ $(use_enable avahi sharing)
+ $(use_enable debug)
+ $(use_enable ldap)
+ $(use_enable libnotify)
+ $(use_enable test tests)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Make it libtool-1 compatible
+ rm -v m4/lt* m4/libtool.m4 || die "removing libtool macros failed"
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in || die "sed failed"
+}
+
+pkg_postinst() {
+ einfo "The seahorse-agent tool has been moved to app-crypt/seahorse-plugins"
+ einfo "Use that if you want seahorse to manage your terminal SSH keys"
+}