summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-12-15 23:00:59 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-12-15 23:00:59 +0000
commit0ce36806b94529ce9db7e630370ab72b076ebc80 (patch)
treedd03ff22ec19ddb227afdd863576aeb4d4768349 /app-crypt
parentAdd epatch_user and pull prealloc patch (bug #532424 by Ulenrich). (diff)
downloadgentoo-2-0ce36806b94529ce9db7e630370ab72b076ebc80.tar.gz
gentoo-2-0ce36806b94529ce9db7e630370ab72b076ebc80.tar.bz2
gentoo-2-0ce36806b94529ce9db7e630370ab72b076ebc80.zip
Version bump for Gnome 3.14.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gcr/ChangeLog7
-rw-r--r--app-crypt/gcr/gcr-3.14.0.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/app-crypt/gcr/ChangeLog b/app-crypt/gcr/ChangeLog
index bcb9f07c192b..508a90433b3d 100644
--- a/app-crypt/gcr/ChangeLog
+++ b/app-crypt/gcr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/gcr
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/ChangeLog,v 1.45 2014/10/11 11:29:52 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/ChangeLog,v 1.46 2014/12/15 23:00:59 eva Exp $
+
+*gcr-3.14.0 (15 Dec 2014)
+
+ 15 Dec 2014; Gilles Dartiguelongue <eva@gentoo.org> +gcr-3.14.0.ebuild:
+ Version bump for Gnome 3.14.
11 Oct 2014; Markus Meier <maekke@gentoo.org> gcr-3.12.2.ebuild:
arm stable, bug #512012
diff --git a/app-crypt/gcr/gcr-3.14.0.ebuild b/app-crypt/gcr/gcr-3.14.0.ebuild
new file mode 100644
index 000000000000..d29207876f22
--- /dev/null
+++ b/app-crypt/gcr/gcr-3.14.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gcr/gcr-3.14.0.ebuild,v 1.1 2014/12/15 23:00:59 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.20"
+VALA_USE_DEPEND="vapigen"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 python-any-r1 vala virtualx
+
+DESCRIPTION="Libraries for cryptographic UIs and accessing PKCS#11 modules"
+HOMEPAGE="https://developer.gnome.org/gcr/"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/1" # subslot = suffix of libgcr-3
+IUSE="debug gtk +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ >=app-crypt/gnupg-2
+ >=app-crypt/p11-kit-0.19
+ >=dev-libs/glib-2.34:2
+ >=dev-libs/libgcrypt-1.2.2:0=
+ >=dev-libs/libtasn1-1:=
+ >=sys-apps/dbus-1
+ gtk? ( >=x11-libs/gtk+-3:3[introspection?] )
+ introspection? ( >=dev-libs/gobject-introspection-1.34 )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gnome-keyring-3.3
+"
+# gcr was part of gnome-keyring until 3.3
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/gobject-introspection-common
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.9
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+# eautoreconf needs:
+# dev-libs/gobject-introspection-common
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Disable stupid flag changes
+ sed -e 's/CFLAGS="$CFLAGS -g"//' \
+ -e 's/CFLAGS="$CFLAGS -O0"//' \
+ -i configure.ac configure || die
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ gnome2_src_configure \
+ $(use_with gtk) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ $(usex debug --enable-debug=yes --enable-debug=default) \
+ --disable-update-icon-cache \
+ --disable-update-mime
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check
+}