summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-21 06:34:54 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-21 06:34:54 +0000
commit1f293e5b49106d3a1f41a0717593c44b6a2a6c08 (patch)
tree8e9335086d980b1075be7b6549f9e6ea095c21a8 /app-crypt
parentnew stable version, GREAT new features (diff)
downloadgentoo-2-1f293e5b49106d3a1f41a0717593c44b6a2a6c08.tar.gz
gentoo-2-1f293e5b49106d3a1f41a0717593c44b6a2a6c08.tar.bz2
gentoo-2-1f293e5b49106d3a1f41a0717593c44b6a2a6c08.zip
Updated ebuild, closes #8216.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/ChangeLog6
-rw-r--r--app-crypt/gnupg/gnupg-1.2.0.ebuild30
2 files changed, 18 insertions, 18 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index ca329c8f782f..34d1c884ec26 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.7 2002/10/18 10:38:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.8 2002/10/21 06:34:54 aliz Exp $
*gnupg-1.2.0 (18 Oct 2002)
+ 21 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> gnupg-1.2.0.ebuild :
+ Updated ebuild, contributed by Jacob Perkins <jap1@ionet.net> in #8216.
+ Adds ldap support.
+
18 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> gnupg-1.2.0.ebuild :
Version bump, found by Daniel Seyffer <gentoo-bugs@seyffer.de> in #8778.
diff --git a/app-crypt/gnupg/gnupg-1.2.0.ebuild b/app-crypt/gnupg/gnupg-1.2.0.ebuild
index 6b0f4319bad8..900be9a41e48 100644
--- a/app-crypt/gnupg/gnupg-1.2.0.ebuild
+++ b/app-crypt/gnupg/gnupg-1.2.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.0.ebuild,v 1.1 2002/10/18 10:38:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.0.ebuild,v 1.2 2002/10/21 06:34:54 aliz Exp $
-IUSE="nls"
+IUSE="zlib ldap nls"
S="${WORKDIR}/${P}"
DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
@@ -13,32 +13,33 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
-DEPEND=">=sys-libs/zlib-1.1.3"
+DEPEND="sys-devel/perl
+ zlib? ( sys-libs/zlib )
+ ldap? ( net-nds/openldap )"
RDEPEND="nls? ( sys-devel/gettext )"
-
+
src_compile() {
local myconf
- use nls || myconf="--disable-nls"
+ use nls || myconf="${myconf} --disable-nls"
+ use ldap || myconf="${myconf} --disable-ldap"
+ use zlib || myconf="${myconf} --with-included-zlib"
+ #Still needed?
# Bug #6387, --enable-m-guard causes bus error on sparcs
if [ "${ARCH}" != "sparc" -a "${ARCH}" != "sparc64" ]; then
myconf="${myconf} --enable-m-guard"
fi
- econf \
- --enable-static-rnd=linux \
- --host="${CHOST}" \
- ${myconf} || die
+ econf ${myconf} || die
emake || make || die
}
src_install () {
make DESTDIR="${D}" install || die
- dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS
- dodoc README TODO VERSION
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS README THANKS TODO VERSION
docinto doc
cd doc
- dodoc FAQ HACKING DETAILS ChangeLog
+ dodoc FAQ HACKING DETAILS ChangeLog OpenPGP
docinto sgml
dodoc gpg.sgml gpgv.sgml
dohtml faq.html
@@ -51,9 +52,4 @@ pkg_postinst() {
einfo "gpg is installed SUID root to make use of protected memory space"
einfo "This is needed in order to have a secure place to store your passphrases,"
einfo "etc. at runtime but may make some sysadmins nervous"
- echo " "
- einfo "Note: this version is not backwards compatible with gnupg-1.0.6."
- einfo " To update your keyrings run: gpg --rebuild-keydb-caches"
- einfo " To backup your keyrings run: gpg --export-ownertrust"
- einfo " and copy the keyrings out of your ~/.gnupg directory."
}