summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2012-12-24 17:13:25 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2012-12-24 17:13:25 +0000
commit25df33cf0b75876bc684f001d7a61eb4889bb9f5 (patch)
treea1436a228cb46b87aedf31d1cb42363b6c096d9e /app-crypt
parentVersion bump for Gnome 3.6. Switch to EAPI=5 and python-single-r1.eclass. (diff)
downloadgentoo-2-25df33cf0b75876bc684f001d7a61eb4889bb9f5.tar.gz
gentoo-2-25df33cf0b75876bc684f001d7a61eb4889bb9f5.tar.bz2
gentoo-2-25df33cf0b75876bc684f001d7a61eb4889bb9f5.zip
Fix /var/run handling, per bug#448430, thanks to flameeyes
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/tpm-emulator/ChangeLog8
-rwxr-xr-xapp-crypt/tpm-emulator/files/tpm-emulator.initd-0.7.43
-rw-r--r--app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild (renamed from app-crypt/tpm-emulator/tpm-emulator-0.7.4.ebuild)5
3 files changed, 10 insertions, 6 deletions
diff --git a/app-crypt/tpm-emulator/ChangeLog b/app-crypt/tpm-emulator/ChangeLog
index 5fd1c2325b76..74f556dbed4c 100644
--- a/app-crypt/tpm-emulator/ChangeLog
+++ b/app-crypt/tpm-emulator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/tpm-emulator
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-emulator/ChangeLog,v 1.18 2012/12/23 01:25:26 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-emulator/ChangeLog,v 1.19 2012/12/24 17:13:25 alonbl Exp $
+
+*tpm-emulator-0.7.4-r1 (24 Dec 2012)
+
+ 24 Dec 2012; Alon Bar-Lev <alonbl@gentoo.org> +tpm-emulator-0.7.4-r1.ebuild,
+ -tpm-emulator-0.7.4.ebuild, files/tpm-emulator.initd-0.7.4:
+ Fix /var/run handling, per bug#448430, thanks to flameeyes
*tpm-emulator-0.7.4 (23 Dec 2012)
diff --git a/app-crypt/tpm-emulator/files/tpm-emulator.initd-0.7.4 b/app-crypt/tpm-emulator/files/tpm-emulator.initd-0.7.4
index 16e4c370162f..26ed541bbea0 100755
--- a/app-crypt/tpm-emulator/files/tpm-emulator.initd-0.7.4
+++ b/app-crypt/tpm-emulator/files/tpm-emulator.initd-0.7.4
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-emulator/files/tpm-emulator.initd-0.7.4,v 1.1 2012/12/23 01:25:26 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-emulator/files/tpm-emulator.initd-0.7.4,v 1.2 2012/12/24 17:13:25 alonbl Exp $
STARTUP_MODE='save';
@@ -29,6 +29,7 @@ checkconfig() {
start() {
ebegin "Starting tpm-emulator daemon with mode '$STARTUP_MODE' (tpmd)"
checkconfig || eend $?
+ checkpath -d -m 0775 -o tss /var/run/tpm
start-stop-daemon --start --exec "${command}" -- ${command_args} $STARTUP_MODE > /dev/null
eend $?
}
diff --git a/app-crypt/tpm-emulator/tpm-emulator-0.7.4.ebuild b/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild
index 20fdb23c2449..d58b7c4f856a 100644
--- a/app-crypt/tpm-emulator/tpm-emulator-0.7.4.ebuild
+++ b/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-emulator/tpm-emulator-0.7.4.ebuild,v 1.1 2012/12/23 01:25:26 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/tpm-emulator/tpm-emulator-0.7.4-r1.ebuild,v 1.1 2012/12/24 17:13:25 alonbl Exp $
EAPI=2
inherit user linux-mod cmake-utils udev
@@ -64,9 +64,6 @@ src_install() {
newinitd "${FILESDIR}"/${PN}.initd-0.7.4 ${PN}
newconfd "${FILESDIR}"/${PN}.confd-0.7.4 ${PN}
- keepdir /var/run/tpm
- fowners tss /var/run/tpm
-
keepdir /var/log/tpm
fowners tss:tss /var/log/tpm
}