summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-01-05 13:09:58 +0000
committerMichael Weber <xmw@gentoo.org>2012-01-05 13:09:58 +0000
commit2b4c26b6b6715ea0ad4211b2ca11035c7828ecb9 (patch)
tree4fd8df8f43998d8a22a96bb3a80d44f4f706ee82 /app-crypt
parentRemove unneeded/non-matching fperm (thanks to Agostino Sarubbo, bug 391891) (diff)
downloadgentoo-2-2b4c26b6b6715ea0ad4211b2ca11035c7828ecb9.tar.gz
gentoo-2-2b4c26b6b6715ea0ad4211b2ca11035c7828ecb9.tar.bz2
gentoo-2-2b4c26b6b6715ea0ad4211b2ca11035c7828ecb9.zip
Adding parallel-make patch by xarthisius (bug 298669)
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/keynote/ChangeLog10
-rw-r--r--app-crypt/keynote/files/keynote-2.3-parallel-build.patch14
-rw-r--r--app-crypt/keynote/keynote-2.3-r2.ebuild50
3 files changed, 72 insertions, 2 deletions
diff --git a/app-crypt/keynote/ChangeLog b/app-crypt/keynote/ChangeLog
index ce89d763a7a9..58ced8e8714f 100644
--- a/app-crypt/keynote/ChangeLog
+++ b/app-crypt/keynote/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/keynote
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/ChangeLog,v 1.12 2010/09/20 22:36:24 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/ChangeLog,v 1.13 2012/01/05 13:09:58 xmw Exp $
+
+*keynote-2.3-r2 (05 Jan 2012)
+
+ 05 Jan 2012; Michael Weber <xmw@gentoo.org> +keynote-2.3-r2.ebuild,
+ +files/keynote-2.3-parallel-build.patch:
+ Adding parallel-make patch by xarthisius (bug 298669)
*keynote-2.3-r1 (20 Sep 2010)
diff --git a/app-crypt/keynote/files/keynote-2.3-parallel-build.patch b/app-crypt/keynote/files/keynote-2.3-parallel-build.patch
new file mode 100644
index 000000000000..cf4b4926f79d
--- /dev/null
+++ b/app-crypt/keynote/files/keynote-2.3-parallel-build.patch
@@ -0,0 +1,14 @@
+--- keynote-2.3.orig/Makefile.in 2010-02-04 09:51:35.757096194 +0100
++++ keynote-2.3/Makefile.in 2010-02-04 09:52:17.441137132 +0100
+@@ -86,9 +86,11 @@
+
+ k.tab.c: keynote.y header.h keynote.h assertion.h config.h
+ $(YACC) $(YACCFLAGS) keynote.y
++k.tab.h: k.tab.c
+
+ z.tab.c: keynote-ver.y keynote.h header.h config.h
+ $(YACC) $(YACCFLAGS2) keynote-ver.y
++z.tab.h: z.tab.c
+
+ lex.kn.c: keynote.l k.tab.h header.h keynote.h assertion.h config.h
+ $(LEX) $(LEXFLAGS) keynote.l
diff --git a/app-crypt/keynote/keynote-2.3-r2.ebuild b/app-crypt/keynote/keynote-2.3-r2.ebuild
new file mode 100644
index 000000000000..d22ce90a60a2
--- /dev/null
+++ b/app-crypt/keynote/keynote-2.3-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/keynote-2.3-r2.ebuild,v 1.1 2012/01/05 13:09:58 xmw Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="The KeyNote Trust-Management System"
+HOMEPAGE="http://www1.cs.columbia.edu/~angelos/keynote.html"
+SRC_URI="http://www1.cs.columbia.edu/~angelos/Code/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cp -av Makefile.in{,.orig}
+ epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/$P-parallel-build.patch
+}
+
+src_configure() {
+ tc-export AR CC RANLIB
+ econf
+}
+
+src_compile() {
+ if use ssl; then
+ emake || die
+ else
+ emake nocrypto || die
+ fi
+}
+
+src_install() {
+ dobin keynote || die
+
+ dolib.a libkeynote.a
+
+ insinto /usr/include
+ doins keynote.h
+
+ doman man/keynote.[1345]
+ dodoc README HOWTO.add.crypto TODO
+}