summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2012-10-09 08:50:50 +0000
committerEray Aslan <eras@gentoo.org>2012-10-09 08:50:50 +0000
commit5a9b70aceae48a9487ee36a565c4f2c4f45c50ac (patch)
tree7a907afc3875b8aca1addf0aeb7d5611a1c445e9 /app-crypt
parentBump, updated homepage (diff)
downloadgentoo-2-5a9b70aceae48a9487ee36a565c4f2c4f45c50ac.tar.gz
gentoo-2-5a9b70aceae48a9487ee36a565c4f2c4f45c50ac.tar.bz2
gentoo-2-5a9b70aceae48a9487ee36a565c4f2c4f45c50ac.zip
Fix building with glibc-2.16.0 - bug #437660
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/shishi/ChangeLog9
-rw-r--r--app-crypt/shishi/files/shishi_gets.patch20
-rw-r--r--app-crypt/shishi/shishi-1.0.1-r1.ebuild81
3 files changed, 108 insertions, 2 deletions
diff --git a/app-crypt/shishi/ChangeLog b/app-crypt/shishi/ChangeLog
index ff03c811cf76..26c5ddeda073 100644
--- a/app-crypt/shishi/ChangeLog
+++ b/app-crypt/shishi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/shishi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/shishi/ChangeLog,v 1.4 2012/07/11 09:11:47 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/shishi/ChangeLog,v 1.5 2012/10/09 08:50:50 eras Exp $
+
+*shishi-1.0.1-r1 (09 Oct 2012)
+
+ 09 Oct 2012; Eray Aslan <eraya@gentoo.org> +files/shishi_gets.patch,
+ +shishi-1.0.1-r1.ebuild:
+ Fix building with glibc-2.16.0 - bug #437660
11 Jul 2012; Eray Aslan <eras@gentoo.org> shishi-1.0.1.ebuild,
+files/shishi_automake-1.12.patch:
@@ -19,4 +25,3 @@
+files/shishi_resolv.patch, +files/shishid.confd, +files/shishid.init,
+metadata.xml:
Initial import - bug #255461. Based on ebuild by AD Rutledge
-
diff --git a/app-crypt/shishi/files/shishi_gets.patch b/app-crypt/shishi/files/shishi_gets.patch
new file mode 100644
index 000000000000..12137204f455
--- /dev/null
+++ b/app-crypt/shishi/files/shishi_gets.patch
@@ -0,0 +1,20 @@
+diff --git a/gl/stdio.in.h b/gl/stdio.in.h
+index 06d9780..fa04a10 100644
+--- a/gl/stdio.in.h
++++ b/gl/stdio.in.h
+@@ -713,10 +713,13 @@ _GL_CXXALIAS_SYS (gets, char *, (char *s));
+ # endif
+ _GL_CXXALIASWARN (gets);
+ /* It is very rare that the developer ever has full control of stdin,
+- so any use of gets warrants an unconditional warning. Assume it is
+- always declared, since it is required by C89. */
++ so any use of gets warrants an unconditional warning; besides C11
++ removed it. */
++#ifdef gets
++#undef gets
+ _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+ #endif
++#endif
+
+
+ #if @GNULIB_OBSTACK_PRINTF@ || @GNULIB_OBSTACK_PRINTF_POSIX@
diff --git a/app-crypt/shishi/shishi-1.0.1-r1.ebuild b/app-crypt/shishi/shishi-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..37b29bc505dd
--- /dev/null
+++ b/app-crypt/shishi/shishi-1.0.1-r1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/shishi/shishi-1.0.1-r1.ebuild,v 1.1 2012/10/09 08:50:50 eras Exp $
+
+EAPI=4
+inherit multilib autotools eutils
+
+DESCRIPTION="A free implementation of the Kerberos 5 network security system"
+HOMEPAGE="https://www.gnu.org/software/shishi/"
+SRC_URI="mirror://gnu/shishi/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gnutls idn ipv6 nls pam +des +3des +aes +md +null +arcfour static-libs"
+
+DEPEND="gnutls? ( net-libs/gnutls )
+ idn? ( net-dns/libidn )
+ dev-libs/libtasn1
+ dev-libs/libgcrypt
+ dev-libs/libgpg-error
+ virtual/libiconv
+ virtual/libintl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # fix finding libresolv.so
+ epatch "${FILESDIR}/${PN}_resolv.patch"
+ # fix building with automake-1.12 bug #424095
+ epatch "${FILESDIR}/${PN}_automake-1.12.patch"
+ # fix building with glibc-2.16.0
+ epatch "${FILESDIR}/${PN}_gets.patch"
+
+ # don't create a new database
+ sed -i -e '/install-data-hook/s/^/#/' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable pam) \
+ $(use_enable nls) \
+ $(use_enable ipv6) \
+ $(use_with idn libidn-prefix) \
+ $(use_enable gnutls starttls) \
+ $(use_enable des) \
+ $(use_enable 3des) \
+ $(use_enable aes) \
+ $(use_enable md) \
+ $(use_enable null) \
+ $(use_enable arcfour) \
+ $(use_enable static-libs static) \
+ --with-system-asn1 \
+ --with-libgcrypt \
+ --with-html-dir=/usr/share/doc/${P} \
+ --with-db-dir=/var/shishi \
+ --with-pam-dir=/$(get_libdir)/security \
+ --disable-rpath \
+ --with-packager="Gentoo" \
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ keepdir /var/shishi
+ fperms 0700 /var/shishi
+ echo "db file /var/shishi" >> "${D}/etc/shishi/shisa.conf" || die
+
+ newinitd "${FILESDIR}/shishid.init" shishid
+ newconfd "${FILESDIR}/shishid.confd" shishid
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS
+ doman doc/man/* doc/*.1
+ dohtml doc/reference/html/*
+ doinfo doc/*.info*
+
+ rm -f "${D}/$(get_libdir)/security/pam_shishi.la"
+ use static-libs || find "${D}"/usr/lib* -name '*.la' -delete
+}