summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-12-22 05:17:11 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-12-22 05:17:11 +0000
commit63aee494ae513e0eb10e7572bb364dce805f61ef (patch)
treefd2f94bc6ebac64dcb066a9dde4a49c0ba404c30 /app-crypt
parentnew ebuild for bug 89290 (diff)
downloadgentoo-2-63aee494ae513e0eb10e7572bb364dce805f61ef.tar.gz
gentoo-2-63aee494ae513e0eb10e7572bb364dce805f61ef.tar.bz2
gentoo-2-63aee494ae513e0eb10e7572bb364dce805f61ef.zip
Fix grab (again), this time, remove the map-event completely, bug#201951
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pinentry/ChangeLog9
-rw-r--r--app-crypt/pinentry/files/digest-pinentry-0.7.4-r1 (renamed from app-crypt/pinentry/files/digest-pinentry-0.7.4)0
-rw-r--r--app-crypt/pinentry/files/pinentry-0.7.4-grab.patch4
-rw-r--r--app-crypt/pinentry/pinentry-0.7.4-r1.ebuild (renamed from app-crypt/pinentry/pinentry-0.7.4.ebuild)2
4 files changed, 11 insertions, 4 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index 6031d76c7269..955b22aae1e9 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/pinentry
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.74 2007/12/21 07:27:15 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.75 2007/12/22 05:17:11 alonbl Exp $
+
+*pinentry-0.7.4-r1 (22 Dec 2007)
+
+ 22 Dec 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ files/pinentry-0.7.4-grab.patch, -pinentry-0.7.4.ebuild,
+ +pinentry-0.7.4-r1.ebuild:
+ Fix grab (again), this time, remove the map-event completely, bug#201951
21 Dec 2007; Alon Bar-Lev <alonbl@gentoo.org> pinentry-0.7.4.ebuild:
Readd flag-o-matic
diff --git a/app-crypt/pinentry/files/digest-pinentry-0.7.4 b/app-crypt/pinentry/files/digest-pinentry-0.7.4-r1
index 0a7c2f5bbefa..0a7c2f5bbefa 100644
--- a/app-crypt/pinentry/files/digest-pinentry-0.7.4
+++ b/app-crypt/pinentry/files/digest-pinentry-0.7.4-r1
diff --git a/app-crypt/pinentry/files/pinentry-0.7.4-grab.patch b/app-crypt/pinentry/files/pinentry-0.7.4-grab.patch
index c96875d0afc9..118745b33807 100644
--- a/app-crypt/pinentry/files/pinentry-0.7.4-grab.patch
+++ b/app-crypt/pinentry/files/pinentry-0.7.4-grab.patch
@@ -6,11 +6,11 @@ diff -urNp pinentry-0.7.4/gtk+-2/pinentry-gtk-2.c pinentry-0.7.4.new/gtk+-2/pine
{
g_signal_connect (G_OBJECT (win),
- pinentry->grab ? "map-event" : "focus-in-event",
-+ pinentry->grab ? "expose-event" : "focus-in-event",
++ "focus-in-event",
G_CALLBACK (grab_keyboard), NULL);
g_signal_connect (G_OBJECT (win),
- pinentry->grab ? "unmap-event" : "focus-out-event",
-+ pinentry->grab ? "no-expose-event" : "focus-out-event",
++ "focus-out-event",
G_CALLBACK (ungrab_keyboard), NULL);
}
gtk_window_add_accel_group (GTK_WINDOW (win), acc);
diff --git a/app-crypt/pinentry/pinentry-0.7.4.ebuild b/app-crypt/pinentry/pinentry-0.7.4-r1.ebuild
index 5d58f1334abb..efb15574619d 100644
--- a/app-crypt/pinentry/pinentry-0.7.4.ebuild
+++ b/app-crypt/pinentry/pinentry-0.7.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.4.ebuild,v 1.3 2007/12/21 07:27:15 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.4-r1.ebuild,v 1.1 2007/12/22 05:17:11 alonbl Exp $
inherit qt3 multilib eutils flag-o-matic