summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-06-07 16:50:20 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-06-07 16:50:20 +0000
commit65f54704a2a35dce6b54748fe7b5362693f06e4a (patch)
tree3ab3da60b563fafc1360faa834cb880ab6aca984 /app-crypt
parentInitial ebuild (diff)
downloadgentoo-2-65f54704a2a35dce6b54748fe7b5362693f06e4a.tar.gz
gentoo-2-65f54704a2a35dce6b54748fe7b5362693f06e4a.tar.bz2
gentoo-2-65f54704a2a35dce6b54748fe7b5362693f06e4a.zip
Version bump, bug#181201, thanks to Yoann Pannier
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog7
-rw-r--r--app-crypt/truecrypt/files/digest-truecrypt-4.3a3
-rw-r--r--app-crypt/truecrypt/truecrypt-4.3a.ebuild105
3 files changed, 114 insertions, 1 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index d2ddb68c2a8d..7c6a3f96b54f 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.19 2007/04/28 16:10:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.20 2007/06/07 16:50:20 alonbl Exp $
+
+*truecrypt-4.3a (07 Jun 2007)
+
+ 07 Jun 2007; Alon Bar-Lev <alonbl@gentoo.org> +truecrypt-4.3a.ebuild:
+ Version bump, bug#181201, thanks to Yoann Pannier
28 Apr 2007; Raúl Porcel <armin76@gentoo.org> truecrypt-4.3.ebuild:
x86 stable wrt #176159
diff --git a/app-crypt/truecrypt/files/digest-truecrypt-4.3a b/app-crypt/truecrypt/files/digest-truecrypt-4.3a
new file mode 100644
index 000000000000..f36489dc1c50
--- /dev/null
+++ b/app-crypt/truecrypt/files/digest-truecrypt-4.3a
@@ -0,0 +1,3 @@
+MD5 8f2536eae16e6044a22b2a82c7003357 truecrypt-4.3a-source-code.tar.gz 1110554
+RMD160 1a24ae6132b43876161a090751c19afed7c5c996 truecrypt-4.3a-source-code.tar.gz 1110554
+SHA256 d5515cfeb1bb328ad6f13ef347cd9422b4bb15bf849aabc4cd4f2f69a3e0c74a truecrypt-4.3a-source-code.tar.gz 1110554
diff --git a/app-crypt/truecrypt/truecrypt-4.3a.ebuild b/app-crypt/truecrypt/truecrypt-4.3a.ebuild
new file mode 100644
index 000000000000..551c17e4c99a
--- /dev/null
+++ b/app-crypt/truecrypt/truecrypt-4.3a.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-4.3a.ebuild,v 1.1 2007/06/07 16:50:20 alonbl Exp $
+
+#
+# NOTES:
+# - Upstream overwrite CFLAGS, and does not wish us to mess with them.
+# - Upstream insist on hiding the Makefile commands... Don't wish to patch it
+# again.
+# - Some issues with parallel make of user mode library.
+# - Upstream is not responsive, even new kernel versions are not supported
+# by upstream, but by other users.
+#
+
+inherit linux-mod toolchain-funcs multilib
+
+DESCRIPTION="Free open-source disk encryption software"
+HOMEPAGE="http://www.truecrypt.org/"
+SRC_URI="http://www.truecrypt.org/downloads/truecrypt-${PV}-source-code.tar.gz"
+
+LICENSE="truecrypt-collective-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/device-mapper"
+DEPEND="virtual/linux-sources
+ ${RDEPEND}"
+
+S="${WORKDIR}/${P}-source-code"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ dmcrypt_check
+ kernel_is lt 2 6 5 && die 'requires at least 2.6.5 kernel version'
+
+ BUILD_PARAMS="KERNEL_SRC=${KERNEL_DIR} NO_WARNINGS=1"
+ BUILD_TARGETS="truecrypt"
+ MODULE_NAMES="truecrypt(block:${S}/Linux/Kernel)"
+
+}
+
+src_compile() {
+ linux-mod_src_compile || die "Truecrypt module compilation failed."
+
+ einfo "Building truecrypt utility"
+ cd "${S}/Linux/Cli"
+ MAKEOPTS="-j1" emake all NO_STRIP=1 NO_WARNINGS=1 CC="$(tc-getCC)" || die "Compile and/or linking of TrueCrypt Linux CLI application failed."
+}
+
+src_test() {
+ "${S}/Linux/Cli/truecrypt" --test
+}
+
+pkg_preinst() {
+ # unload truecrypt modules if already loaded
+ /sbin/rmmod truecrypt >&- 2>&-
+ grep -q "^truecrypt" /proc/modules && die "Please dismount all mounted TrueCrypt volumes"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ einfo "Installing truecrypt utility"
+ cd "${S}"
+ dobin Linux/Cli/truecrypt
+ doman Linux/Cli/Man/truecrypt.1
+ dodoc Readme.txt 'Release/Setup Files/TrueCrypt User Guide.pdf'
+ insinto "/$(get_libdir)/rcscripts/addons"
+ newins "${FILESDIR}/${PN}-stop.sh" "${PN}-stop.sh"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ elog " For TrueCrypt 4.2 to work you have to load a "
+ elog " kernel module. This can be done in three ways: "
+ elog
+ elog " 1. Loading the module automatically by the running kernel. "
+ elog " For this 'Automatic kernel module loading' needs to be "
+ elog " enabled (CONFIG_KMOD=y). "
+ elog " 2. Loading the module manually before mounting the volume. "
+ elog " Try 'modprobe truecrypt' as root to load the module. "
+ elog " 3. Load the module during boot by listing it in "
+ elog " '/etc/modules.autoload.d/kernel-2.6' "
+}
+
+dmcrypt_check() {
+ ebegin "Checking for Device mapper support (BLK_DEV_DM)"
+ linux_chkconfig_present BLK_DEV_DM
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ ewarn "TrueCrypt requires Device mapper support!"
+ ewarn "Please enable Device mapper support in your kernel config, found at:"
+ ewarn "(for 2.6 kernels)"
+ ewarn
+ ewarn " Device Drivers"
+ ewarn " Multi-Device Support"
+ ewarn " <*> Device mapper support"
+ ewarn
+ ewarn "and recompile your kernel if you want this package to work."
+ epause 10
+ fi
+}