summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2001-09-12 04:47:46 +0000
committerBruce A. Locke <blocke@gentoo.org>2001-09-12 04:47:46 +0000
commit8f55fcd3c51eef995d4ae1fd1f2c5379e5044519 (patch)
tree1eb91ae969f98885074cbf40c5ed0204d4677d43 /app-crypt
parentgwcc 0.9.6 (diff)
downloadgentoo-2-8f55fcd3c51eef995d4ae1fd1f2c5379e5044519.tar.gz
gentoo-2-8f55fcd3c51eef995d4ae1fd1f2c5379e5044519.tar.bz2
gentoo-2-8f55fcd3c51eef995d4ae1fd1f2c5379e5044519.zip
gpgme: a library for the use of gnupg
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gpgme/files/digest-gpgme-0.2.21
-rw-r--r--app-crypt/gpgme/gpgme-0.2.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/gpgme/files/digest-gpgme-0.2.2 b/app-crypt/gpgme/files/digest-gpgme-0.2.2
new file mode 100644
index 000000000000..e33ebeb58b6b
--- /dev/null
+++ b/app-crypt/gpgme/files/digest-gpgme-0.2.2
@@ -0,0 +1 @@
+MD5 5ac08884612ad7fd5bdb640e4b949c79 gpgme-0.2.2.tar.gz
diff --git a/app-crypt/gpgme/gpgme-0.2.2.ebuild b/app-crypt/gpgme/gpgme-0.2.2.ebuild
new file mode 100644
index 000000000000..68ab091dab2e
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-0.2.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+# $Header: /home/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.0.4.ebuild,v 1.0
+# 2001/04/21 12:45 CST blutgens Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications."
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/gpgme/${A}"
+HOMEPAGE="http://www.gnupg.org/gpgme.html"
+
+DEPEND="virtual/glibc
+ nls? ( >=sys-devel/gettext-0.10.35 )
+ >=sys-libs/zlib-1.1.3 >=app-crypt/gnupg-1.0.6"
+
+RDEPEND=">=app-crypt/gnupg-1.0.6"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]; then
+ myconf="--disable-nls"
+ fi
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man \
+ --infodir=/usr/share/info --host=${CHOST} ${myconf}
+
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README README-alpha THANKS TODO
+
+}