summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-06-15 16:25:32 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-06-15 16:25:32 +0000
commitb2defcc5980cf74899fbd5dbe5a5ffe30d6a7292 (patch)
tree25c05d970c9c3b460305cdf1736651368cf38521 /app-crypt
parentremove version using obsolete webapp-apache eclass, bug #182129 (diff)
downloadgentoo-2-b2defcc5980cf74899fbd5dbe5a5ffe30d6a7292.tar.gz
gentoo-2-b2defcc5980cf74899fbd5dbe5a5ffe30d6a7292.tar.bz2
gentoo-2-b2defcc5980cf74899fbd5dbe5a5ffe30d6a7292.zip
Fix gtk2+ grab issue, bug#165493, thanks to Vincent Pit
(Portage version: 2.1.2.9)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pinentry/ChangeLog8
-rw-r--r--app-crypt/pinentry/files/digest-pinentry-0.7.2-r43
-rw-r--r--app-crypt/pinentry/files/pinentry-0.7.2-grab.patch15
-rw-r--r--app-crypt/pinentry/pinentry-0.7.2-r4.ebuild76
4 files changed, 101 insertions, 1 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index 9a5fcc367782..fe62b452f6c9 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/pinentry
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.60 2007/04/24 20:11:55 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.61 2007/06/15 16:25:32 alonbl Exp $
+
+*pinentry-0.7.2-r4 (15 Jun 2007)
+
+ 15 Jun 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/pinentry-0.7.2-grab.patch, +pinentry-0.7.2-r4.ebuild:
+ Fix gtk2+ grab issue, bug#165493, thanks to Vincent Pit
24 Apr 2007; Sven Wegener <swegener@gentoo.org> -pinentry-0.7.2-r2.ebuild:
Cleanup.
diff --git a/app-crypt/pinentry/files/digest-pinentry-0.7.2-r4 b/app-crypt/pinentry/files/digest-pinentry-0.7.2-r4
new file mode 100644
index 000000000000..bcde47e68cda
--- /dev/null
+++ b/app-crypt/pinentry/files/digest-pinentry-0.7.2-r4
@@ -0,0 +1,3 @@
+MD5 55626ce13ed76d82ec5330d19bdf3ab4 pinentry-0.7.2.tar.gz 398775
+RMD160 db667256801545ef065d9d47cafe5e67137fa6ce pinentry-0.7.2.tar.gz 398775
+SHA256 fbdb15ef6b05c5435745d1dde90cf4c82dd512c983d7a178cd25bdbe882dd668 pinentry-0.7.2.tar.gz 398775
diff --git a/app-crypt/pinentry/files/pinentry-0.7.2-grab.patch b/app-crypt/pinentry/files/pinentry-0.7.2-grab.patch
new file mode 100644
index 000000000000..c88aa62f3115
--- /dev/null
+++ b/app-crypt/pinentry/files/pinentry-0.7.2-grab.patch
@@ -0,0 +1,15 @@
+--- pinentry-0.7.2/gtk+-2/pinentry-gtk-2.c 2007-06-15 15:53:28.000000000 +0200
++++ pinentry-0.7.2/gtk+-2/pinentry-gtk-2.c 2007-06-15 16:01:57.000000000 +0200
+@@ -207,10 +207,10 @@
+ if (!confirm_mode)
+ {
+ g_signal_connect (G_OBJECT (win),
+- pinentry->grab ? "map-event" : "focus-in-event",
++ pinentry->grab ? "expose-event" : "focus-in-event",
+ G_CALLBACK (grab_keyboard), NULL);
+ g_signal_connect (G_OBJECT (win),
+- pinentry->grab ? "unmap-event" : "focus-out-event",
++ pinentry->grab ? "no-expose-event" : "focus-out-event",
+ G_CALLBACK (ungrab_keyboard), NULL);
+ }
+ gtk_window_add_accel_group (GTK_WINDOW (win), acc);
diff --git a/app-crypt/pinentry/pinentry-0.7.2-r4.ebuild b/app-crypt/pinentry/pinentry-0.7.2-r4.ebuild
new file mode 100644
index 000000000000..7d9f36606c95
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-0.7.2-r4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.2-r4.ebuild,v 1.1 2007/06/15 16:25:32 alonbl Exp $
+
+WANT_AUTOCONF="2.5"
+WANT_AUTOMAKE="1.9"
+
+inherit flag-o-matic qt3 multilib eutils autotools
+
+DESCRIPTION="Collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="http://www.gnupg.org/aegypten/"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk ncurses qt3 caps"
+
+DEPEND="gtk? ( =x11-libs/gtk+-2* )
+ ncurses? ( sys-libs/ncurses )
+ qt3? ( $(qt_min_version 3.3) )
+ !gtk? ( !qt3? ( !ncurses? ( sys-libs/ncurses ) ) )
+ caps? ( sys-libs/libcap )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PV}-libcap.patch
+ epatch "${FILESDIR}"/${PV}-info.patch
+ epatch "${FILESDIR}"/${P}-grab.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ local myconf=""
+
+ if ! ( use qt3 || use gtk || use ncurses )
+ then
+ myconf="--enable-pinentry-curses --enable-fallback-curses"
+ fi
+
+ append-ldflags $(bindnow-flags)
+
+ # Issues finding qt on multilib systems
+ export QTLIB="${QTDIR}/$(get_libdir)"
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-maintainer-mode \
+ --disable-pinentry-gtk \
+ $(use_enable gtk pinentry-gtk2) \
+ $(use_enable qt3 pinentry-qt) \
+ $(use_enable ncurses pinentry-curses) \
+ $(use_enable ncurses fallback-curses) \
+ $(use_with caps libcap) \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "We no longer install pinentry-curses and pinentry-qt SUID root by default."
+ elog "Linux kernels >=2.6.9 support memory locking for unprivileged processes."
+ elog "The soft resource limit for memory locking specifies the limit an"
+ elog "unprivileged process may lock into memory. You can also use POSIX"
+ elog "capabilities to allow pinentry to lock memory. To do so activate the caps"
+ elog "USE flag and add the CAP_IPC_LOCK capability to the permitted set of"
+ elog "your users."
+}