summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-02-08 18:42:13 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-02-08 18:42:13 +0000
commitb75815ac96f0ba1028cf703e71fe6b275a59735a (patch)
tree80f02461b506bcd911a2698617136c3b718963d8 /app-crypt
parentStable on x86 wrt bug #208128 (diff)
downloadgentoo-2-b75815ac96f0ba1028cf703e71fe6b275a59735a.tar.gz
gentoo-2-b75815ac96f0ba1028cf703e71fe6b275a59735a.tar.bz2
gentoo-2-b75815ac96f0ba1028cf703e71fe6b275a59735a.zip
Version bump, bug#209091
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog10
-rw-r--r--app-crypt/truecrypt/files/truecrypt-5.0-build.patch28
-rw-r--r--app-crypt/truecrypt/truecrypt-5.0.ebuild73
3 files changed, 109 insertions, 2 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 85aecdf349d5..9334fa2355f8 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/truecrypt
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.28 2007/12/25 21:01:31 alonbl Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.29 2008/02/08 18:42:12 alonbl Exp $
+
+*truecrypt-5.0 (08 Feb 2008)
+
+ 08 Feb 2008; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/truecrypt-5.0-build.patch, +truecrypt-5.0.ebuild:
+ Version bump, bug#209091
25 Dec 2007; Alon Bar-Lev <alonbl@gentoo.org>
files/truecrypt-4.3a-2.6.24.patch:
diff --git a/app-crypt/truecrypt/files/truecrypt-5.0-build.patch b/app-crypt/truecrypt/files/truecrypt-5.0-build.patch
new file mode 100644
index 000000000000..e34e5be2eacc
--- /dev/null
+++ b/app-crypt/truecrypt/files/truecrypt-5.0-build.patch
@@ -0,0 +1,28 @@
+diff -urNp truecrypt-5.0-source.org/Main/Main.make truecrypt-5.0-source/Main/Main.make
+--- truecrypt-5.0-source.org/Main/Main.make 2008-02-05 01:16:52.000000000 +0200
++++ truecrypt-5.0-source/Main/Main.make 2008-02-08 19:09:47.000000000 +0200
+@@ -62,18 +62,20 @@ RESOURCES += ../Mount/Logo_96dpi.bmp.h
+
+ CXXFLAGS += -I$(BASE_DIR)/Main
+
++WX_CONFIG ?= $(WX_BUILD_DIR)/wx-config
++WX_CONFIG_EXTRA ?= --static
+
+ #------ wxWidgets configuration ------
+
+ ifeq "$(TC_BUILD_CONFIG)" "Release"
+
+-CXXFLAGS += $(shell $(WX_BUILD_DIR)/wx-config --unicode --static --cxxflags)
+-WX_LIBS = $(shell $(WX_BUILD_DIR)/wx-config --unicode --static --libs adv,core,base)
++CXXFLAGS += $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --cxxflags)
++WX_LIBS = $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --libs adv,core,base)
+
+ else
+
+-CXXFLAGS += $(shell $(WX_BUILD_DIR)/wx-config --debug --unicode --static --cxxflags)
+-WX_LIBS = $(shell $(WX_BUILD_DIR)/wx-config --debug --unicode --static --libs adv,core,base)
++CXXFLAGS += $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --debug --cxxflags)
++WX_LIBS = $(shell $(WX_CONFIG) $(WX_CONFIG_EXTRA) --debug --libs adv,core,base)
+
+ endif
+
diff --git a/app-crypt/truecrypt/truecrypt-5.0.ebuild b/app-crypt/truecrypt/truecrypt-5.0.ebuild
new file mode 100644
index 000000000000..f3768ddd5bb7
--- /dev/null
+++ b/app-crypt/truecrypt/truecrypt-5.0.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-5.0.ebuild,v 1.1 2008/02/08 18:42:12 alonbl Exp $
+
+#
+# NOTES:
+# - Upstream overwrite CFLAGS, and does not wish us to mess with them.
+# - Upstream insist on hiding the Makefile commands... Don't wish to patch it
+# again.
+# - Some issues with parallel make of user mode library.
+# - Upstream is not responsive, even new kernel versions are not supported
+# by upstream, but by other users.
+#
+
+inherit eutils toolchain-funcs multilib wxwidgets
+
+DESCRIPTION="Free open-source disk encryption software"
+HOMEPAGE="http://www.truecrypt.org/"
+SRC_URI="${P}.tar.gz"
+
+LICENSE="truecrypt-collective-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="fetch"
+
+RDEPEND="sys-fs/fuse
+ =x11-libs/wxGTK-2.8*"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}-source"
+
+pkg_nofetch() {
+ einfo "Please download tar.gz source from:"
+ einfo "http://www.truecrypt.org/downloads2.php"
+ einfo "Then put the file in ${DISTDIR}/${P}.tar.gz"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.patch"
+}
+
+src_compile() {
+ WX_GTK_VER="2.8"
+ need-wxwidgets unicode
+ emake \
+ NOSTRIP=1 \
+ VERBOSE=1 \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ CXX="$(tc-getCXX)" \
+ RANLIB="$(tc-getRANLIB)" \
+ EXTRA_CFLAGS="${CFLAGS}" \
+ EXTRA_CXXFLAGS="${CXXFLAGS}" \
+ EXTRA_LDFLAGS="${LDFLAGS}" \
+ WX_CONFIG="${WX_CONFIG}" \
+ WX_CONFIG_EXTRA="" \
+ || die
+}
+
+# Requires DISPLAY anyway...
+#src_test() {
+# "${S}/Main/truecrypt" --text --test
+#}
+
+src_install() {
+ dobin Main/truecrypt
+ dodoc Readme.txt 'Release/Setup Files/TrueCrypt User Guide.pdf'
+ insinto "/$(get_libdir)/rcscripts/addons"
+ newins "${FILESDIR}/${PN}-stop.sh" "${PN}-stop.sh"
+}