summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-01-03 13:42:24 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-01-03 13:42:24 +0000
commitf89171df2c40e9bd412eac84d5f8e123106f6bde (patch)
tree7bea15f97b497dda4f7cea77fccee17bc8b5834a /app-crypt
parentapply some indentation to make next patch less invasive, still no functional ... (diff)
downloadgentoo-2-f89171df2c40e9bd412eac84d5f8e123106f6bde.tar.gz
gentoo-2-f89171df2c40e9bd412eac84d5f8e123106f6bde.tar.bz2
gentoo-2-f89171df2c40e9bd412eac84d5f8e123106f6bde.zip
Patch for gnupg2 support. Patch needs to go to upstream.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/seahorse/ChangeLog10
-rw-r--r--app-crypt/seahorse/files/digest-seahorse-0.8.2-r13
-rw-r--r--app-crypt/seahorse/files/seahorse-0.8.2-gpg2.0.patch109
-rw-r--r--app-crypt/seahorse/seahorse-0.8.2-r1.ebuild64
4 files changed, 184 insertions, 2 deletions
diff --git a/app-crypt/seahorse/ChangeLog b/app-crypt/seahorse/ChangeLog
index 06914498add9..5366d93edd21 100644
--- a/app-crypt/seahorse/ChangeLog
+++ b/app-crypt/seahorse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/seahorse
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.63 2006/11/04 20:10:47 compnerd Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/ChangeLog,v 1.64 2007/01/03 13:42:24 robbat2 Exp $
+
+*seahorse-0.8.2-r1 (03 Jan 2007)
+
+ 03 Jan 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/seahorse-0.8.2-gpg2.0.patch, +seahorse-0.8.2-r1.ebuild:
+ Patch for gnupg2 support. Patch needs to go to upstream.
*seahorse-0.8.2 (04 Nov 2006)
diff --git a/app-crypt/seahorse/files/digest-seahorse-0.8.2-r1 b/app-crypt/seahorse/files/digest-seahorse-0.8.2-r1
new file mode 100644
index 000000000000..be2633249aaf
--- /dev/null
+++ b/app-crypt/seahorse/files/digest-seahorse-0.8.2-r1
@@ -0,0 +1,3 @@
+MD5 24d9a8c3564700d105847934020920bd seahorse-0.8.2.tar.bz2 990284
+RMD160 722f060a2d54ff028c7dfcf3e935153ca4996803 seahorse-0.8.2.tar.bz2 990284
+SHA256 350f1a1cc5010bb81f08c6c124a24f2560a9dffea16c8a5a62e9cdeebb03c68e seahorse-0.8.2.tar.bz2 990284
diff --git a/app-crypt/seahorse/files/seahorse-0.8.2-gpg2.0.patch b/app-crypt/seahorse/files/seahorse-0.8.2-gpg2.0.patch
new file mode 100644
index 000000000000..a0232b99be83
--- /dev/null
+++ b/app-crypt/seahorse/files/seahorse-0.8.2-gpg2.0.patch
@@ -0,0 +1,109 @@
+Subject: GnuPG 2.0 support for Seahorse
+From: Robin H. Johnson <robbat2@gentoo.org>
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+The following patch fixes the previous hardcoding of 1.4 and 1.2 versions of
+GnuPG to also allow the 2.0 series.
+
+diff -Nuar --exclude '*~' seahorse-0.8.2.orig/configure seahorse-0.8.2/configure
+--- seahorse-0.8.2.orig/configure 2006-07-10 10:41:43.000000000 -0700
++++ seahorse-0.8.2/configure 2007-01-02 17:14:27.474945791 -0800
+@@ -19569,8 +19569,7 @@
+ fi;
+
+ if test "$DO_CHECK" = "yes"; then
+- major_versions="1"
+- minor_versions="2 4"
++ accept_versions="1.2 1.4 2.0"
+ # Extract the first word of "gpg", so it can be a program name with args.
+ set dummy gpg; ac_word=$2
+ echo "$as_me:$LINENO: checking for $ac_word" >&5
+@@ -19623,21 +19622,11 @@
+ micro=`echo $gnupg_version | \
+ sed 's/^gpg (GnuPG) \([0-9]*\)\.\([0-9]*\)\.\([0-9]*\).*/\3/'`
+
+- for ver in $major_versions; do
+- if test "$ver" = "$major"; then
+-
+- # Check the minor version
+- for ver2 in $minor_versions; do
+- if test "$ver2" = "$minor"; then
+-
++ for ver in $accept_versions; do
++ if test "$ver" = "$major.$minor"; then
+ ok="yes"
+ break
+-
+- fi
+- done
+- break
+-
+- fi
++ fi
+ done
+
+ fi
+diff -Nuar --exclude '*~' seahorse-0.8.2.orig/configure.in seahorse-0.8.2/configure.in
+--- seahorse-0.8.2.orig/configure.in 2006-07-10 10:40:35.000000000 -0700
++++ seahorse-0.8.2/configure.in 2007-01-02 17:15:25.609655647 -0800
+@@ -59,8 +59,7 @@
+ DO_CHECK=$enableval, DO_CHECK=yes)
+
+ if test "$DO_CHECK" = "yes"; then
+- major_versions="1"
+- minor_versions="2 4"
++ accept_versions="1.2 1.4 2.0"
+ AC_PATH_PROG(GNUPG, gpg, no)
+ ok="no"
+ if test "$GNUPG" != "no"; then
+@@ -72,22 +71,12 @@
+ sed 's/^gpg (GnuPG) \([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\2/'`
+ micro=`echo $gnupg_version | \
+ sed 's/^gpg (GnuPG) \([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
+-
+- for ver in $major_versions; do
+- if test "$ver" = "$major"; then
+-
+- # Check the minor version
+- for ver2 in $minor_versions; do
+- if test "$ver2" = "$minor"; then
+-
++
++ for ver in $accept_versions; do
++ if test "$ver" = "$major.$minor"; then
+ ok="yes"
+ break
+-
+- fi
+- done
+- break
+-
+- fi
++ fi
+ done
+
+ fi
+diff -Nuar --exclude '*~' seahorse-0.8.2.orig/libseahorse/seahorse-gpg-options.c seahorse-0.8.2/libseahorse/seahorse-gpg-options.c
+--- seahorse-0.8.2.orig/libseahorse/seahorse-gpg-options.c 2005-10-05 15:00:24.000000000 -0700
++++ seahorse-0.8.2/libseahorse/seahorse-gpg-options.c 2007-01-03 04:40:35.770386761 -0800
+@@ -32,7 +32,6 @@
+ #include "seahorse-gpg-options.h"
+
+ #define GPG_CONF_HEADER "# FILE CREATED BY SEAHORSE\n\n"
+-#define GPG_VERSION_PREFIX "1."
+
+ static gchar gpg_homedir[MAXPATHLEN];
+ static gboolean gpg_options_inited = FALSE;
+@@ -271,9 +270,11 @@
+ /*
+ * Make sure it's the right version for us to be messing
+ * around with the configuration file.
++ * Both 1.* and 2.* are suitable.
+ */
+ g_return_val_if_fail (engine && engine->version && engine->file_name &&
+- g_str_has_prefix (engine->version, GPG_VERSION_PREFIX),
++ (g_str_has_prefix (engine->version, "1.") ||
++ g_str_has_prefix (engine->version, "2.")),
+ (seahorse_util_gpgme_to_error
+ (GPG_E (GPG_ERR_INV_ENGINE), err), FALSE));
+
diff --git a/app-crypt/seahorse/seahorse-0.8.2-r1.ebuild b/app-crypt/seahorse/seahorse-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..13ce43f192cf
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-0.8.2-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-0.8.2-r1.ebuild,v 1.1 2007/01/03 13:42:24 robbat2 Exp $
+
+inherit gnome2 eutils autotools flag-o-matic
+
+DESCRIPTION="gnome front end to gnupg"
+HOMEPAGE="http://seahorse.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gedit gnome ldap"
+
+RDEPEND=">=gnome-base/libgnomeui-2.0
+ >=gnome-base/gnome-vfs-2.0
+ >=gnome-base/libglade-2.0
+ >=gnome-base/gconf-2.0
+ >=x11-libs/gtk+-2.4
+ >=dev-libs/glib-2.0
+ || ( =app-crypt/gnupg-1.4* >=app-crypt/gnupg-2.0.1-r2 )
+ >=app-crypt/gpgme-1.0.0
+ >=net-libs/libsoup-2.2
+ x11-misc/shared-mime-info
+ gedit? ( >=app-editors/gedit-2.8.0 )
+ gnome? (
+ >=gnome-base/nautilus-2.10
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libbonoboui-2
+ )
+ ldap? ( net-nds/openldap )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.34
+ >=dev-util/pkgconfig-0.19
+ >=app-text/scrollkeeper-0.3"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-update-mime-database \
+ $(use_enable debug) \
+ $(use_enable gedit) \
+ $(use_enable gnome nautilus) \
+ $(use_enable ldap)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch ${FILESDIR}/${PN}-0.8.2-gpg2.0.patch
+}
+
+src_compile() {
+ append-ldflags $(bindnow-flags)
+ gnome2_src_compile
+}
+
+src_install() {
+ gnome2_src_install
+
+ # remove conflicts with x11-misc/shared-mime-info
+ rm -rf ${D}/usr/share/mime/application ${D}/usr/share/mime/magic \
+ ${D}/usr/share/mime/globs ${D}/usr/share/mime/XMLnamespaces
+}