summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-07-08 11:10:52 +0000
committerPacho Ramos <pacho@gentoo.org>2014-07-08 11:10:52 +0000
commitf2a5fb5d671cf6d6e292711460d5d3bf265382bd (patch)
tree3a1e79bb02ea61b829f29a6559654054f2226c52 /app-dicts/gjiten
parentStable for amd64 wrt bug #516660 (diff)
downloadgentoo-2-f2a5fb5d671cf6d6e292711460d5d3bf265382bd.tar.gz
gentoo-2-f2a5fb5d671cf6d6e292711460d5d3bf265382bd.tar.bz2
gentoo-2-f2a5fb5d671cf6d6e292711460d5d3bf265382bd.zip
Use eapi5 and readme.gentoo.eclass
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-dicts/gjiten')
-rw-r--r--app-dicts/gjiten/ChangeLog8
-rw-r--r--app-dicts/gjiten/files/gjiten-2.6-desktop.patch13
-rw-r--r--app-dicts/gjiten/gjiten-2.6-r3.ebuild69
3 files changed, 89 insertions, 1 deletions
diff --git a/app-dicts/gjiten/ChangeLog b/app-dicts/gjiten/ChangeLog
index 336e9315ae17..092fa1492502 100644
--- a/app-dicts/gjiten/ChangeLog
+++ b/app-dicts/gjiten/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-dicts/gjiten
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/gjiten/ChangeLog,v 1.24 2014/07/08 00:41:15 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gjiten/ChangeLog,v 1.25 2014/07/08 11:10:52 pacho Exp $
+
+*gjiten-2.6-r3 (08 Jul 2014)
+
+ 08 Jul 2014; Pacho Ramos <pacho@gentoo.org> +files/gjiten-2.6-desktop.patch,
+ +gjiten-2.6-r3.ebuild:
+ Use eapi5 and readme.gentoo.eclass
08 Jul 2014; Naohiro Aota <naota@gentoo.org>
+files/gjiten-2.6-drop-gnome.patch, gjiten-2.6-r2.ebuild:
diff --git a/app-dicts/gjiten/files/gjiten-2.6-desktop.patch b/app-dicts/gjiten/files/gjiten-2.6-desktop.patch
new file mode 100644
index 000000000000..731d41be9109
--- /dev/null
+++ b/app-dicts/gjiten/files/gjiten-2.6-desktop.patch
@@ -0,0 +1,13 @@
+--- gnome/gjiten.desktop.in.old 2014-07-08 13:04:35.418149539 +0200
++++ gnome/gjiten.desktop.in 2014-07-08 13:04:55.390544064 +0200
+@@ -3,8 +3,8 @@
+ _Name=Gjiten
+ _Comment=Japanese dictionary
+ Exec=gjiten
+-Icon=jiten.png
++Icon=jiten
+ StartupNotify=true
+ Terminal=false
+ Type=Application
+-Categories=GNOME;Application;Utility;
++Categories=GNOME;Utility;
diff --git a/app-dicts/gjiten/gjiten-2.6-r3.ebuild b/app-dicts/gjiten/gjiten-2.6-r3.ebuild
new file mode 100644
index 000000000000..a3c2271f9af0
--- /dev/null
+++ b/app-dicts/gjiten/gjiten-2.6-r3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/gjiten/gjiten-2.6-r3.ebuild,v 1.1 2014/07/08 11:10:52 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2 readme.gentoo
+
+DESCRIPTION="A Japanese dictionary program for Gnome"
+HOMEPAGE="http://gjiten.sourceforge.net/"
+SRC_URI="http://gjiten.sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+RDEPEND="
+ >=gnome-base/libgnome-2.2
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libglade-2
+"
+DEPEND="${RDEPEND}
+ app-text/rarian
+ dev-util/intltool
+ app-text/xmlto
+ app-text/docbook-xml-dtd:4.1.2
+ virtual/pkgconfig
+"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="Dictionary files are necessary in order for
+Gjiten to function.
+
+Download dictionary files from:
+http://ftp.cc.monash.edu.au/pub/nihongo/00INDEX.html#dic_fil
+
+You need kanjidic and edict at a minimum. Dictionary files
+must be converted to UTF-8 format - check the Gjiten help
+and README files for details.
+
+A shell script is available from
+the Gjiten homepage(${HOMEPAGE}) to
+download and convert the dictionary files, but you need
+to put the files in /usr/share/gjiten after running the script."
+
+src_prepare() {
+ DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+ epatch "${FILESDIR}"/${P}-pref.patch
+ epatch "${FILESDIR}"/${P}-drop-gnome.patch
+ epatch "${FILESDIR}"/${P}-desktop.patch
+
+ AM_OPTS="--foreign" eautoreconf
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}