summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-11-21 11:15:44 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-11-21 11:15:44 +0000
commit286489e700b36cb0cd737e8599517820f9ce90b1 (patch)
treee1314b2fb491b076c6b00674ac3078406f88879c /app-dicts/ispell-nl/ispell-nl-1.00.ebuild
parentMarked ~ppc64 (diff)
downloadgentoo-2-286489e700b36cb0cd737e8599517820f9ce90b1.tar.gz
gentoo-2-286489e700b36cb0cd737e8599517820f9ce90b1.tar.bz2
gentoo-2-286489e700b36cb0cd737e8599517820f9ce90b1.zip
Added a new ebuild for ispell-nl which obsoletes the version 1996 which was a mess and problematic with respect to the licensing. Fixes bug 163640. This new version installs a dictionary for the official 2005 spelling.
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-dicts/ispell-nl/ispell-nl-1.00.ebuild')
-rw-r--r--app-dicts/ispell-nl/ispell-nl-1.00.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-dicts/ispell-nl/ispell-nl-1.00.ebuild b/app-dicts/ispell-nl/ispell-nl-1.00.ebuild
new file mode 100644
index 000000000000..e9903b5f3fba
--- /dev/null
+++ b/app-dicts/ispell-nl/ispell-nl-1.00.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/ispell-nl/ispell-nl-1.00.ebuild,v 1.1 2007/11/21 11:15:43 philantrop Exp $
+
+inherit multilib
+
+DESCRIPTION="A dutch (spelling 2005) dictionary for ispell"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+HOMEPAGE="http://opentaal.nl"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-text/ispell"
+
+src_compile() {
+ /usr/bin/buildhash -s "${S}"/words-nl.ispell "${S}"/dutch.aff "${S}"/dutch.hash \
+ || die "buildhash failed"
+}
+
+src_install () {
+ insinto /usr/$(get_libdir)/ispell
+ doins dutch.aff dutch.hash
+}