summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2005-01-13 16:48:48 +0000
committerAlastair Tse <liquidx@gentoo.org>2005-01-13 16:48:48 +0000
commitad930c0a42aa68a5e7ee0dd2bda9716182616b40 (patch)
tree77dd0caa276adade59a914036816b28ebb14baa4 /app-dicts/stardict/stardict-2.4.4.ebuild
parentremoev debugging from stardict (diff)
downloadgentoo-2-ad930c0a42aa68a5e7ee0dd2bda9716182616b40.tar.gz
gentoo-2-ad930c0a42aa68a5e7ee0dd2bda9716182616b40.tar.bz2
gentoo-2-ad930c0a42aa68a5e7ee0dd2bda9716182616b40.zip
version bump (#73584)
Diffstat (limited to 'app-dicts/stardict/stardict-2.4.4.ebuild')
-rw-r--r--app-dicts/stardict/stardict-2.4.4.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-dicts/stardict/stardict-2.4.4.ebuild b/app-dicts/stardict/stardict-2.4.4.ebuild
new file mode 100644
index 000000000000..0991d5981b5d
--- /dev/null
+++ b/app-dicts/stardict/stardict-2.4.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/stardict/stardict-2.4.4.ebuild,v 1.1 2005/01/13 16:48:48 liquidx Exp $
+
+inherit gnome2 eutils
+
+# NOTE: Even though the *.dict.dz are the same as dictd/freedict's files,
+# their indexes seem to be in a different format. So we'll keep them
+# seperate for now.
+
+IUSE=""
+DESCRIPTION="A GNOME2 international dictionary supporting fuzzy and glob style matching"
+HOMEPAGE="http://stardict.sourceforge.net/ http://cosoft.org.cn/projects/stardict/"
+SRC_URI="mirror://sourceforge/stardict/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# when adding keywords, remember to add to stardict.eclass
+KEYWORDS="~x86 ~ppc ~amd64"
+
+
+RDEPEND=">=gnome-base/libbonobo-2.2.0
+ >=gnome-base/libgnome-2.2.0
+ >=gnome-base/libgnomeui-2.2.0
+ >=sys-libs/zlib-1.1.4
+ >=gnome-base/gconf-1.2
+ >=dev-libs/popt-1.7
+ >=gnome-base/orbit-2.6
+ >=x11-libs/gtk+-2
+ app-text/scrollkeeper"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ gnome2_omf_fix
+}
+
+src_install() {
+ gnome2_src_install
+ # dictionary index generation files
+ exeinto /usr/share/stardict/tools
+ doexe ${S}/src/tools/{dictd2dic,directory2dict,olddic2newdic,oxford2dic,pydict2dict,wquick2dict,stardict_dict_update}
+}
+
+pkg_postinst() {
+ einfo "You will now need to install stardict dictionary files. If"
+ einfo "you have not, execute the below to get a list of dictionaries:"
+ einfo " "
+ einfo " emerge -s stardict-"
+ einfo " "
+ ewarn "If you upgraded from 2.4.1 or lower and use your own dictionary"
+ ewarn "files, you'll need to run: /usr/share/stardict/tools/stardict_dict_update"
+}