summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-07-14 10:27:49 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-07-14 10:27:49 +0000
commit741f58ebd3b924a35cafa525111321a2007e7dc2 (patch)
treef438b430aca05bdf71e6fa794496622db356662d /app-doc/doxygen/doxygen-1.3.2.ebuild
parentVersion bump as requested in bug 24292 (diff)
downloadgentoo-2-741f58ebd3b924a35cafa525111321a2007e7dc2.tar.gz
gentoo-2-741f58ebd3b924a35cafa525111321a2007e7dc2.tar.bz2
gentoo-2-741f58ebd3b924a35cafa525111321a2007e7dc2.zip
Version bump as requested in bug 24292
Diffstat (limited to 'app-doc/doxygen/doxygen-1.3.2.ebuild')
-rw-r--r--app-doc/doxygen/doxygen-1.3.2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-doc/doxygen/doxygen-1.3.2.ebuild b/app-doc/doxygen/doxygen-1.3.2.ebuild
new file mode 100644
index 000000000000..3a2a2cd501e3
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.3.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.3.2.ebuild,v 1.1 2003/07/14 10:27:38 phosphan Exp $
+
+IUSE="doc qt"
+
+DESCRIPTION="Doxygen is a documentation system for C++, C, Java, IDL (Corba, Microsoft, and KDE-DCOP flavors) and to some extent PHP and C#."
+HOMEPAGE="http://www.doxygen.org"
+SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+RDEPEND="media-gfx/graphviz
+ doc? ( app-text/tetex )
+ qt? ( x11-libs/qt )"
+
+DEPEND=">=sys-apps/sed-4
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # use CFLAGS and CXXFLAGS
+ sed -i.orig -e "s:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= ${CFLAGS}:" \
+ -e "s:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= ${CXXFLAGS}:" \
+ tmake/lib/linux-g++/tmake.conf
+ # fix doxygen_manual.tex to work with latex-2.x
+ sed -i.orig "s:^\\\setlength\({\\\footrulewidth}\):\\\renewcommand\1:" \
+ doc/doxygen_manual.tex
+ # fix configure to work w/ install from either fileutils or coreutils
+ sed -ie "s/grep fileutils/egrep 'fileutils|coreutils'/" ${S}/configure
+}
+
+src_compile() {
+ # set ./configure options (prefix, Qt based wizard, static)
+ local confopts="--prefix ${D}/usr"
+ use qt && confopts="${confopts} --with-doxywizard"
+ #use static && confopts="${confopts} --static"
+
+ # ./configure and compile
+ ./configure ${confopts} || die '"./configure" failed.'
+ emake all || die '"emake all" failed.'
+
+ # generate html and pdf documents.
+ # errors here are not considered fatal, hence the ewarn message
+ # TeX's font caching in /var/cache/fonts causes sandbox warnings,
+ # so we allow it.
+ if use doc; then
+ addwrite /var/cache/fonts
+ addwrite /usr/share/texmf/fonts/pk
+ addwrite /usr/share/texmf/ls-R
+ make pdf || ewarn '"make docs" failed.'
+ fi
+}
+
+src_install() {
+ make install || die '"make install" failed.'
+
+ dodoc INSTALL LANGUAGE.HOWTO LICENSE README VERSION
+
+ # pdf and html manuals
+ if use doc; then
+ insinto /usr/share/doc/${P}
+ doins latex/doxygen_manual.pdf
+ dohtml -r html/*
+ fi
+}