summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-02-16 20:24:37 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-02-16 20:24:37 +0000
commit00bcba25c424f83baea67c5d94c4f88e7095243f (patch)
tree5d6671b0ea58b2c3875427ffb047b28aaf5ecc7c /app-doc/doxygen/doxygen-1.5.4.ebuild
parentVersion bump (diff)
downloadgentoo-2-00bcba25c424f83baea67c5d94c4f88e7095243f.tar.gz
gentoo-2-00bcba25c424f83baea67c5d94c4f88e7095243f.tar.bz2
gentoo-2-00bcba25c424f83baea67c5d94c4f88e7095243f.zip
updated with patch from bug #210237 and added latest release
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-doc/doxygen/doxygen-1.5.4.ebuild')
-rw-r--r--app-doc/doxygen/doxygen-1.5.4.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-doc/doxygen/doxygen-1.5.4.ebuild b/app-doc/doxygen/doxygen-1.5.4.ebuild
index 34a08d1f3d18..acb7e8d3a9a8 100644
--- a/app-doc/doxygen/doxygen-1.5.4.ebuild
+++ b/app-doc/doxygen/doxygen-1.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.4.ebuild,v 1.10 2008/01/24 20:30:02 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.4.ebuild,v 1.11 2008/02/16 20:24:36 nerdboy Exp $
inherit eutils flag-o-matic toolchain-funcs qt3 fdo-mime
@@ -47,6 +47,13 @@ src_unpack() {
# qtools stuff, and patches for bugs 129142, 121770, and 129560.
epatch "${FILESDIR}/${PN}-1.5-legacy-patches.diff"
+ # remove internal libpng - see bug #210237
+ epatch "${FILESDIR}/${PN}-1.5-system-libpng.patch"
+
+ if [ $(get_libdir) == "lib64" ] ; then
+ epatch "${FILESDIR}/${PN}-1.5-qtlibdir.patch"
+ fi
+
if is-flagq "-O3" ; then
echo
ewarn "Compiling with -O3 is known to produce incorrectly"