summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-03-20 01:39:54 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-03-20 01:39:54 +0000
commit56e43c7879c96466ba5a0754f44acd413fcce292 (patch)
treec00f07a43e1acef3c155eb72cab9eb7132c42052 /app-doc/doxygen/doxygen-1.7.3.ebuild
parentAdding eselect-postgresql-1.0.3.ebuild. Rewrite of module. Should fix bugs (diff)
downloadgentoo-2-56e43c7879c96466ba5a0754f44acd413fcce292.tar.gz
gentoo-2-56e43c7879c96466ba5a0754f44acd413fcce292.tar.bz2
gentoo-2-56e43c7879c96466ba5a0754f44acd413fcce292.zip
Added final kluge to force local LDFLAGS on doxywizard.
(Portage version: 2.1.9.43/cvs/Linux x86_64)
Diffstat (limited to 'app-doc/doxygen/doxygen-1.7.3.ebuild')
-rw-r--r--app-doc/doxygen/doxygen-1.7.3.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-doc/doxygen/doxygen-1.7.3.ebuild b/app-doc/doxygen/doxygen-1.7.3.ebuild
index c6cea9f024ac..1ff2aad4a0ee 100644
--- a/app-doc/doxygen/doxygen-1.7.3.ebuild
+++ b/app-doc/doxygen/doxygen-1.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.7.3.ebuild,v 1.2 2011/03/19 19:56:26 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.7.3.ebuild,v 1.3 2011/03/20 01:39:54 nerdboy Exp $
EAPI=3
@@ -38,7 +38,7 @@ src_prepare() {
sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
-e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
-e 's:^\(TMAKE_LFLAGS_RELEASE\s*\)=.*$:\1= $(ELDFLAGS):' \
- tmake/lib/{{linux,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++}/tmake.conf \
+ tmake/lib/{{linux,gnu,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++,linux-64}/tmake.conf \
|| die "sed 1 failed"
# Ensure we link to -liconv
@@ -107,6 +107,14 @@ src_compile() {
CFLAGS+="${ECFLAGS}" CXXFLAGS+="${ECXXFLAGS}" LFLAGS+="${ELDFLAGS}" \
emake all || die 'emake failed'
+ # force stupid qmake to use LDFLAGS - yes, it's a big kluge...
+ if use qt4 ; then
+ rm -f bin/doxywizard
+ sed -i -e "s|\-Wl,\-O1 |\-Wl,\-O1 ${ELDFLAGS} |" \
+ addon/doxywizard/Makefile.doxywizard
+ make -C addon/doxywizard
+ fi
+
# generate html and pdf (if tetex in use) documents.
# errors here are not considered fatal, hence the ewarn message
# TeX's font caching in /var/cache/fonts causes sandbox warnings,