summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-12-30 17:29:05 +0000
committerDan Armak <danarmak@gentoo.org>2001-12-30 17:29:05 +0000
commitd825149fce1cd84d61053378aeb311d0ebf7e288 (patch)
treeea70f38911e40981b8f0e70cc86478b275cd0d67 /app-doc/qt-docs
parentupdated to latest version (diff)
downloadgentoo-2-d825149fce1cd84d61053378aeb311d0ebf7e288.tar.gz
gentoo-2-d825149fce1cd84d61053378aeb311d0ebf7e288.tar.bz2
gentoo-2-d825149fce1cd84d61053378aeb311d0ebf7e288.zip
new: x11-libs/qt-3.0.1 ebuild; app-doc/qt-docs 2.3.1 and 3.0.1 ebuilds.
also a few fixes for misc stuff.
Diffstat (limited to 'app-doc/qt-docs')
-rw-r--r--app-doc/qt-docs/files/45qt-docs31
-rw-r--r--app-doc/qt-docs/files/50qt-docs21
-rw-r--r--app-doc/qt-docs/files/digest-qt-docs-2.3.11
-rw-r--r--app-doc/qt-docs/files/digest-qt-docs-3.0.11
-rw-r--r--app-doc/qt-docs/qt-docs-2.3.1.ebuild89
-rw-r--r--app-doc/qt-docs/qt-docs-3.0.1.ebuild91
6 files changed, 184 insertions, 0 deletions
diff --git a/app-doc/qt-docs/files/45qt-docs3 b/app-doc/qt-docs/files/45qt-docs3
new file mode 100644
index 000000000000..d4ae10decfa6
--- /dev/null
+++ b/app-doc/qt-docs/files/45qt-docs3
@@ -0,0 +1 @@
+MANPATH=/usr/qt/3/man
diff --git a/app-doc/qt-docs/files/50qt-docs2 b/app-doc/qt-docs/files/50qt-docs2
new file mode 100644
index 000000000000..c6456a35cbca
--- /dev/null
+++ b/app-doc/qt-docs/files/50qt-docs2
@@ -0,0 +1 @@
+MANPATH=/usr/qt/2/man
diff --git a/app-doc/qt-docs/files/digest-qt-docs-2.3.1 b/app-doc/qt-docs/files/digest-qt-docs-2.3.1
new file mode 100644
index 000000000000..90a2d69a7095
--- /dev/null
+++ b/app-doc/qt-docs/files/digest-qt-docs-2.3.1
@@ -0,0 +1 @@
+MD5 358d6dfbcbdc353b65b5236866b0f3a7 qt-x11-2.3.1.tar.gz 8970240
diff --git a/app-doc/qt-docs/files/digest-qt-docs-3.0.1 b/app-doc/qt-docs/files/digest-qt-docs-3.0.1
new file mode 100644
index 000000000000..6b90fbad670c
--- /dev/null
+++ b/app-doc/qt-docs/files/digest-qt-docs-3.0.1
@@ -0,0 +1 @@
+MD5 cf9afb61d08396c7ca9a290fc7567e92 qt-x11-free-3.0.1.tar.gz 17821696
diff --git a/app-doc/qt-docs/qt-docs-2.3.1.ebuild b/app-doc/qt-docs/qt-docs-2.3.1.ebuild
new file mode 100644
index 000000000000..6d4e889fceeb
--- /dev/null
+++ b/app-doc/qt-docs/qt-docs-2.3.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Philippe Namias <pnamias@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-doc/qt-docs/qt-docs-2.3.1.ebuild,v 1.1 2001/12/30 17:29:05 danarmak Exp $
+
+S=${WORKDIR}/qt-${PV}
+DESCRIPTION="QT ${PV} docs, manpages, examples and tutorials"
+SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-${PV}.tar.gz"
+HOMEPAGE="http://www.trolltech.com/"
+
+RDEPEND=">=x11-libs/qt-$PV"
+
+DEPEND="$RDEPEND
+ sys-devel/gcc"
+
+export QTDIR=${S}
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
+
+ cd ${S}/configs
+ cp linux-g++-shared linux-g++-shared.orig
+ sed -e "s/SYSCONF_CXXFLAGS /SYSCONF_CXXFLAGS = ${CXXFLAGS} \#/" \
+ -e "s/SYSCONF_CFLAGS /SYSCONF_CFLAGS = ${CFLAGS} \#/" \
+ linux-g++-shared.orig > linux-g++-shared || die
+
+}
+
+src_compile() {
+
+ export LDFLAGS="$LDFLAGS -ldl"
+ local myconf
+
+ use opengl || myconf="$myconf -no-opengl"
+ use nas && myconf="${myconf} -system-nas-sound" || myconf="${myconf} -no-nas-sound"
+ use gif && myconf="${myconf} -gif"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release"
+
+ ./configure -sm -thread -system-zlib -system-jpeg ${myconf} \
+ -system-libmng -system-libpng -gif -platform linux-g++ \
+ -ldl -lpthread -no-g++-exceptions || die
+
+ # use already built x11-libs/qt
+ export QTDIR=/usr/qt/2
+
+ cd ${S}/tutorial
+ make || die
+ cd ${S}/examples
+ make || die
+
+}
+
+src_install() {
+
+ QTBASE=/usr/qt/2
+ cd ${S}
+
+ # docs
+ cd ${S}
+ dodoc ANNOUNCE README* INSTALL FAQ LICENSE* PLATFORMS PORTING
+
+ # html docs
+ dodir $QTBASE/doc
+ cp -r ${S}/doc/html $D/$QTBASE/doc
+
+ # manpages
+ dodir $QTBASE/man
+ cp -r ${S}/doc/man $D/$QTBASE
+
+ # examples
+ cp -r ${S}/examples $D/$QTBASE
+
+ # tutorials
+ cp -r ${S}/tutorial $D/$QTBASE
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/50qt-docs2
+
+}
+
+
+
+
diff --git a/app-doc/qt-docs/qt-docs-3.0.1.ebuild b/app-doc/qt-docs/qt-docs-3.0.1.ebuild
new file mode 100644
index 000000000000..7ae630ea6a06
--- /dev/null
+++ b/app-doc/qt-docs/qt-docs-3.0.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-doc/qt-docs/qt-docs-3.0.1.ebuild,v 1.1 2001/12/30 17:29:05 danarmak Exp $
+
+P=qt-x11-${PV}
+S=${WORKDIR}/qt-x11-free-${PV}
+
+DESCRIPTION="QT version ${PV}"
+
+SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-free-${PV}.tar.gz"
+HOMEPAGE="http://www.trolltech.com/"
+
+DEPEND=">=x11-libs/qt-$PV"
+
+RDEPEND="$DEPEND sys-devel/gcc"
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s:read acceptance:acceptance=yes:" configure.orig > configure
+
+ cd ${S}
+ mv tools/assistant/helpdialogimpl.cpp tools/assistant/helpdialogimpl.cpp_orig
+ sed -e 's:"/doc/html:"/share/doc/html:g' \
+ tools/assistant/helpdialogimpl.cpp_orig > tools/assistant/helpdialogimpl.cpp
+ mv tools/assistant/mainwindow.ui.h tools/assistant/mainwindow.ui.h_orig
+ sed -e 's:"/doc/html:"/share/doc/html:g' \
+ tools/assistant/mainwindow.ui.h_orig > tools/assistant/mainwindow.ui.h
+
+}
+
+src_compile() {
+
+ export LDFLAGS="-ldl"
+
+ use nas && myconf="${myconf} -system-nas-sound"
+ use gif && myconf="${myconf} -qt-gif"
+ use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
+ use odbc && myconf="${myconf} -plugin-sql-odbc"
+ [ -n "$DEBUG" ] && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
+
+ ./configure -sm -thread -stl -system-zlib -system-libjpeg ${myconf} \
+ -system-libmng -system-libpng -ldl -lpthread || die
+
+ # use already built qt
+ export QTDIR=/usr/qt/3
+
+ # what's with the make doc target? it wants an executable qdoc in the path, and I haven't
+ # been able to find it. FIXME!
+ #cd ${S}
+ #make doc || die
+ cd ${S}/tutorial
+ make || die
+ cd ${S}/examples
+ make || die
+
+}
+
+src_install() {
+
+ cd ${S}
+
+ # misc
+ insinto /etc/env.d
+ doins ${FILESDIR}/45qt-docs3
+
+ # docs
+ cd ${S}/doc
+ dodir ${QTBASE}/doc
+ for x in html flyers; do
+ cp -r $x ${D}/${QTBASE}/doc
+ done
+
+ # manpages
+ cp -r ${S}/doc/man ${D}/${QTBASE}
+
+ # examples
+ cp -r ${S}/examples ${D}/${QTBASE}
+
+ # tutorials
+ cp -r ${S}/tutorial ${D}/${QTBASE}
+
+}
+
+