summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2006-07-03 01:26:31 +0000
committerSteve Arnold <nerdboy@gentoo.org>2006-07-03 01:26:31 +0000
commitaeb9f13a65ee05eaaf9bc19f6b1764c02093a282 (patch)
tree8ed600a7bf51b7c084aed1bcaf70f56541e021ef /app-doc
parentblock on seamonkey (diff)
downloadgentoo-2-aeb9f13a65ee05eaaf9bc19f6b1764c02093a282.tar.gz
gentoo-2-aeb9f13a65ee05eaaf9bc19f6b1764c02093a282.tar.bz2
gentoo-2-aeb9f13a65ee05eaaf9bc19f6b1764c02093a282.zip
version bump for bug 137283, need arch testing
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/ChangeLog11
-rw-r--r--app-doc/doxygen/doxygen-1.4.7.ebuild109
-rw-r--r--app-doc/doxygen/files/1.4.7/01_all_cp1251.patch35
-rw-r--r--app-doc/doxygen/files/1.4.7/05_all_system-libpng.patch124
-rw-r--r--app-doc/doxygen/files/1.4.7/06_all_qtools.patch44
-rw-r--r--app-doc/doxygen/files/digest-doxygen-1.4.73
6 files changed, 325 insertions, 1 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index 8f32949ce0e0..5c4c6bff7944 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-doc/doxygen
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.100 2006/06/24 01:44:20 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.101 2006/07/03 01:26:31 nerdboy Exp $
+
+*doxygen-1.4.7 (03 Jul 2006)
+
+ 03 Jul 2006; Steve Arnold <nerdboy@gentoo.org>
+ +files/1.4.7/01_all_cp1251.patch, +files/1.4.7/05_all_system-libpng.patch,
+ +files/1.4.7/06_all_qtools.patch, +doxygen-1.4.7.ebuild:
+ Version bump for bug #137283, need arch testing and graphviz answers (see
+ bug #134575) before package cleanup can occur. Filed bug #138937 on the
+ doxygen stablization issue.
24 Jun 2006; Doug Goldstein <cardoe@gentoo.org> doxygen-1.4.2.ebuild,
doxygen-1.4.3-r1.ebuild, doxygen-1.4.4.ebuild, doxygen-1.4.5.ebuild,
diff --git a/app-doc/doxygen/doxygen-1.4.7.ebuild b/app-doc/doxygen/doxygen-1.4.7.ebuild
new file mode 100644
index 000000000000..14bcf4814a4c
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.4.7.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.7.ebuild,v 1.1 2006/07/03 01:26:31 nerdboy Exp $
+
+inherit eutils toolchain-funcs qt3
+
+DESCRIPTION="Doxygen is a documentation system for C++, C, Java, Objective-C,
+ Python, IDL , and other C-like languages."
+HOMEPAGE="http://www.doxygen.org/"
+SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+# unicode? ( mirror://gentoo/${PN}-utf8-ru.patch.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc qt3 tetex"
+
+RDEPEND=">=media-gfx/graphviz-2.6
+ qt? ( $(qt_min_version 3.3) )
+ tetex? ( virtual/tetex )
+ virtual/ghostscript"
+DEPEND=">=sys-apps/sed-4
+ ${RDEPEND}"
+
+EPATCH_SUFFIX="patch"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # use CFLAGS, CXXFLAGS, LDFLAGS
+ sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
+ -e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
+ -e 's:^\(TMAKE_LFLAGS_RELEASE\s*\)=.*$:\1= $(ELDFLAGS):' \
+ tmake/lib/{{linux,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++}/tmake.conf
+
+ # Consolidate patches, apply FreeBSD configure patch, codepage patch,
+ # qtools stuff, and patches for bugs 129142, 121770, and 129560.
+ epatch ${FILESDIR}/${PV}
+}
+
+src_compile() {
+ export ECFLAGS="${CFLAGS}" ECXXFLAGS="${CXXFLAGS}" ELDFLAGS="${LDFLAGS}"
+ # set ./configure options (prefix, Qt based wizard, docdir)
+ local my_conf="--prefix ${D}usr"
+ if use qt; then
+ einfo "using QTDIR: '$QTDIR'."
+ export LD_LIBRARY_PATH=${QTDIR}/$(get_libdir):${LD_LIBRARY_PATH}
+ export LIBRARY_PATH=${QTDIR}/$(get_libdir):${LIBRARY_PATH}
+ einfo "using QT LIBRARY_PATH: '$LIBRARY_PATH'."
+ einfo "using QT LD_LIBRARY_PATH: '$LD_LIBRARY_PATH'."
+ ./configure ${my_conf} $(use_with qt doxywizard) || die 'configure failed'
+ else
+ ./configure ${my_conf} || die 'configure failed'
+ fi
+
+ # and compile
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
+ LINK_SHLIB="$(tc-getCXX)" all || die 'emake failed'
+
+ # generate html and pdf (if tetex in use) documents.
+ # errors here are not considered fatal, hence the ewarn message
+ # TeX's font caching in /var/cache/fonts causes sandbox warnings,
+ # so we allow it.
+ if use doc; then
+ if use tetex; then
+ addwrite /var/cache/fonts
+ addwrite /usr/share/texmf/fonts/pk
+ addwrite /usr/share/texmf/ls-R
+ make pdf || ewarn '"make pdf docs" failed.'
+ else
+ cp doc/Doxyfile doc/Doxyfile.orig
+ cp doc/Makefile doc/Makefile.orig
+ sed -i.orig -e "s/GENERATE_LATEX = YES/GENERATE_LATEX = NO/" doc/Doxyfile
+ sed -i.orig -e "s/@epstopdf/# @epstopdf/" \
+ -e "s/@cp Makefile.latex/# @cp Makefile.latex/" \
+ -e "s/@sed/# @sed/" doc/Makefile
+ make docs || ewarn '"make html docs" failed.'
+ fi
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} MAN1DIR=share/man/man1 \
+ install || die '"make install" failed.'
+
+ dodoc INSTALL LANGUAGE.HOWTO README
+
+ # pdf and html manuals
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ if use tetex; then
+ doins latex/doxygen_manual.pdf
+ fi
+ dohtml -r html/*
+ fi
+}
+
+pkg_postinst() {
+
+ ewarn
+ einfo "The USE flags qt, doc, and tetex will enable doxywizard, or"
+ einfo "the html and pdf documentation, respectively. For examples"
+ einfo "and other goodies, see the source tarball. For some example"
+ einfo "output, run doxygen on the doxygen source using the Doxyfile"
+ einfo "provided in the top-level source dir."
+ einfo ""
+ einfo "See the Doxygen homepage for additional language support tools."
+ ewarn
+}
diff --git a/app-doc/doxygen/files/1.4.7/01_all_cp1251.patch b/app-doc/doxygen/files/1.4.7/01_all_cp1251.patch
new file mode 100644
index 000000000000..0ffed14733e1
--- /dev/null
+++ b/app-doc/doxygen/files/1.4.7/01_all_cp1251.patch
@@ -0,0 +1,35 @@
+--- qtools/qtextcodec.cpp.orig 2003-12-14 14:00:57.000000000 -0800
++++ qtools/qtextcodec.cpp 2005-05-29 19:13:17.000000000 -0700
+@@ -1321,7 +1321,7 @@
+
+
+
+-#ifndef QT_NO_CODECS
++// #ifndef QT_NO_CODECS
+
+ class QSimpleTextCodec: public QTextCodec
+ {
+@@ -1948,7 +1948,7 @@
+ }
+
+
+-#endif // QT_NO_CODECS
++// #endif // QT_NO_CODECS
+
+ class QLatin1Codec: public QTextCodec
+ {
+@@ -2048,12 +2048,13 @@
+ {
+ (void)new QLatin1Codec;
+
+-#ifndef QT_NO_CODECS
++
+ int i = 0;
+ do {
+ (void)new QSimpleTextCodec( i );
+ } while( unicodevalues[i++].mib != LAST_MIB );
+
++#ifndef QT_NO_CODECS
+ (void)new QEucJpCodec;
+ (void)new QSjisCodec;
+ (void)new QJisCodec;
diff --git a/app-doc/doxygen/files/1.4.7/05_all_system-libpng.patch b/app-doc/doxygen/files/1.4.7/05_all_system-libpng.patch
new file mode 100644
index 000000000000..491e3a22a801
--- /dev/null
+++ b/app-doc/doxygen/files/1.4.7/05_all_system-libpng.patch
@@ -0,0 +1,124 @@
+--- doxygen-1.4.6.orig/debian/patches/system-libpng.dpatch
++++ doxygen-1.4.6/debian/patches/system-libpng.dpatch
+@@ -0,0 +1,121 @@
++#! /bin/sh -e
++
++# DP: Use the system libpng library
++
++dir=
++if [ $# -eq 3 -a "$2" = '-d' ]; then
++ pdir="-d $3"
++ dir="$3/"
++elif [ $# -ne 1 ]; then
++ echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
++ exit 1
++fi
++case "$1" in
++ -patch)
++ patch $pdir -f --no-backup-if-mismatch -p1 < $0
++ ;;
++ -unpatch)
++ patch $pdir -f --no-backup-if-mismatch -R -p1 < $0
++ ;;
++ *)
++ echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
++ exit 1
++esac
++exit 0
++
++diff -u ./src/pngenc.cpp.orig ./src/pngenc.cpp
++--- ./src/pngenc.cpp.orig 2004-01-06 04:40:25.000000000 +0100
+++++ ./src/pngenc.cpp 2004-09-21 09:04:40.000000000 +0200
++@@ -25,7 +25,7 @@
++ #endif
++
++ #define ALL_STATIC
++-#include <../libpng/png.h>
+++#include <png.h>
++ #include <stdio.h>
++ #include <stdlib.h>
++ #include <string.h>
++diff -u ./Makefile.in.orig ./Makefile.in
++--- ./Makefile.in.orig 2003-11-13 04:40:21.000000000 +0100
+++++ ./Makefile.in 2004-09-21 09:04:40.000000000 +0200
++@@ -7,7 +7,6 @@
++ cd doc ; $(MAKE) clean
++ cd qtools ; $(MAKE) clean
++ cd src ; $(MAKE) clean
++- cd libpng ; $(MAKE) clean
++ cd libmd5 ; $(MAKE) clean
++ cd addon/doxywizard ; $(MAKE) clean
++ cd addon/doxmlparser/src ; $(MAKE) clean
++@@ -18,7 +17,6 @@
++
++ distclean: clean
++ cd src ; $(MAKE) distclean
++- cd libpng ; $(MAKE) distclean
++ cd libmd5 ; $(MAKE) distclean
++ cd addon/doxywizard ; $(MAKE) distclean
++ cd addon/doxmlparser/src ; $(MAKE) distclean
++@@ -31,11 +29,10 @@
++ -rm -f objects/*.o
++ -rm -f src/Makefile.doxygen src/Makefile.libdoxygen
++ -rm -f src/Makefile.doxytag src/Makefile.libdoxycfg
++- -rm -f libpng/Makefile.libpng
++ -rm -f libmd5/Makefile.libmd5
++ -rm -f Makefile qtools/Makefile src/Makefile examples/Makefile doc/Makefile
++ -rm -f .makeconfig .tmakeconfig
++- -rm -f src/doxygen.pro src/libdoxygen.pro src/doxytag.pro qtools/qtools.pro src/libdoxycfg.pro libpng/libpng.pro libmd5/libmd5.pro
+++ -rm -f src/doxygen.pro src/libdoxygen.pro src/doxytag.pro qtools/qtools.pro src/libdoxycfg.pro libmd5/libmd5.pro
++ -rm -f src/version.cpp
++ -rm -r addon/doxywizard/Makefile
++ -rm -f addon/doxywizard/Makefile.doxywizard
++diff -u ./configure.orig ./configure
++--- ./configure.orig 2004-09-14 04:40:12.000000000 +0200
+++++ ./configure 2004-09-21 09:09:06.000000000 +0200
++@@ -457,7 +457,7 @@
++ EOF
++ fi
++
++-f_inmakefiles="Makefile.in qtools/Makefile.in src/Makefile.in examples/Makefile.in doc/Makefile.in addon/doxywizard/Makefile.in addon/doxmlparser/src/Makefile.in addon/doxmlparser/test/Makefile.in addon/doxmlparser/examples/metrics/Makefile.in libpng/Makefile.in libmd5/Makefile.in"
+++f_inmakefiles="Makefile.in qtools/Makefile.in src/Makefile.in examples/Makefile.in doc/Makefile.in addon/doxywizard/Makefile.in addon/doxmlparser/src/Makefile.in addon/doxmlparser/test/Makefile.in addon/doxmlparser/examples/metrics/Makefile.in libmd5/Makefile.in"
++
++ for i in $f_inmakefiles ; do
++ SRC=$i
++@@ -474,7 +474,6 @@
++ echo "" >> $DST
++ echo "all: src/version.cpp " >> $DST
++ echo " \$(MAKE) -C qtools" >> $DST
++- echo " \$(MAKE) -C libpng" >> $DST
++ echo " \$(MAKE) -C libmd5" >> $DST
++ echo " \$(MAKE) -C src" >> $DST
++ if test $f_wizard = YES; then
++@@ -491,7 +490,7 @@
++ echo " Created $DST from $SRC..."
++ done
++
++-f_inprofiles="qtools/qtools.pro.in src/libdoxygen.pro.in src/libdoxycfg.pro.in src/doxygen.pro.in src/doxytag.pro.in addon/doxywizard/doxywizard.pro.in addon/doxmlparser/src/doxmlparser.pro.in addon/doxmlparser/test/xmlparse.pro.in addon/doxmlparser/examples/metrics/metrics.pro.in libpng/libpng.pro.in libmd5/libmd5.pro.in"
+++f_inprofiles="qtools/qtools.pro.in src/libdoxygen.pro.in src/libdoxycfg.pro.in src/doxygen.pro.in src/doxytag.pro.in addon/doxywizard/doxywizard.pro.in addon/doxmlparser/src/doxmlparser.pro.in addon/doxmlparser/test/xmlparse.pro.in addon/doxmlparser/examples/metrics/metrics.pro.in libmd5/libmd5.pro.in"
++
++ for i in $f_inprofiles ; do
++ SRC=$i
++diff -u ./src/doxygen.pro.in.orig ./src/doxygen.pro.in
++--- ./src/doxygen.pro.in.orig 2004-05-18 04:40:13.000000000 +0200
+++++ ./src/doxygen.pro.in 2004-09-21 09:58:06.000000000 +0200
++@@ -28,7 +28,7 @@
++ win32:TMAKE_CXXFLAGS += -DQT_NODLL
++ win32-g++:LIBS = -L../lib -ldoxygen -ldoxycfg -lqtools -lpng -lmd5
++ win32-g++:TMAKE_CXXFLAGS += -fno-exceptions -fno-rtti
++-INCLUDEPATH += ../qtools ../libpng ../libmd5 .
+++INCLUDEPATH += ../qtools ../libmd5 .
++ #win32-g++:INCLUDEPATH -= ../libpng
++ DESTDIR = ../bin
++ TARGET = doxygen
++diff -u ./src/libdoxygen.pro.in.orig ./src/libdoxygen.pro.in
++--- ./src/libdoxygen.pro.in.orig 2004-08-25 04:40:18.000000000 +0200
+++++ ./src/libdoxygen.pro.in 2004-09-21 09:58:55.000000000 +0200
++@@ -189,7 +189,6 @@
++ win32-msvc:TMAKE_CXXFLAGS += -Zm200
++ win32-g++:TMAKE_CXXFLAGS += -fno-exceptions -fno-rtti
++ INCLUDEPATH += ../qtools
++-INCLUDEPATH += ../libpng
++ INCLUDEPATH += ../libmd5
++ win32:INCLUDEPATH += .
++ win32-g++:INCLUDEPATH = ../qtools /usr/include/libpng12 ../libmd5
diff --git a/app-doc/doxygen/files/1.4.7/06_all_qtools.patch b/app-doc/doxygen/files/1.4.7/06_all_qtools.patch
new file mode 100644
index 000000000000..38a4fcbf000e
--- /dev/null
+++ b/app-doc/doxygen/files/1.4.7/06_all_qtools.patch
@@ -0,0 +1,44 @@
+--- doxygen-1.4.6.orig/debian/patches/qstring-gcc40.dpatch
++++ doxygen-1.4.6/debian/patches/qstring-gcc40.dpatch
+@@ -0,0 +1,41 @@
++#! /bin/sh -e
++
++# DP: Remove unused code that does not build with gcc 4.0 (#338099).
++
++dir=
++if [ $# -eq 3 -a "$2" = '-d' ]; then
++ pdir="-d $3"
++ dir="$3/"
++elif [ $# -ne 1 ]; then
++ echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
++ exit 1
++fi
++case "$1" in
++ -patch)
++ patch $pdir -f --no-backup-if-mismatch -p0 < $0
++ ;;
++ -unpatch)
++ patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
++ ;;
++ *)
++ echo >&2 "usage: `basename $0`: -patch|-unpatch [-d <srcdir>]"
++ exit 1
++esac
++exit 0
++
++--- qtools/qstring.h.orig 2004-12-01 19:26:16.000000000 +0000
+++++ qtools/qstring.h 2005-12-04 20:09:01.000000000 +0000
++@@ -163,8 +163,13 @@
++ bool isLetterOrNumber() const;
++ bool isDigit() const;
++
+++ // the non-const ::cell and ::row cannot be compiled with gcc 4.0 on ARM,
+++ // so they have been removed; the methods are not needed for doxygen
+++#if 0
++ uchar& cell() { return cl; }
++ uchar& row() { return rw; }
+++#endif
+++
++ uchar cell() const { return cl; }
++ uchar row() const { return rw; }
++
diff --git a/app-doc/doxygen/files/digest-doxygen-1.4.7 b/app-doc/doxygen/files/digest-doxygen-1.4.7
new file mode 100644
index 000000000000..c62d1675acad
--- /dev/null
+++ b/app-doc/doxygen/files/digest-doxygen-1.4.7
@@ -0,0 +1,3 @@
+MD5 11db63a72bd3b510fd2fa7ae48086979 doxygen-1.4.7.src.tar.gz 2928354
+RMD160 4de02b866cef53a7fd6f54e0ba90111814a9d77a doxygen-1.4.7.src.tar.gz 2928354
+SHA256 5db0e9ddf6fe74273096419d53d3835e9f1822581f20f5f20c057500a5e512ed doxygen-1.4.7.src.tar.gz 2928354