summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-01-21 06:41:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-01-21 06:41:28 +0000
commitda0bfb186f4e2474e8fe67c40748407f1fec0058 (patch)
tree87f5e1e3a9f5c33856ee3fe8d2c1f06412213fb7 /app-doc
parentRevision bump to avoid file collision with >=kde-base/katepart-4.12.0 wrt bug... (diff)
downloadgentoo-2-da0bfb186f4e2474e8fe67c40748407f1fec0058.tar.gz
gentoo-2-da0bfb186f4e2474e8fe67c40748407f1fec0058.tar.bz2
gentoo-2-da0bfb186f4e2474e8fe67c40748407f1fec0058.zip
Remove old EAPI1 ebuilds
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/doxygen/ChangeLog8
-rw-r--r--app-doc/doxygen/doxygen-1.4.7.ebuild120
-rw-r--r--app-doc/doxygen/doxygen-1.5.4.ebuild155
3 files changed, 6 insertions, 277 deletions
diff --git a/app-doc/doxygen/ChangeLog b/app-doc/doxygen/ChangeLog
index 8b918eea9653..e04d863e3aed 100644
--- a/app-doc/doxygen/ChangeLog
+++ b/app-doc/doxygen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-doc/doxygen
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.258 2013/12/27 22:00:10 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/ChangeLog,v 1.259 2014/01/21 06:41:28 patrick Exp $
+
+ 21 Jan 2014; Patrick Lauer <patrick@gentoo.org> -doxygen-1.4.7.ebuild,
+ -doxygen-1.5.4.ebuild:
+ Remove old EAPI1 ebuilds
27 Dec 2013; Tom Wijsman <TomWij@gentoo.org> -files/doxygen-1.5-dot-eps.patch:
[QA] Remove unused files.
diff --git a/app-doc/doxygen/doxygen-1.4.7.ebuild b/app-doc/doxygen/doxygen-1.4.7.ebuild
deleted file mode 100644
index a990f06c22c7..000000000000
--- a/app-doc/doxygen/doxygen-1.4.7.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.7.ebuild,v 1.32 2012/05/08 10:27:47 xarthisius Exp $
-
-EAPI=1
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="documentation system for C++, C, Java, Objective-C, Python, IDL, and other languages"
-HOMEPAGE="http://www.doxygen.org/"
-SRC_URI="http://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz
- http://dev.gentoo.org/~xarthisius/distfiles/doxywizard.png
- unicode? ( mirror://gentoo/${P}-utf8-ru.patch.gz )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="doc latex unicode"
-
-RDEPEND=">=media-gfx/graphviz-2.6
- latex? ( app-text/texlive-core
- dev-texlive/texlive-latexrecommended
- dev-texlive/texlive-genericrecommended
- dev-texlive/texlive-fontsrecommended )
- app-text/ghostscript-gpl"
-DEPEND=">=sys-apps/sed-4
- ${RDEPEND}"
-
-EPATCH_SUFFIX="patch"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # still needs patch for Russian text in source files (see bug #112076)
- if use unicode; then
- epatch "${WORKDIR}/${P}-utf8-ru.patch" || die "utf8-ru patch failed"
- fi
-
- # use CFLAGS, CXXFLAGS, LDFLAGS
- sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
- -e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
- -e 's:^\(TMAKE_LFLAGS_RELEASE\s*\)=.*$:\1= $(ELDFLAGS):' \
- tmake/lib/{{linux,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++}/tmake.conf
-
- # Consolidate patches, apply FreeBSD configure patch, codepage patch,
- # qtools stuff, and patches for bugs 129142, 121770, and 129560.
- epatch "${FILESDIR}/${PV}"
-
- if is-flagq "-O3" ; then
- echo
- ewarn "Compiling with -O3 is known to produce incorrectly"
- ewarn "optimized code which breaks doxygen."
- echo
- epause 6
- elog "Continuing with -O2 instead ..."
- echo
- replace-flags "-O3" "-O2"
- fi
-}
-
-src_compile() {
- export ECFLAGS="${CFLAGS}" ECXXFLAGS="${CXXFLAGS}" ELDFLAGS="${LDFLAGS}"
- # set ./configure options (prefix, Qt based wizard, docdir)
- local my_conf="--prefix ${D}usr"
- ./configure ${my_conf} || die 'configure failed'
-
- # and compile
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
- LINK_SHLIB="$(tc-getCXX)" all || die 'emake failed'
-
- # generate html and pdf (if tetex in use) documents.
- # errors here are not considered fatal, hence the ewarn message
- # TeX's font caching in /var/cache/fonts causes sandbox warnings,
- # so we allow it.
- if use doc; then
- if use tetex; then
- addwrite /var/cache/fonts
- addwrite /usr/share/texmf/fonts/pk
- addwrite /usr/share/texmf/ls-R
- make pdf || ewarn '"make pdf docs" failed.'
- else
- cp doc/Doxyfile doc/Doxyfile.orig
- cp doc/Makefile doc/Makefile.orig
- sed -i.orig -e "s/GENERATE_LATEX = YES/GENERATE_LATEX = NO/" doc/Doxyfile
- sed -i.orig -e "s/@epstopdf/# @epstopdf/" \
- -e "s/@cp Makefile.latex/# @cp Makefile.latex/" \
- -e "s/@sed/# @sed/" doc/Makefile
- make docs || ewarn '"make html docs" failed.'
- fi
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" MAN1DIR=share/man/man1 \
- install || die '"make install" failed.'
-
- dodoc INSTALL LANGUAGE.HOWTO README
-
- # pdf and html manuals
- if use doc; then
- insinto /usr/share/doc/${PF}
- if use tetex; then
- doins latex/doxygen_manual.pdf
- fi
- dohtml -r html/*
- fi
-}
-
-pkg_postinst() {
- elog
- elog "The USE flags doc, and tetex will enable "
- elog "the html and pdf documentation, respectively. For examples"
- elog "and other goodies, see the source tarball. For some example"
- elog "output, run doxygen on the doxygen source using the Doxyfile"
- elog "provided in the top-level source dir."
- elog
- elog "See the Doxygen homepage for additional language support tools."
- elog
-}
diff --git a/app-doc/doxygen/doxygen-1.5.4.ebuild b/app-doc/doxygen/doxygen-1.5.4.ebuild
deleted file mode 100644
index 7d8881e47516..000000000000
--- a/app-doc/doxygen/doxygen-1.5.4.ebuild
+++ /dev/null
@@ -1,155 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.5.4.ebuild,v 1.24 2012/05/31 03:38:35 zmedico Exp $
-
-EAPI=1
-
-inherit eutils flag-o-matic multilib toolchain-funcs fdo-mime
-
-DESCRIPTION="documentation system for C++, C, Java, Objective-C, Python, IDL, and other languages"
-HOMEPAGE="http://www.doxygen.org/"
-SRC_URI="http://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz
- http://dev.gentoo.org/~xarthisius/distfiles/doxywizard.png"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="debug doc nodot latex elibc_FreeBSD"
-
-RDEPEND="latex? ( app-text/texlive-core
- dev-texlive/texlive-latexrecommended
- dev-texlive/texlive-genericrecommended
- dev-texlive/texlive-fontsrecommended
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-latexextra )
- dev-lang/python
- virtual/libiconv
- app-text/ghostscript-gpl
- !nodot? ( >=media-gfx/graphviz-2.6
- media-libs/freetype )"
-DEPEND=">=sys-apps/sed-4
- ${RDEPEND}"
-
-EPATCH_SUFFIX="patch"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # use CFLAGS, CXXFLAGS, LDFLAGS
- sed -i.orig -e 's:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= $(ECFLAGS):' \
- -e 's:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= $(ECXXFLAGS):' \
- -e 's:^\(TMAKE_LFLAGS_RELEASE\s*\)=.*$:\1= $(ELDFLAGS):' \
- tmake/lib/{{linux,freebsd,netbsd,openbsd,solaris}-g++,macosx-c++}/tmake.conf \
- || die "sed failed"
-
- # Ensure we link to -liconv
- if use elibc_FreeBSD; then
- for pro in */*.pro.in */*/*.pro.in; do
- echo "unix:LIBS += -liconv" >> "${pro}"
- done
- fi
-
- # Consolidate patches, apply FreeBSD configure patch, codepage patch,
- # qtools stuff, and patches for bugs 129142, 121770, and 129560.
- epatch "${FILESDIR}/${PN}-1.5-legacy-patches.diff"
-
- # remove internal libpng - see bug #210237
- epatch "${FILESDIR}/${PN}-1.5-system-libpng.patch"
-
- if [ $(get_libdir) == "lib64" ] ; then
- epatch "${FILESDIR}/${PN}-1.5-qtlibdir.patch"
- fi
-
- if is-flagq "-O3" ; then
- echo
- ewarn "Compiling with -O3 is known to produce incorrectly"
- ewarn "optimized code which breaks doxygen."
- echo
- epause 6
- elog "Continuing with -O2 instead ..."
- echo
- replace-flags "-O3" "-O2"
- fi
-}
-
-src_compile() {
- export ECFLAGS="${CFLAGS}" ECXXFLAGS="${CXXFLAGS}" ELDFLAGS="${LDFLAGS}"
- # set ./configure options (prefix, Qt based wizard, docdir)
-
- if use debug; then
- local my_conf="--prefix ${D}usr --debug"
- else
- local my_conf="--prefix ${D}usr"
- fi
-
- ./configure ${my_conf} || die 'configure failed'
-
- # and compile
- emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" LINK="$(tc-getCXX)" \
- LINK_SHLIB="$(tc-getCXX)" all || die 'emake failed'
-
- # generate html and pdf (if tetex in use) documents.
- # errors here are not considered fatal, hence the ewarn message
- # TeX's font caching in /var/cache/fonts causes sandbox warnings,
- # so we allow it.
- if use doc; then
- if use nodot; then
- sed -i -e "s/HAVE_DOT = YES/HAVE_DOT = NO/" \
- {Doxyfile,doc/Doxyfile} || ewarn "disabling dot failed"
- fi
- if use latex; then
- addwrite /var/cache/fonts
- addwrite /var/cache/fontconfig
- addwrite /usr/share/texmf/fonts/pk
- addwrite /usr/share/texmf/ls-R
- make pdf || ewarn '"make pdf docs" failed.'
- else
- cp doc/Doxyfile doc/Doxyfile.orig
- cp doc/Makefile doc/Makefile.orig
- sed -i.orig -e "s/GENERATE_LATEX = YES/GENERATE_LATEX = NO/" \
- doc/Doxyfile
- sed -i.orig -e "s/@epstopdf/# @epstopdf/" \
- -e "s/@cp Makefile.latex/# @cp Makefile.latex/" \
- -e "s/@sed/# @sed/" doc/Makefile
- make docs || ewarn '"make html docs" failed.'
- fi
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" MAN1DIR=share/man/man1 \
- install || die '"make install" failed.'
-
- dodoc INSTALL LANGUAGE.HOWTO README
-
- # pdf and html manuals
- if use doc; then
- insinto /usr/share/doc/${PF}
- if use latex; then
- doins latex/doxygen_manual.pdf
- fi
- dohtml -r html/*
- fi
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
-
- elog
- elog "The USE flags doc, and latex will enable "
- elog "the html and pdf documentation, respectively. For examples"
- elog "and other goodies, see the source tarball. For some example"
- elog "output, run doxygen on the doxygen source using the Doxyfile"
- elog "provided in the top-level source dir."
- elog
- elog "Enabling the nodot USE flag will remove the GraphViz dependency,"
- elog "along with Doxygen's ability to generate diagrams in the docs."
- elog "See the Doxygen homepage for additional helper tools to parse"
- elog "more languages."
- elog
-}
-
-pkg_postrm() {
- fdo-mime_desktop_database_update
-}