summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <abcd@gentoo.org>2010-04-05 04:04:43 +0000
committerJonathan Callen <abcd@gentoo.org>2010-04-05 04:04:43 +0000
commit17fd30e892cfc4107af1dc381c14bde4380134f3 (patch)
tree5744143d9cb60d598f402a22debe61a27745be3a /app-editors/cooledit
parentVersion bump. Avoid segfault when shutting down; return previous mute state i... (diff)
downloadgentoo-2-17fd30e892cfc4107af1dc381c14bde4380134f3.tar.gz
gentoo-2-17fd30e892cfc4107af1dc381c14bde4380134f3.tar.bz2
gentoo-2-17fd30e892cfc4107af1dc381c14bde4380134f3.zip
Add prefix keywords, patches for Interix
(Portage version: -svn/cvs/Linux i686)
Diffstat (limited to 'app-editors/cooledit')
-rw-r--r--app-editors/cooledit/ChangeLog9
-rw-r--r--app-editors/cooledit/cooledit-3.17.17.ebuild13
-rw-r--r--app-editors/cooledit/files/cooledit-3.17.17-interix.patch31
-rw-r--r--app-editors/cooledit/files/cooledit-3.17.17-interix5.patch13
4 files changed, 60 insertions, 6 deletions
diff --git a/app-editors/cooledit/ChangeLog b/app-editors/cooledit/ChangeLog
index e191733bd30d..0e89e745c6f7 100644
--- a/app-editors/cooledit/ChangeLog
+++ b/app-editors/cooledit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/cooledit
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cooledit/ChangeLog,v 1.26 2008/12/07 13:04:19 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cooledit/ChangeLog,v 1.27 2010/04/05 04:04:43 abcd Exp $
+
+ 05 Apr 2010; Jonathan Callen <abcd@gentoo.org> cooledit-3.17.17.ebuild,
+ +files/cooledit-3.17.17-interix.patch,
+ +files/cooledit-3.17.17-interix5.patch:
+ Add prefix keywords, patches for Interix
07 Dec 2008; <ssuominen@gentoo.org>
+files/cooledit-3.17.17-asneeded.patch,
diff --git a/app-editors/cooledit/cooledit-3.17.17.ebuild b/app-editors/cooledit/cooledit-3.17.17.ebuild
index f30cc6589728..5b804289c109 100644
--- a/app-editors/cooledit/cooledit-3.17.17.ebuild
+++ b/app-editors/cooledit/cooledit-3.17.17.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/cooledit/cooledit-3.17.17.ebuild,v 1.7 2008/12/07 13:04:19 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/cooledit/cooledit-3.17.17.ebuild,v 1.8 2010/04/05 04:04:43 abcd Exp $
inherit autotools eutils
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/apps/editors/X/cooledit/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ppc x86"
+KEYWORDS="~amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="nls"
RDEPEND="x11-libs/libX11
@@ -25,11 +25,16 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${P}-gcc4.patch \
"${FILESDIR}"/${P}-asneeded.patch \
- "${FILESDIR}"/${P}-implicit_declarations.patch
+ "${FILESDIR}"/${P}-implicit_declarations.patch \
+ "${FILESDIR}"/${P}-interix.patch \
+ "${FILESDIR}"/${P}-interix5.patch
+
eautoreconf
}
src_compile() {
+ [[ ${CHOST} == *-interix* ]] && export ac_cv_header_wchar_h=no
+
# Fix for bug 40152 (04 Feb 2004 agriffis)
addwrite /dev/ptym/clone:/dev/ptmx
econf $(use_enable nls)
diff --git a/app-editors/cooledit/files/cooledit-3.17.17-interix.patch b/app-editors/cooledit/files/cooledit-3.17.17-interix.patch
new file mode 100644
index 000000000000..f6599ae8557c
--- /dev/null
+++ b/app-editors/cooledit/files/cooledit-3.17.17-interix.patch
@@ -0,0 +1,31 @@
+diff -ru -x '*.Po' -x '*.Plo' cooledit-3.17.17.orig/editor/_coolpython.c cooledit-3.17.17/editor/_coolpython.c
+--- cooledit-3.17.17.orig/editor/_coolpython.c 2008-04-03 10:59:33 +0200
++++ cooledit-3.17.17/editor/_coolpython.c 2008-04-03 11:02:45 +0200
+@@ -1,4 +1,15 @@
+
++// on interix, need this before config.h to avoid clashes
++// with wchar.h, which cooledit believes is not there, and therefore
++// defines mbstate_t. Python.h includes it, and thus wchar.h messes up.
++#ifdef __cplusplus
++extern "C" {
++#endif
++#include "Python.h"
++#ifdef __cplusplus
++}
++#endif
++
+ #include <config.h>
+
+ #ifdef HAVE_PYTHON
+diff -ru -x '*.Po' -x '*.Plo' cooledit-3.17.17.orig/rxvt/_rxvtlib.h cooledit-3.17.17/rxvt/_rxvtlib.h
+--- cooledit-3.17.17.orig/rxvt/_rxvtlib.h 2008-04-03 11:10:02 +0200
++++ cooledit-3.17.17/rxvt/_rxvtlib.h 2008-04-03 09:00:13 +0200
+@@ -170,7 +170,7 @@
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <net/if.h>
+-#if !defined(__NetBSD__) && !defined(__OpenBSD__)
++#if !defined(__NetBSD__) && !defined(__OpenBSD__) && !defined(__INTERIX)
+ #include <net/if_arp.h>
+ #endif
+ #include "X11/keysymdef.h"
diff --git a/app-editors/cooledit/files/cooledit-3.17.17-interix5.patch b/app-editors/cooledit/files/cooledit-3.17.17-interix5.patch
new file mode 100644
index 000000000000..46048c334c98
--- /dev/null
+++ b/app-editors/cooledit/files/cooledit-3.17.17-interix5.patch
@@ -0,0 +1,13 @@
+diff -ru -x '*.Po' -x '*.Plo' cooledit-3.17.17.orig/rxvt/_rxvtlib.h cooledit-3.17.17/rxvt/_rxvtlib.h
+--- cooledit-3.17.17.orig/rxvt/_rxvtlib.h 2008-04-17 12:09:05 +0200
++++ cooledit-3.17.17/rxvt/_rxvtlib.h 2008-04-17 12:09:31 +0200
+@@ -169,7 +169,9 @@
+ #endif
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
++#ifndef __INTERIX
+ #include <net/if.h>
++#endif
+ #if !defined(__NetBSD__) && !defined(__OpenBSD__) && !defined(__INTERIX)
+ #include <net/if_arp.h>
+ #endif