summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-07-20 22:15:41 +0000
committerHanno Böck <hanno@gentoo.org>2009-07-20 22:15:41 +0000
commit225e443585171aacd6a5c1a35fa869630c996db3 (patch)
treec11d257cafffb121a42478849866fb8bc0fb6c4a /app-editors/efte
parentunmask emul packages for amd64, as requested by Pacho Ramos <pacho AT condmat... (diff)
downloadgentoo-2-225e443585171aacd6a5c1a35fa869630c996db3.tar.gz
gentoo-2-225e443585171aacd6a5c1a35fa869630c996db3.tar.bz2
gentoo-2-225e443585171aacd6a5c1a35fa869630c996db3.zip
efte version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/efte')
-rw-r--r--app-editors/efte/ChangeLog9
-rw-r--r--app-editors/efte/efte-1.0.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/app-editors/efte/ChangeLog b/app-editors/efte/ChangeLog
index ba580b69583a..1aa752dec4fa 100644
--- a/app-editors/efte/ChangeLog
+++ b/app-editors/efte/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/efte
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/ChangeLog,v 1.4 2008/05/28 13:55:33 hanno Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/ChangeLog,v 1.5 2009/07/20 22:15:41 hanno Exp $
+
+*efte-1.0 (20 Jul 2009)
+
+ 20 Jul 2009; Hanno Boeck <hanno@gentoo.org> +efte-1.0.ebuild:
+ Version bump, cefte stuff no longer needed.
28 May 2008; Hanno Boeck <hanno@gentoo.org> efte-0.96.ebuild:
Change dependencies from xorg-x11 to the separate libraries.
diff --git a/app-editors/efte/efte-1.0.ebuild b/app-editors/efte/efte-1.0.ebuild
new file mode 100644
index 000000000000..a460fdeba0b9
--- /dev/null
+++ b/app-editors/efte/efte-1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/efte/efte-1.0.ebuild,v 1.1 2009/07/20 22:15:41 hanno Exp $
+
+DESCRIPTION="A fast text editor supporting folding, syntax highlighting, etc."
+HOMEPAGE="http://efte.sourceforge.net"
+SRC_URI="http://downloads.sourceforge.net/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gpm X"
+
+RDEPEND="sys-libs/ncurses
+ gpm? ( sys-libs/gpm )
+ X? (
+ x11-libs/libXpm
+ x11-libs/libXdmcp
+ x11-libs/libXau
+ media-fonts/font-misc-misc
+ )"
+DEPEND="${RDEPEND}
+ dev-util/cmake"
+
+src_compile() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_GPM=$(use gpm && echo ON || echo OFF) \
+ -DBUILD_X=$(use X && echo ON || echo OFF) \
+ ./
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}