summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-10-30 00:10:19 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-10-30 00:10:19 +0000
commit1656e235ee8eb88f54139e3eac493e7e0ba5b27c (patch)
treed0330ff3daab2ce760a162c3e9634010cbe5a120 /app-editors/emacs-cvs
parentdev-java/rxtx:lfd - Installs and uses LockFileServer daemon (lfd) (diff)
downloadgentoo-2-1656e235ee8eb88f54139e3eac493e7e0ba5b27c.tar.gz
gentoo-2-1656e235ee8eb88f54139e3eac493e7e0ba5b27c.tar.bz2
gentoo-2-1656e235ee8eb88f54139e3eac493e7e0ba5b27c.zip
Merge emacs-22 ebuild to emacs-23 ebuild; Correct desktop file slotting; Resolves Bug #153174.
(Portage version: 2.1.2_pre3-r9)
Diffstat (limited to 'app-editors/emacs-cvs')
-rw-r--r--app-editors/emacs-cvs/ChangeLog10
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-22.0.90.ebuild19
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-23.0.0-r1.ebuild190
-rw-r--r--app-editors/emacs-cvs/files/digest-emacs-cvs-23.0.0-r10
-rw-r--r--app-editors/emacs-cvs/files/emacs.desktop.in8
5 files changed, 218 insertions, 9 deletions
diff --git a/app-editors/emacs-cvs/ChangeLog b/app-editors/emacs-cvs/ChangeLog
index 4146649806c1..769a19aacd59 100644
--- a/app-editors/emacs-cvs/ChangeLog
+++ b/app-editors/emacs-cvs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-editors/emacs-cvs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.52 2006/10/28 06:54:35 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.53 2006/10/30 00:10:19 mkennedy Exp $
+
+*emacs-cvs-23.0.0-r1 (30 Oct 2006)
+
+ 30 Oct 2006; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/emacs.desktop.in, emacs-cvs-22.0.90.ebuild,
+ +emacs-cvs-23.0.0-r1.ebuild:
+ Merge emacs-22 ebuild to emacs-23 ebuild; Correct desktop file slotting;
+ Resolves Bug #153174.
*emacs-cvs-22.0.90 (28 Oct 2006)
diff --git a/app-editors/emacs-cvs/emacs-cvs-22.0.90.ebuild b/app-editors/emacs-cvs/emacs-cvs-22.0.90.ebuild
index ab17fc7faf6a..4391ca491b0c 100644
--- a/app-editors/emacs-cvs/emacs-cvs-22.0.90.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-22.0.90.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.90.ebuild,v 1.1 2006/10/28 06:54:35 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-22.0.90.ebuild,v 1.2 2006/10/30 00:10:19 mkennedy Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -76,7 +76,7 @@ src_compile() {
else
myconf="${myconf} --without-x"
fi
- if use aqua ; then
+ if use aqua; then
einfo "Configuring to build with Carbon Emacs"
econf \
--enable-carbon-app=/Applications/Gentoo \
@@ -85,12 +85,13 @@ src_compile() {
$(use_with gif) $(use_with png) \
|| die "econf carbon emacs failed"
make bootstrap || die "make carbon emacs bootstrap failed"
+ else
+ econf \
+ --program-suffix=.emacs-${SLOT} \
+ --without-carbon \
+ ${myconf} || die "econf emacs failed"
+ make bootstrap || die "make emacs bootstrap failed"
fi
- econf \
- --program-suffix=.emacs-${SLOT} \
- --without-carbon \
- ${myconf} || die "econf emacs failed"
- make bootstrap || die "make emacs bootstrap failed"
}
src_install () {
@@ -148,7 +149,9 @@ EOF
fi
dodoc BUGS ChangeLog README
insinto /usr/share/applications
- doins ${FILESDIR}/${DFILE}
+ cp ${FILESDIR}/emacs.desktop.in ${DFILE}
+ sed -i -e "s,@PV@,${SLOT},g" ${DFILE}
+ doins ${DFILE}
}
update-alternatives() {
diff --git a/app-editors/emacs-cvs/emacs-cvs-23.0.0-r1.ebuild b/app-editors/emacs-cvs/emacs-cvs-23.0.0-r1.ebuild
new file mode 100644
index 000000000000..8b53f1ed7d9c
--- /dev/null
+++ b/app-editors/emacs-cvs/emacs-cvs-23.0.0-r1.ebuild
@@ -0,0 +1,190 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.0-r1.ebuild,v 1.1 2006/10/30 00:10:19 mkennedy Exp $
+
+ECVS_AUTH="pserver"
+ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
+ECVS_MODULE="emacs"
+ECVS_BRANCH="emacs-unicode-2"
+
+inherit elisp-common cvs alternatives flag-o-matic eutils
+
+IUSE="X Xaw3d aqua gif gtk jpeg nls png spell tiff source gzip-el toolkit-scroll-bars xft"
+
+S=${WORKDIR}/emacs
+
+DESCRIPTION="Emacs is the extensible, customizable, self-documenting real-time display editor."
+SRC_URI=""
+HOMEPAGE="http://www.gnu.org/software/emacs"
+
+RESTRICT="$RESTRICT nostrip"
+
+X_DEPEND="x11-libs/libXmu x11-libs/libXpm x11-libs/libXt x11-misc/xbitmaps || ( media-fonts/font-adobe-100dpi media-fonts/font-adobe-75dpi )"
+
+DEPEND=">=sys-libs/ncurses-5.3
+ spell? ( || ( app-text/ispell app-text/aspell ) )
+ X? ( || ( ( $X_DEPEND ) virtual/x11 ) )
+ X? ( gif? ( >=media-libs/giflib-4.1.0.1b )
+ jpeg? ( >=media-libs/jpeg-6b )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ png? ( >=media-libs/libpng-1.2.5 )
+ gtk? ( =x11-libs/gtk+-2* )
+ !gtk? ( Xaw3d? ( x11-libs/Xaw3d ) )
+ xft? ( media-libs/fontconfig virtual/xft >=dev-libs/libotf-0.9.4 ) )
+ sys-libs/zlib
+ >=sys-apps/portage-2.0.51_rc1"
+
+PROVIDE="virtual/emacs virtual/editor"
+
+SLOT="23.0.0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+
+DFILE=emacs-${SLOT}.desktop
+
+src_unpack() {
+ cvs_src_unpack
+ cd ${S};
+ epatch ${FILESDIR}/emacs-subdirs-el-gentoo.diff
+ use ppc-macos && epatch ${FILESDIR}/emacs-cvs-21.3.50-nofink.diff
+}
+
+src_compile() {
+ export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ ALLOWED_FLAGS=" "
+ strip-flags
+ unset LDFLAGS
+ replace-flags -O[3-9] -O2
+ sed -i -e "s/-lungif/-lgif/g" configure* src/Makefile* || die
+
+ local myconf
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ myconf="${myconf} --with-xpm"
+ myconf="${myconf} $(use_with toolkit-scroll-bars)"
+ myconf="${myconf} $(use_enable xft font-backend)"
+ myconf="${myconf} $(use_with xft freetype)"
+ myconf="${myconf} $(use_with xft)"
+ myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
+ myconf="${myconf} $(use_with gif) $(use_with png)"
+ if use gtk; then
+ einfo "Configuring to build with GTK support"
+ myconf="${myconf} --with-x-toolkit=gtk"
+ else
+ einfo "Configuring to build with lucid toolkit support"
+ myconf="${myconf} $(use_with Xaw3d toolkit-scroll-bars)"
+ myconf="${myconf} --without-gtk"
+ myconf="${myconf} --with-x-toolkit=lucid"
+ fi
+ else
+ myconf="${myconf} --without-x"
+ fi
+ if use aqua; then
+ einfo "Configuring to build with Carbon Emacs"
+ econf --enable-debug \
+ --enable-carbon-app=/Applications/Gentoo \
+ --without-x \
+ $(use_with jpeg) $(use_with tiff) \
+ $(use_with gif) $(use_with png) \
+ $(use_enable xft font-backend) \
+ || die "econf carbon emacs failed"
+ make bootstrap || die "make carbon emacs bootstrap failed"
+ else
+ econf --enable-debug \
+ --program-suffix=.emacs-${SLOT} \
+ --without-carbon \
+ ${myconf} || die "econf emacs failed"
+ make bootstrap || die "make emacs bootstrap failed"
+ fi
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ rm ${D}/usr/bin/emacs-${SLOT}.emacs-${SLOT} || die "removing duplicate emacs executable failed"
+ dohard /usr/bin/emacs.emacs-${SLOT} /usr/bin/emacs-${SLOT} || die
+
+ if use aqua ; then
+ einfo "Installing Carbon Emacs..."
+ dodir /Applications/Gentoo/Emacs.app
+ pushd mac/Emacs.app
+ tar -chf - . | ( cd ${D}/Applications/Gentoo/Emacs.app; tar -xf -)
+ popd
+ fi
+
+ # fix info documentation
+ einfo "Fixing info documentation..."
+ dodir /usr/share/info/emacs-${SLOT}
+ mv ${D}/usr/share/info/{,emacs-${SLOT}/}dir || die "mv dir failed"
+ for i in ${D}/usr/share/info/*
+ do
+ if [ "${i##*/}" != emacs-${SLOT} ] ; then
+ mv ${i} ${i/info/info/emacs-${SLOT}}.info
+ gzip -9 ${i/info/info/emacs-${SLOT}}.info
+ fi
+ done
+
+ if has_version 'app-text/aspell' ; then
+ # defaults to aspell if installed
+ elisp-site-file-install ${FILESDIR}/40aspell-gentoo.el
+ fi
+ insinto /etc/env.d
+ cat >${D}/etc/env.d/50emacs-cvs-${SLOT} <<EOF
+INFOPATH=/usr/share/info/emacs-${SLOT}
+EOF
+ einfo "Fixing manpages..."
+ for m in ${D}/usr/share/man/man1/* ; do
+ mv ${m} ${m/.1/.emacs-${SLOT}.1} || die "mv man failed"
+ done
+
+ if use source; then
+ insinto /usr/share/emacs/${SLOT}/src
+ # This is not meant to install all the source -- just the
+ # C source you might find via find-function
+ doins src/*.[ch]
+ cat >00emacs-cvs-${SLOT}-gentoo.el <<EOF
+(when (substring emacs-version 0 (length "${SLOT}"))
+ (setq find-function-C-source-directory "/usr/share/emacs/${SLOT}/src"))
+EOF
+ elisp-site-file-install 00emacs-cvs-${SLOT}-gentoo.el
+ fi
+
+
+ if ! use gzip-el; then
+ find ${D} -type f -name \*.el.gz -print0 |xargs -0 gunzip
+ fi
+ dodoc BUGS ChangeLog ChangeLog.unicode README README.unicode
+ insinto /usr/share/applications
+ cp ${FILESDIR}/emacs.desktop.in ${DFILE}
+ sed -i -e "s,@PV@,${SLOT},g" ${DFILE}
+ doins ${DFILE}
+}
+
+update-alternatives() {
+ for i in emacs emacsclient etags ctags b2m ebrowse \
+ rcs-checkin grep-changelog ; do
+ alternatives_auto_makesym "/usr/bin/$i" "/usr/bin/$i.emacs-*"
+ done
+}
+
+pkg_postinst() {
+ use ppc-macos || update-alternatives
+ elisp-site-regen
+ if use X; then
+ while read line; do einfo "${line}"; done<<'EOF'
+
+You need to install some fonts for Emacs. Under monolithic
+XFree86/Xorg you typically had such fonts installed by default. With
+modular Xorg, you will have to perform this step yourself.
+
+Installing media-fonts/font-adobe-{75,100}dpi would satisfy basic
+Emacs requirements under X11.
+
+EOF
+ fi
+}
+
+pkg_postrm() {
+ use ppc-macos || update-alternatives
+ elisp-site-regen
+}
diff --git a/app-editors/emacs-cvs/files/digest-emacs-cvs-23.0.0-r1 b/app-editors/emacs-cvs/files/digest-emacs-cvs-23.0.0-r1
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-editors/emacs-cvs/files/digest-emacs-cvs-23.0.0-r1
diff --git a/app-editors/emacs-cvs/files/emacs.desktop.in b/app-editors/emacs-cvs/files/emacs.desktop.in
new file mode 100644
index 000000000000..fae10e12554b
--- /dev/null
+++ b/app-editors/emacs-cvs/files/emacs.desktop.in
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=GNU Emacs @PV@
+Comment=Emacs is the extensible, customizable, self-documenting real-time display editor.
+Icon=gnome-emacs.png
+Terminal=0
+Type=Application
+Categories=Application;Development;
+Exec=/usr/bin/emacs-@PV@