summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-10-25 21:31:09 +0000
committerUlrich Müller <ulm@gentoo.org>2010-10-25 21:31:09 +0000
commit867b1ab79e026f79d9afbc2b55054de163d990bf (patch)
treedaaa889c5f7838db3aaa91b0206687b91639e87e /app-editors/emacs-vcs
parentFilter -fstack-protector and -fstack-protector-all flags, bug 285778. (diff)
downloadgentoo-2-867b1ab79e026f79d9afbc2b55054de163d990bf.tar.gz
gentoo-2-867b1ab79e026f79d9afbc2b55054de163d990bf.tar.bz2
gentoo-2-867b1ab79e026f79d9afbc2b55054de163d990bf.zip
Filter -fstack-protector and -fstack-protector-all flags, bug 285778.
(Portage version: 2.1.9.21/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/emacs-vcs')
-rw-r--r--app-editors/emacs-vcs/ChangeLog7
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-23.2.9999.ebuild8
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild8
3 files changed, 16 insertions, 7 deletions
diff --git a/app-editors/emacs-vcs/ChangeLog b/app-editors/emacs-vcs/ChangeLog
index 9b444c4b1549..2f160dd030d7 100644
--- a/app-editors/emacs-vcs/ChangeLog
+++ b/app-editors/emacs-vcs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/emacs-vcs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/ChangeLog,v 1.32 2010/10/21 20:41:46 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/ChangeLog,v 1.33 2010/10/25 21:31:09 ulm Exp $
+
+ 25 Oct 2010; Ulrich Mueller <ulm@gentoo.org> emacs-vcs-23.2.9999.ebuild,
+ emacs-vcs-24.0.9999.ebuild:
+ Filter -fstack-protector and -fstack-protector-all flags that cause
+ segmentation faults in hardened profiles. Bug 285778.
21 Oct 2010; Ulrich Mueller <ulm@gentoo.org> emacs-vcs-24.0.9999.ebuild:
New USE flags: gnutls and selinux.
diff --git a/app-editors/emacs-vcs/emacs-vcs-23.2.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-23.2.9999.ebuild
index 8c8806077369..78b085b2820d 100644
--- a/app-editors/emacs-vcs/emacs-vcs-23.2.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-23.2.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-23.2.9999.ebuild,v 1.8 2010/10/13 21:36:09 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-23.2.9999.ebuild,v 1.9 2010/10/25 21:31:09 ulm Exp $
EAPI=2
@@ -91,7 +91,8 @@ src_prepare() {
# EPATCH_SUFFIX=patch epatch
fi
- sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
+ sed -i \
+ -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
-e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
"${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
@@ -115,7 +116,8 @@ src_prepare() {
src_configure() {
ALLOWED_FLAGS=""
strip-flags
- #unset LDFLAGS
+ filter-flags -fstack-protector -fstack-protector-all #285778
+
if use sh; then
replace-flags -O[1-9] -O0 #262359
elif use ia64; then
diff --git a/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
index ec74bfd55294..3a1e60329a6d 100644
--- a/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild,v 1.18 2010/10/21 20:41:46 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.0.9999.ebuild,v 1.19 2010/10/25 21:31:09 ulm Exp $
EAPI=2
@@ -104,7 +104,8 @@ src_prepare() {
# EPATCH_SUFFIX=patch epatch
fi
- sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
+ sed -i \
+ -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
-e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
"${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
@@ -128,7 +129,8 @@ src_prepare() {
src_configure() {
ALLOWED_FLAGS=""
strip-flags
- #unset LDFLAGS
+ filter-flags -fstack-protector -fstack-protector-all #285778
+
if use sh; then
replace-flags -O[1-9] -O0 #262359
elif use ia64; then