summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-10-19 11:50:04 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-10-19 11:50:04 +0000
commit3fcaf6222f4987980758310cf72f6148b43f175b (patch)
treedae7b7d59a588b899296bc3cc1bd5adabbaa9fd5 /app-editors/fb2edit
parentremove app-text/unix2dos from RDEPEND (#525824 by Michael Orlitzky) (diff)
downloadgentoo-2-3fcaf6222f4987980758310cf72f6148b43f175b.tar.gz
gentoo-2-3fcaf6222f4987980758310cf72f6148b43f175b.tar.bz2
gentoo-2-3fcaf6222f4987980758310cf72f6148b43f175b.zip
Version bump, wrt bug #525778
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'app-editors/fb2edit')
-rw-r--r--app-editors/fb2edit/ChangeLog8
-rw-r--r--app-editors/fb2edit/fb2edit-0.0.9.ebuild34
-rw-r--r--app-editors/fb2edit/files/fb2edit-0.0.9-fix-compiler-warnings.patch101
3 files changed, 142 insertions, 1 deletions
diff --git a/app-editors/fb2edit/ChangeLog b/app-editors/fb2edit/ChangeLog
index 8394c7693ced..1c2196840c3c 100644
--- a/app-editors/fb2edit/ChangeLog
+++ b/app-editors/fb2edit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/fb2edit
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fb2edit/ChangeLog,v 1.12 2014/06/16 11:23:00 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fb2edit/ChangeLog,v 1.13 2014/10/19 11:50:04 pinkbyte Exp $
+
+*fb2edit-0.0.9 (19 Oct 2014)
+
+ 19 Oct 2014; Sergey Popov <pinkbyte@gentoo.org> +fb2edit-0.0.9.ebuild,
+ +files/fb2edit-0.0.9-fix-compiler-warnings.patch:
+ Version bump, wrt bug #525778
16 Jun 2014; Michael Palimaka <kensington@gentoo.org> metadata.xml:
Remove Qt herd.
diff --git a/app-editors/fb2edit/fb2edit-0.0.9.ebuild b/app-editors/fb2edit/fb2edit-0.0.9.ebuild
new file mode 100644
index 000000000000..e4c033753cbb
--- /dev/null
+++ b/app-editors/fb2edit/fb2edit-0.0.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fb2edit/fb2edit-0.0.9.ebuild,v 1.1 2014/10/19 11:50:04 pinkbyte Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="a WYSIWYG FictionBook (fb2) editor"
+HOMEPAGE="http://fb2edit.lintest.ru/"
+SRC_URI="https://github.com/lintest/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libxml2
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtwebkit:4
+ dev-qt/qtxmlpatterns:4"
+RDEPEND="${DEPEND}
+ x11-themes/hicolor-icon-theme"
+
+DOCS=( AUTHORS README )
+
+PATCHES=( "${FILESDIR}/${P}-fix-compiler-warnings.patch" )
+
+src_prepare() {
+ # drop -g from CFLAGS
+ sed -i -e '/^add_definitions(-W/s/-g//' CMakeLists.txt || die 'sed failed'
+
+ cmake-utils_src_prepare
+}
diff --git a/app-editors/fb2edit/files/fb2edit-0.0.9-fix-compiler-warnings.patch b/app-editors/fb2edit/files/fb2edit-0.0.9-fix-compiler-warnings.patch
new file mode 100644
index 000000000000..7422c505858e
--- /dev/null
+++ b/app-editors/fb2edit/files/fb2edit-0.0.9-fix-compiler-warnings.patch
@@ -0,0 +1,101 @@
+commit 5a378858e83e95f88ffec5e14ae1fd8157101ed0
+Author: Kandrashin Denis <mail@lintest.ru>
+Date: Fri Jul 18 23:03:05 2014 +0400
+
+ Remove compiler warning
+
+diff --git a/source/fb2main.cpp b/source/fb2main.cpp
+index 50c5a80..504ccd8 100644
+--- a/source/fb2main.cpp
++++ b/source/fb2main.cpp
+@@ -27,6 +27,7 @@ FbMainWindow::FbMainWindow(const QString &filename, ViewMode mode)
+ , isSwitched(false)
+ , isUntitled(true)
+ {
++ Q_UNUSED(mode);
+ connect(qApp, SIGNAL(logMessage(QtMsgType, QString)), SLOT(logMessage(QtMsgType, QString)));
+
+ setUnifiedTitleAndToolBarOnMac(true);
+@@ -50,16 +51,22 @@ FbMainWindow::FbMainWindow(const QString &filename, ViewMode mode)
+
+ void FbMainWindow::warning(int row, int col, const QString &msg)
+ {
++ Q_UNUSED(row);
++ Q_UNUSED(col);
+ logMessage(QtWarningMsg, msg.simplified());
+ }
+
+ void FbMainWindow::error(int row, int col, const QString &msg)
+ {
++ Q_UNUSED(row);
++ Q_UNUSED(col);
+ logMessage(QtCriticalMsg, msg.simplified());
+ }
+
+ void FbMainWindow::fatal(int row, int col, const QString &msg)
+ {
++ Q_UNUSED(row);
++ Q_UNUSED(col);
+ logMessage(QtFatalMsg, msg.simplified());
+ }
+
+@@ -164,6 +171,7 @@ void FbMainWindow::createActions()
+ FbTextEdit *text = mainDock->text();
+ FbHeadEdit *head = mainDock->head();
+ FbCodeEdit *code = mainDock->code();
++ Q_UNUSED(head)
+
+ menu = menuBar()->addMenu(tr("&File"));
+ tool = addToolBar(tr("File"));
+diff --git a/source/fb2text.cpp b/source/fb2text.cpp
+index 0ea146f..aa2d276 100644
+--- a/source/fb2text.cpp
++++ b/source/fb2text.cpp
+@@ -37,14 +37,14 @@ FbTextAction::FbTextAction(const QIcon &icon, const QString &text, QWebPage::Web
+ {
+ }
+
+-QAction * FbTextAction::action(QWebPage::WebAction action)
++QAction * FbTextAction::action()
+ {
+ return m_parent->pageAction(m_action);
+ }
+
+ void FbTextAction::updateAction()
+ {
+- if (QAction * act = action(m_action)) {
++ if (QAction * act = action()) {
+ if (isCheckable()) setChecked(act->isChecked());
+ setEnabled(act->isEnabled());
+ }
+@@ -52,7 +52,7 @@ void FbTextAction::updateAction()
+
+ void FbTextAction::connectAction()
+ {
+- if (QAction * act = action(m_action)) {
++ if (QAction * act = action()) {
+ connect(this, SIGNAL(triggered(bool)), act, SIGNAL(triggered(bool)));
+ connect(act, SIGNAL(changed()), this, SLOT(updateAction()));
+ if (isCheckable()) setChecked(act->isChecked());
+@@ -65,7 +65,7 @@ void FbTextAction::connectAction()
+
+ void FbTextAction::disconnectAction()
+ {
+- QAction * act = action(m_action);
++ QAction * act = action();
+ disconnect(act, 0, this, 0);
+ disconnect(this, 0, act, 0);
+ }
+diff --git a/source/fb2text.hpp b/source/fb2text.hpp
+index c1d1cb4..41f8a6c 100644
+--- a/source/fb2text.hpp
++++ b/source/fb2text.hpp
+@@ -169,7 +169,7 @@ private slots:
+ void updateAction();
+
+ private:
+- QAction * action(QWebPage::WebAction action);
++ QAction * action();
+
+ private:
+ QWebPage::WebAction m_action;