summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-31 22:12:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-31 22:12:04 +0000
commit85bf0780b54b0388919f656d5d2475ac8dfbfc7d (patch)
tree5462eacfdcae74754e7ca88e02f792ab14b385f0 /app-editors/gedit
parentversion bump, first gpg-signed package ;) (Manifest recommit) (diff)
downloadgentoo-2-85bf0780b54b0388919f656d5d2475ac8dfbfc7d.tar.gz
gentoo-2-85bf0780b54b0388919f656d5d2475ac8dfbfc7d.tar.bz2
gentoo-2-85bf0780b54b0388919f656d5d2475ac8dfbfc7d.zip
dont install uselss COPYING file and fix other stuff while i'm at it
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/gedit-0.9.6-r1.ebuild40
-rw-r--r--app-editors/gedit/gedit-2.6.0.ebuild9
-rw-r--r--app-editors/gedit/gedit-2.6.1.ebuild9
3 files changed, 25 insertions, 33 deletions
diff --git a/app-editors/gedit/gedit-0.9.6-r1.ebuild b/app-editors/gedit/gedit-0.9.6-r1.ebuild
index ed78b46174a3..747f35687a0d 100644
--- a/app-editors/gedit/gedit-0.9.6-r1.ebuild
+++ b/app-editors/gedit/gedit-0.9.6-r1.ebuild
@@ -1,43 +1,37 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-0.9.6-r1.ebuild,v 1.14 2004/05/29 03:43:38 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-0.9.6-r1.ebuild,v 1.15 2004/05/31 22:12:03 vapier Exp $
-IUSE="nls"
+inherit flag-o-matic
-S=${WORKDIR}/${P}
DESCRIPTION="Gnome Text Editor"
-SRC_URI="mirror://gnome//sources/gedit/${PV/.6}/${P}.tar.gz"
HOMEPAGE="http://gedit.sourceforge.net/"
-SLOT="O"
+SRC_URI="mirror://gnome//sources/gedit/${PV/.6}/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="O"
KEYWORDS="x86 sparc ppc"
+IUSE="nls"
-RDEPEND=" <gnome-base/libglade-2
- >=gnome-base/gnome-print-0.30
- =gnome-base/gnome-vfs-1*"
-
+RDEPEND="<gnome-base/libglade-2
+ >=gnome-base/gnome-print-0.30
+ =gnome-base/gnome-vfs-1*"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-
src_compile() {
local myconf
+ use nls || myconf="--disable-nls"
+ append-flags `gnome-config --cflags libglade vfs`
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
-
- CFLAGS="${CFLAGS} `gnome-config --cflags libglade vfs`"
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- ${myconf} || die
-
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ ${myconf} || die
emake || die
}
src_install() {
- make prefix=${D}/usr install || die
-
- dodoc AUTHORS BUGS COPYING ChangeLog FAQ NEWS README* THANKS TODO
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS BUGS ChangeLog FAQ NEWS README* THANKS TODO
}
diff --git a/app-editors/gedit/gedit-2.6.0.ebuild b/app-editors/gedit/gedit-2.6.0.ebuild
index 96a37079f482..0ae344179dde 100644
--- a/app-editors/gedit/gedit-2.6.0.ebuild
+++ b/app-editors/gedit/gedit-2.6.0.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.6.0.ebuild,v 1.4 2004/05/29 03:43:38 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.6.0.ebuild,v 1.5 2004/05/31 22:12:03 vapier Exp $
inherit gnome2
DESCRIPTION="A text editor for the Gnome2 desktop"
HOMEPAGE="http://www.gnome.org/"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="x86 ppc ~alpha ~sparc hppa ~amd64 ~ia64 ~mips"
+SLOT="0"
+KEYWORDS="x86 ppc ~sparc ~mips ~alpha hppa ~amd64 ~ia64"
IUSE="spell"
RDEPEND=">=gnome-base/libglade-2
@@ -21,11 +21,10 @@ RDEPEND=">=gnome-base/libglade-2
>=x11-libs/gtksourceview-0.9
spell? ( virtual/aspell-dict )"
# FIXME : spell autodetect only
-
DEPEND="${RDEPEND}
sys-devel/gettext
>=dev-util/pkgconfig-0.12.0
>=app-text/scrollkeeper-0.3.11
>=dev-util/intltool-0.29"
-DOCS="AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README THANKS TODO"
+DOCS="AUTHORS BUGS ChangeLog INSTALL NEWS README THANKS TODO"
diff --git a/app-editors/gedit/gedit-2.6.1.ebuild b/app-editors/gedit/gedit-2.6.1.ebuild
index 5f3b402490cb..f0df27f8f8fe 100644
--- a/app-editors/gedit/gedit-2.6.1.ebuild
+++ b/app-editors/gedit/gedit-2.6.1.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.6.1.ebuild,v 1.1 2004/05/04 15:10:04 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.6.1.ebuild,v 1.2 2004/05/31 22:12:03 vapier Exp $
inherit gnome2
DESCRIPTION="A text editor for the Gnome2 desktop"
HOMEPAGE="http://www.gnome.org/"
-SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64 ~mips"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64"
IUSE="spell"
RDEPEND=">=gnome-base/libglade-2.3.6
@@ -21,11 +21,10 @@ RDEPEND=">=gnome-base/libglade-2.3.6
>=x11-libs/gtksourceview-1
spell? ( virtual/aspell-dict )"
# FIXME : spell autodetect only
-
DEPEND="${RDEPEND}
sys-devel/gettext
>=dev-util/pkgconfig-0.12.0
>=app-text/scrollkeeper-0.3.11
>=dev-util/intltool-0.29"
-DOCS="AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README THANKS TODO"
+DOCS="AUTHORS BUGS ChangeLog INSTALL NEWS README THANKS TODO"