summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-24 11:34:37 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-24 11:34:37 +0000
commit0d7e4ac8776ffe0be0863e00343688b6079b4071 (patch)
tree1c9613414735b7422f24bcd11a029b7e4fab548a /app-editors/gummi
parentVersion Bump, removed old (diff)
downloadgentoo-2-0d7e4ac8776ffe0be0863e00343688b6079b4071.tar.gz
gentoo-2-0d7e4ac8776ffe0be0863e00343688b6079b4071.tar.bz2
gentoo-2-0d7e4ac8776ffe0be0863e00343688b6079b4071.zip
Initial commit of live ebuild.
(Portage version: 2.2_rc99/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/gummi')
-rw-r--r--app-editors/gummi/ChangeLog7
-rw-r--r--app-editors/gummi/gummi-9999.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/app-editors/gummi/ChangeLog b/app-editors/gummi/ChangeLog
index 9bf852fc8822..216da9e78354 100644
--- a/app-editors/gummi/ChangeLog
+++ b/app-editors/gummi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gummi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/ChangeLog,v 1.8 2010/10/24 11:04:42 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/ChangeLog,v 1.9 2010/10/24 11:34:37 hwoarang Exp $
+
+*gummi-9999 (24 Oct 2010)
+
+ 24 Oct 2010; Markos Chandras <hwoarang@gentoo.org> +gummi-9999.ebuild:
+ Initial commit of live ebuild.
*gummi-0.5.3 (24 Oct 2010)
diff --git a/app-editors/gummi/gummi-9999.ebuild b/app-editors/gummi/gummi-9999.ebuild
new file mode 100644
index 000000000000..f78bbe6ee73a
--- /dev/null
+++ b/app-editors/gummi/gummi-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/gummi-9999.ebuild,v 1.1 2010/10/24 11:34:37 hwoarang Exp $
+
+EAPI=2
+inherit base eutils subversion
+
+ESVN_REPO_URI="http://dev.midnightcoding.org/svn/gummi/trunk"
+ESVN_PROJECT="${PN/-svn}"
+
+DESCRIPTION="Simple LaTeX editor for GTK+ users"
+HOMEPAGE="http://gummi.midnightcoding.org"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+LANGS="ca da de fr el it nl pt_BR ru zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ >=x11-libs/gtk+-2.16:2"
+DEPEND="${RDEPEND}
+ app-text/gtkspell
+ app-text/poppler[cairo]
+ x11-libs/gtksourceview:2.0
+ x11-libs/pango"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ strip-linguas ${LANGS}
+}
+
+pkg_postinst() {
+ elog "Gummi >=0.4.8 supports spell-checking through gtkspell. Support for"
+ elog "additional languages can be added by installing myspell-** packages"
+ elog "for your language of choice."
+}