summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-03-03 15:03:19 +0000
committerAli Polatel <hawking@gentoo.org>2008-03-03 15:03:19 +0000
commitc7720bd5c61d7c6e7704af087bab0e9db9817665 (patch)
treeb6bc53ad2b1e7e591736d076ef2c3801b7e98e21 /app-editors/gvim/gvim-7.1.266.ebuild
parentgimp version bump (diff)
downloadgentoo-2-c7720bd5c61d7c6e7704af087bab0e9db9817665.tar.gz
gentoo-2-c7720bd5c61d7c6e7704af087bab0e9db9817665.tar.bz2
gentoo-2-c7720bd5c61d7c6e7704af087bab0e9db9817665.zip
Version bump. Fixes some memory leaks and other bugs.
(Portage version: 2.1.4.4, RepoMan options: --force)
Diffstat (limited to 'app-editors/gvim/gvim-7.1.266.ebuild')
-rw-r--r--app-editors/gvim/gvim-7.1.266.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-7.1.266.ebuild b/app-editors/gvim/gvim-7.1.266.ebuild
new file mode 100644
index 000000000000..2f4bbe86e9d2
--- /dev/null
+++ b/app-editors/gvim/gvim-7.1.266.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.1.266.ebuild,v 1.1 2008/03/03 15:03:19 hawking Exp $
+
+inherit vim
+
+VIM_VERSION="7.1"
+VIM_GENTOO_PATCHES="vim-${VIM_VERSION}-gentoo-patches.tar.bz2"
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+GVIMRC_FILE_SUFFIX="-r1"
+GVIM_DESKTOP_SUFFIX="-r1"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unstable/unix/vim-${VIM_VERSION}.tar.bz2
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-extra.tar.gz
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="aqua gnome gtk motif nextaw"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}
+ x11-libs/libXext
+ !aqua? (
+ gtk? (
+ >=x11-libs/gtk+-2.6
+ virtual/xft
+ gnome? ( >=gnome-base/libgnomeui-2.6 )
+ )
+ !gtk? (
+ motif? (
+ x11-libs/openmotif
+ )
+ !motif? (
+ nextaw? (
+ x11-libs/neXtaw
+ )
+ !nextaw? ( x11-libs/libXaw )
+ )
+ )
+ )"