summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-07-25 04:44:13 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-07-25 04:44:13 +0000
commitb9f5b94fa6ef83b4821487b560930a871baca0fc (patch)
tree0a3b3eebce813c5a64ef21590272eac9d16c56ad /app-editors/jedit
parentrepoman'd (diff)
downloadgentoo-2-b9f5b94fa6ef83b4821487b560930a871baca0fc.tar.gz
gentoo-2-b9f5b94fa6ef83b4821487b560930a871baca0fc.tar.bz2
gentoo-2-b9f5b94fa6ef83b4821487b560930a871baca0fc.zip
fixed perms on docs/ dir problem
Diffstat (limited to 'app-editors/jedit')
-rw-r--r--app-editors/jedit/ChangeLog9
-rw-r--r--app-editors/jedit/files/digest-jedit-4.0.3-r21
-rw-r--r--app-editors/jedit/jedit-4.0.3-r2.ebuild65
3 files changed, 74 insertions, 1 deletions
diff --git a/app-editors/jedit/ChangeLog b/app-editors/jedit/ChangeLog
index 64fb80a104e8..e3c2f2f45bd6 100644
--- a/app-editors/jedit/ChangeLog
+++ b/app-editors/jedit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/jedit
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.4 2002/07/12 16:30:43 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/ChangeLog,v 1.5 2002/07/25 04:44:13 mkennedy Exp $
+
+*jedit-4.0.3-r2 (24 Jul 2002)
+
+ 24 Jul 2002; Matthew Kennedy <mkennedy@gentoo.org> jedit-4.0.3-r2.ebuild :
+
+ Should install the docs now... with the right permissions (resolves
+ bug #4929)
*jedit-4.0.3-r1 (12 Jul 2002)
diff --git a/app-editors/jedit/files/digest-jedit-4.0.3-r2 b/app-editors/jedit/files/digest-jedit-4.0.3-r2
new file mode 100644
index 000000000000..05e5e28f8719
--- /dev/null
+++ b/app-editors/jedit/files/digest-jedit-4.0.3-r2
@@ -0,0 +1 @@
+MD5 95a26ccc1ab89257a467ef159f5dad05 jedit403source.tar.gz 1283199
diff --git a/app-editors/jedit/jedit-4.0.3-r2.ebuild b/app-editors/jedit/jedit-4.0.3-r2.ebuild
new file mode 100644
index 000000000000..0631bc64c1b3
--- /dev/null
+++ b/app-editors/jedit/jedit-4.0.3-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jedit/jedit-4.0.3-r2.ebuild,v 1.1 2002/07/25 04:44:13 mkennedy Exp $
+
+S="${WORKDIR}/jEdit"
+DESCRIPTION="Programmer's editor written in Java"
+HOMEPAGE="http://www.jedit.org"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/jedit/jedit403source.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="*"
+
+RDEPEND=">=virtual/jdk-1.3"
+DEPEND="${RDEPEND}
+ >=dev-java/ant-1.4.1
+ jikes? ( >=dev-java/jikes-1.15 )"
+
+src_compile() {
+ local antflags
+
+ antflags=""
+ if [ `use jikes` ] ; then
+ einfo "Please ignore the following compiler warnings."
+ einfo "Jikes is just too pedantic..."
+ antflags="${antflags} -Dbuild.compiler=jikes"
+ fi
+
+ ant ${antflags} || die "compile problem"
+}
+
+src_install () {
+ mkdir -m 755 -p ${D}/usr/share/jedit
+ mkdir -m 755 ${D}/usr/bin
+
+ cp -R jedit.jar jars doc macros modes properties startup ${D}/usr/share/jedit
+ cd ${D}/usr/share/jedit
+ chmod -R u+rw,ug-s,go+u,go-w \
+ jedit.jar jars doc macros modes properties startup
+
+ cat >${D}/usr/share/jedit/jedit.sh <<-EOF
+ #!/bin/bash
+
+ cd /usr/share/jedit
+ java -jar /usr/share/jedit/jedit.jar $@
+ EOF
+ chmod 755 ${D}/usr/share/jedit/jedit.sh
+
+ ln -s ../share/jedit/jedit.sh ${D}/usr/bin/jedit
+}
+
+pkg_postinst() {
+ touch /usr/share/jedit/jars/.keep
+
+ einfo "The system directory for jEdit plugins is"
+ einfo "/usr/share/jedit/jars"
+}
+
+pkg_postrm() {
+ einfo "jEdit plugins installed into /usr/share/jedit/jars"
+ einfo "(after installation of jEdit itself) haven't been"
+ einfo "removed. To get rid of jEdit completely, you may"
+ einfo "want to run"
+ einfo ""
+ einfo "\trm -r /usr/share/jedit"
+}