summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-20 06:29:32 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-20 06:29:32 +0000
commit73655f5d29c6228a8317a821a78ae7b5984aa58f (patch)
tree06ba791f27a2434da9ff02543e2b9e4c4f7985d9 /app-editors/latexila
parentFix typo in src_install wrt #438994 by darkbasic <darkbasic@linuxsystems.it> (diff)
downloadgentoo-2-73655f5d29c6228a8317a821a78ae7b5984aa58f.tar.gz
gentoo-2-73655f5d29c6228a8317a821a78ae7b5984aa58f.tar.bz2
gentoo-2-73655f5d29c6228a8317a821a78ae7b5984aa58f.zip
Version bump, drop old.
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/latexila')
-rw-r--r--app-editors/latexila/ChangeLog9
-rw-r--r--app-editors/latexila/latexila-2.4.0.ebuild68
-rw-r--r--app-editors/latexila/latexila-2.6.1.ebuild43
3 files changed, 50 insertions, 70 deletions
diff --git a/app-editors/latexila/ChangeLog b/app-editors/latexila/ChangeLog
index 39d8d2459c30..d4f01b152f0d 100644
--- a/app-editors/latexila/ChangeLog
+++ b/app-editors/latexila/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/latexila
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/latexila/ChangeLog,v 1.11 2012/10/04 14:44:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/latexila/ChangeLog,v 1.12 2012/10/20 06:29:32 pacho Exp $
+
+*latexila-2.6.1 (20 Oct 2012)
+
+ 20 Oct 2012; Pacho Ramos <pacho@gentoo.org> +latexila-2.6.1.ebuild,
+ -latexila-2.4.0.ebuild:
+ Version bump, drop old.
04 Oct 2012; Agostino Sarubbo <ago@gentoo.org> latexila-2.4.1.ebuild:
Stable for amd64, wrt bug #427544
@@ -47,4 +53,3 @@
17 Dec 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+latexila-2.2.2.ebuild, +metadata.xml:
New ebuild for a LaTeX IDE for bug #380779, thanks to Sébastien Wilmet.
-
diff --git a/app-editors/latexila/latexila-2.4.0.ebuild b/app-editors/latexila/latexila-2.4.0.ebuild
deleted file mode 100644
index d15ec5d789cf..000000000000
--- a/app-editors/latexila/latexila-2.4.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/latexila/latexila-2.4.0.ebuild,v 1.5 2012/05/15 19:41:58 pacho Exp $
-
-EAPI="4"
-CMAKE_MIN_VERSION="2.6.4"
-CMAKE_IN_SOURCE_BUILD="yes" # for gnome2.eclass compat
-GCONF_DEBUG="no"
-
-inherit cmake-utils gnome2
-
-DESCRIPTION="Integrated LaTeX environment for GNOME"
-HOMEPAGE="http://projects.gnome.org/latexila/"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gnome +latexmk rubber vala"
-
-COMMON_DEPEND="
- app-text/gtkspell:2
- >=dev-libs/glib-2.30:2
- dev-libs/libgee:0
- dev-libs/libunique:1
- >=x11-libs/gtk+-2.16:2
- >=x11-libs/gtksourceview-2.10:2.0
- x11-libs/gdk-pixbuf:2
- x11-libs/libX11
- x11-libs/pango
- gnome? ( gnome-base/gsettings-desktop-schemas )
- vala? ( >=dev-lang/vala-0.16.0:0.16 )
-"
-RDEPEND="${COMMON_DEPEND}
- virtual/latex-base
- x11-themes/hicolor-icon-theme
- latexmk? ( dev-tex/latexmk )
- rubber? ( dev-tex/rubber )
-"
-DEPEND="${COMMON_DEPEND}
- dev-util/itstool
- virtual/pkgconfig
- sys-devel/gettext
-"
-
-pkg_setup() {
- DOCS="AUTHORS HACKING NEWS README"
-}
-
-src_prepare() {
- if [[ -n ${LINGUAS+set} ]]; then
- # LINGUAS is set, let's try to respect it.
- pushd po > /dev/null
- local po_file
- for po_file in *.po; do
- has "${po_file%.po}" ${LINGUAS} || rm -v "${po_file}"
- done
- popd > /dev/null
- fi
-}
-
-src_configure() {
- local mycmakeargs="
- VALAC=$(type -p valac-0.16)
- $(cmake-utils_use_build vala VALA)
- $(cmake-utils_use_with gnome GNOME)
- -DCOMPILE_SCHEMA=OFF"
- cmake-utils_src_configure
-}
diff --git a/app-editors/latexila/latexila-2.6.1.ebuild b/app-editors/latexila/latexila-2.6.1.ebuild
new file mode 100644
index 000000000000..dc0e4a55fa77
--- /dev/null
+++ b/app-editors/latexila/latexila-2.6.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/latexila/latexila-2.6.1.ebuild,v 1.1 2012/10/20 06:29:32 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+
+inherit gnome2 vala
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="http://projects.gnome.org/latexila/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+latexmk rubber"
+
+COMMON_DEPEND="
+ app-text/enchant
+ >=dev-libs/glib-2.32:2
+ dev-libs/libgee:0
+ gnome-base/gsettings-desktop-schemas
+ >=x11-libs/gtk+-3.4.3:3
+ >=x11-libs/gtksourceview-3.4.1:3.0
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libX11
+ x11-libs/pango
+ $(vala_depend)
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/itstool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+DOCS="AUTHORS HACKING NEWS README"