summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-06 11:10:19 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-06 11:10:19 +0000
commitb8b6d919e1988bb397a5c50a99a11b7233d841fc (patch)
tree196ca646abc86440bc78ab4a9ae2fddd919bf438 /app-editors/leo
parentdev-python/httplib2: Add pypy3 support (diff)
downloadgentoo-2-b8b6d919e1988bb397a5c50a99a11b7233d841fc.tar.gz
gentoo-2-b8b6d919e1988bb397a5c50a99a11b7233d841fc.tar.bz2
gentoo-2-b8b6d919e1988bb397a5c50a99a11b7233d841fc.zip
bump; not py3 ready, converted to new eclass, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-editors/leo')
-rw-r--r--app-editors/leo/ChangeLog8
-rw-r--r--app-editors/leo/leo-4.10.ebuild39
-rw-r--r--app-editors/leo/leo-4.11.ebuild3
-rw-r--r--app-editors/leo/leo-4.8.ebuild39
-rw-r--r--app-editors/leo/leo-5.0.ebuild36
5 files changed, 45 insertions, 80 deletions
diff --git a/app-editors/leo/ChangeLog b/app-editors/leo/ChangeLog
index b8c0f8245c03..651a114c4a05 100644
--- a/app-editors/leo/ChangeLog
+++ b/app-editors/leo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/leo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.30 2014/03/24 15:05:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/ChangeLog,v 1.31 2014/12/06 11:10:19 idella4 Exp $
+
+*leo-5.0 (06 Dec 2014)
+
+ 06 Dec 2014; Ian Delaney <idella4@gentoo.org> +leo-5.0.ebuild,
+ -leo-4.10.ebuild, -leo-4.8.ebuild, leo-4.11.ebuild:
+ bump; not py3 ready, converted to new eclass, rm old
24 Mar 2014; Agostino Sarubbo <ago@gentoo.org> leo-4.11.ebuild:
Stable for ppc, wrt bug #495332
diff --git a/app-editors/leo/leo-4.10.ebuild b/app-editors/leo/leo-4.10.ebuild
deleted file mode 100644
index 0947366f9558..000000000000
--- a/app-editors/leo/leo-4.10.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.10.ebuild,v 1.2 2012/11/01 10:12:09 ulm Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.6"
-PYTHON_USE_WITH="tk"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-pypy-* *-jython"
-
-inherit distutils eutils
-
-MY_P="Leo-${PV}-final"
-
-DESCRIPTION="Leo: Literate Editor with Outlines"
-HOMEPAGE="http://leo.sourceforge.net/ http://pypi.python.org/pypi/leo"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND="app-text/silvercity
- dev-python/PyQt4[X]"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-fix_syntax_errors.patch"
-}
-
-src_install() {
- distutils_src_install
- dohtml -r leo/doc/html/* || die "dohtml failed"
-}
diff --git a/app-editors/leo/leo-4.11.ebuild b/app-editors/leo/leo-4.11.ebuild
index caeb6ca9c6be..91fb5bca1a0b 100644
--- a/app-editors/leo/leo-4.11.ebuild
+++ b/app-editors/leo/leo-4.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.11.ebuild,v 1.4 2014/03/24 15:05:21 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.11.ebuild,v 1.5 2014/12/06 11:10:19 idella4 Exp $
EAPI="3"
PYTHON_DEPEND="2:2.6"
@@ -23,6 +23,7 @@ IUSE=""
RDEPEND="app-text/silvercity
dev-python/PyQt4[X]"
+
DEPEND="${RDEPEND}
app-arch/unzip"
diff --git a/app-editors/leo/leo-4.8.ebuild b/app-editors/leo/leo-4.8.ebuild
deleted file mode 100644
index c3c2de666d95..000000000000
--- a/app-editors/leo/leo-4.8.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-4.8.ebuild,v 1.6 2012/11/01 10:12:09 ulm Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.6"
-PYTHON_USE_WITH="tk"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-pypy-* *-jython"
-
-inherit distutils eutils
-
-MY_P="Leo-${PV}-final"
-
-DESCRIPTION="Leo: Literate Editor with Outlines"
-HOMEPAGE="http://leo.sourceforge.net/ http://pypi.python.org/pypi/leo"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-RDEPEND="app-text/silvercity
- dev-python/PyQt4[X]"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${P}-fix_syntax_errors.patch"
-}
-
-src_install() {
- distutils_src_install
- dohtml -r leo/doc/html/* || die "dohtml failed"
-}
diff --git a/app-editors/leo/leo-5.0.ebuild b/app-editors/leo/leo-5.0.ebuild
new file mode 100644
index 000000000000..e5330a9bb0fd
--- /dev/null
+++ b/app-editors/leo/leo-5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/leo/leo-5.0.ebuild,v 1.1 2014/12/06 11:10:19 idella4 Exp $
+
+EAPI=5
+
+# Not py3 prepared
+# https://bugs.launchpad.net/leo-editor/+bug/1399895
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQUIRED_USE="tk"
+
+inherit distutils-r1
+
+MY_P="Leo-${PV}-final"
+MY_PN="Leo${PV}-final"
+
+DESCRIPTION="Leo: Literate Editor with Outlines"
+HOMEPAGE="http://leo.sourceforge.net/ http://pypi.python.org/pypi/leo"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND="app-text/silvercity
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_PN}"
+
+python_install_all() {
+ use doc && local HTML_DOCS=( leo/doc/html/. )
+ distutils-r1_python_install_all
+}