summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorParag Mehta <pm@gentoo.org>2001-10-04 03:33:33 +0000
committerParag Mehta <pm@gentoo.org>2001-10-04 03:33:33 +0000
commit0153441c02bbd54a9bd523901a7fa7f3b0638376 (patch)
tree1353b35539196f2917239fd696e023f23a24bb80 /app-editors/nano
parentAdd Anjuta #2 .. forgot to rm -rf CVS when cp -R from dev-utils (diff)
downloadgentoo-2-0153441c02bbd54a9bd523901a7fa7f3b0638376.tar.gz
gentoo-2-0153441c02bbd54a9bd523901a7fa7f3b0638376.tar.bz2
gentoo-2-0153441c02bbd54a9bd523901a7fa7f3b0638376.zip
new stable release with some update in cut.c. for more see Changelog.
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/files/digest-nano-1.0.51
-rw-r--r--app-editors/nano/nano-1.0.5.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-editors/nano/files/digest-nano-1.0.5 b/app-editors/nano/files/digest-nano-1.0.5
new file mode 100644
index 000000000000..73e929f7da8f
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.0.5
@@ -0,0 +1 @@
+MD5 6673330d15c1d08d826215e8fefe443a nano-1.0.5.tar.gz
diff --git a/app-editors/nano/nano-1.0.5.ebuild b/app-editors/nano/nano-1.0.5.ebuild
new file mode 100644
index 000000000000..c7b7b1ab1e89
--- /dev/null
+++ b/app-editors/nano/nano-1.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Parag Mehta <pm@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.0.5.ebuild,v 1.1 2001/10/04 03:33:33 pm Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A Clone of PICO with more Fuctions in a smaller Size"
+#SRC_URI="http://www.nano-editor.org/dist/v1.0/${A}"
+SRC_URI="http://www.nano-editor.org/dist/v1.0/${P}.tar.gz"
+HOMEPAGE="http://www.nano-editor.org"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=sys-libs/ncurses-5.2"
+
+src_compile() {
+ cd ${S}
+ try ./configure --prefix=/usr --enable-extra --mandir=/usr/share/man \
+ --infodir=/usr/share/info
+ try make
+}
+
+src_install () {
+ cd ${S}
+ try make DESTDIR=${D} install
+ if [ -z "`use bootcd`" ] && [ -z "`use build`" ]
+ then
+ dodoc COPYING ChangeLog README
+ else
+ rm -rf ${D}/usr/share
+ fi
+}