summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-15 02:31:14 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-15 02:31:14 +0000
commita68f61848b3fc2162fdd9b78262359437bc96e10 (patch)
treedc3abc50134c0165e498e68cbe2a39a2d57ab9d8 /app-editors/nano
parentold (diff)
downloadgentoo-2-a68f61848b3fc2162fdd9b78262359437bc96e10.tar.gz
gentoo-2-a68f61848b3fc2162fdd9b78262359437bc96e10.tar.bz2
gentoo-2-a68f61848b3fc2162fdd9b78262359437bc96e10.zip
Fix from upstream.
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/ChangeLog8
-rw-r--r--app-editors/nano/files/digest-nano-1.3.12-r13
-rw-r--r--app-editors/nano/files/nano-1.3.12-scroll.patch39
-rw-r--r--app-editors/nano/nano-1.3.12-r1.ebuild74
4 files changed, 123 insertions, 1 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index 9bfbbf08eae2..62a66e1741c1 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/nano
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.117 2006/07/09 02:13:57 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.118 2006/07/15 02:31:14 vapier Exp $
+
+*nano-1.3.12-r1 (15 Jul 2006)
+
+ 15 Jul 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/nano-1.3.12-scroll.patch, +nano-1.3.12-r1.ebuild:
+ Fix from upstream.
09 Jul 2006; Joshua Kinard <kumba@gentoo.org> nano-1.3.11-r2.ebuild:
Marked stable on mips.
diff --git a/app-editors/nano/files/digest-nano-1.3.12-r1 b/app-editors/nano/files/digest-nano-1.3.12-r1
new file mode 100644
index 000000000000..f1444b97207b
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-1.3.12-r1
@@ -0,0 +1,3 @@
+MD5 1450892aac7ae31d00817d42636d9a0d nano-1.3.12.tar.gz 1250777
+RMD160 f594c4805af873718828b0aedba06c1f89946458 nano-1.3.12.tar.gz 1250777
+SHA256 f5537b8a988618fa8524b6a4b0a6950184d37db983b4521ad843b98845da571c nano-1.3.12.tar.gz 1250777
diff --git a/app-editors/nano/files/nano-1.3.12-scroll.patch b/app-editors/nano/files/nano-1.3.12-scroll.patch
new file mode 100644
index 000000000000..f5d533633224
--- /dev/null
+++ b/app-editors/nano/files/nano-1.3.12-scroll.patch
@@ -0,0 +1,39 @@
+fix from upstream
+
+diff -ur nano-1.3.12/src/move.c nano-1.3.12-fixed/src/move.c
+--- nano-1.3.12/src/move.c 2006-05-21 22:08:49.000000000 -0400
++++ nano-1.3.12-fixed/src/move.c 2006-07-06 17:01:03.000000000 -0400
+@@ -521,6 +521,16 @@
+
+ /* Scroll the edit window up one line. */
+ edit_scroll(UP, 1);
++
++ /* If we're not on the first line of the edit window, update the
++ * line we were on before and the line we're on now. The former
++ * needs to be redrawn if we're not on the first page, and the
++ * latter needs to be drawn unconditionally. */
++ if (openfile->current_y > 0) {
++ if (need_vertical_update(0))
++ update_line(openfile->current->next, 0);
++ update_line(openfile->current, openfile->current_x);
++ }
+ }
+ #endif /* !NANO_TINY */
+
+@@ -574,6 +584,16 @@
+
+ /* Scroll the edit window down one line. */
+ edit_scroll(DOWN, 1);
++
++ /* If we're not on the last line of the edit window, update the line
++ * we were on before and the line we're on now. The former needs to
++ * be redrawn if we're not on the first page, and the latter needs
++ * to be drawn unconditionally. */
++ if (openfile->current_y < editwinrows - 1) {
++ if (need_vertical_update(0))
++ update_line(openfile->current->prev, 0);
++ update_line(openfile->current, openfile->current_x);
++ }
+ }
+ #endif /* !NANO_TINY */
+
diff --git a/app-editors/nano/nano-1.3.12-r1.ebuild b/app-editors/nano/nano-1.3.12-r1.ebuild
new file mode 100644
index 000000000000..780808dc4028
--- /dev/null
+++ b/app-editors/nano/nano-1.3.12-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.3.12-r1.ebuild,v 1.1 2006/07/15 02:31:14 vapier Exp $
+
+#ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
+#ECVS_MODULE="nano"
+#ECVS_AUTH="pserver"
+#ECVS_USER="anonymous"
+#inherit cvs
+inherit eutils
+
+MY_P=${PN}-${PV/_}
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+SRC_URI="http://www.nano-editor.org/dist/v1.3/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="build debug justify minimal ncurses nls slang spell unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ !ncurses? ( slang? ( sys-libs/slang ) )"
+PROVIDE="virtual/editor"
+
+src_compile() {
+ if [[ ! -e configure ]] ; then
+ ./autogen.sh || die "autogen failed"
+ fi
+
+ local myconf=""
+ use ncurses \
+ && myconf="--without-slang" \
+ || myconf="${myconf} $(use_with slang)"
+
+ econf \
+ --bindir=/bin \
+ --enable-color \
+ --enable-multibuffer \
+ --enable-nanorc \
+ --disable-wrapping-as-root \
+ $(use_enable spell) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode utf8) \
+ $(use_enable minimal tiny) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use build ; then
+ rm -rf "${D}"/usr/share
+ else
+ cat "${FILESDIR}"/nanorc-* >> doc/nanorc.sample
+ dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+ fi
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}
+
+pkg_postinst() {
+ einfo "More helpful info about nano, visit the GDP page:"
+ einfo "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
+}