summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-03-16 10:18:42 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-03-16 10:18:42 +0000
commit607794852305aadc16b38a3632e804f5f03860bf (patch)
tree9185f35c42781d251a8b5d53c49d2c858095dfda /app-editors/ne
parentBump (diff)
downloadgentoo-2-607794852305aadc16b38a3632e804f5f03860bf.tar.gz
gentoo-2-607794852305aadc16b38a3632e804f5f03860bf.tar.bz2
gentoo-2-607794852305aadc16b38a3632e804f5f03860bf.zip
Bump
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/ne')
-rw-r--r--app-editors/ne/ChangeLog9
-rw-r--r--app-editors/ne/ne-2.3.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/app-editors/ne/ChangeLog b/app-editors/ne/ChangeLog
index 3a6ecbeccef6..e6a0c01b516c 100644
--- a/app-editors/ne/ChangeLog
+++ b/app-editors/ne/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/ne
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ChangeLog,v 1.43 2011/03/12 13:37:40 swegener Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ChangeLog,v 1.44 2012/03/16 10:18:42 patrick Exp $
+
+*ne-2.3 (16 Mar 2012)
+
+ 16 Mar 2012; Patrick Lauer <patrick@gentoo.org> +ne-2.3.ebuild:
+ Bump
12 Mar 2011; Sven Wegener <swegener@gentoo.org> -ne-1.42.ebuild,
-ne-1.43.ebuild:
diff --git a/app-editors/ne/ne-2.3.ebuild b/app-editors/ne/ne-2.3.ebuild
new file mode 100644
index 000000000000..1daa42a82176
--- /dev/null
+++ b/app-editors/ne/ne-2.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ne-2.3.ebuild,v 1.1 2012/03/16 10:18:42 patrick Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="the nice editor, easy to use for the beginner and powerful for the wizard"
+HOMEPAGE="http://ne.dsi.unimi.it/"
+SRC_URI="http://ne.dsi.unimi.it/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_prepare() {
+ sed -i -e 's/-O3//' src/makefile || die
+ epatch "${FILESDIR}"/${PN}-2.1-asneeded.patch
+}
+
+src_compile() {
+ emake \
+ -j1 \
+ -C src \
+ ne \
+ OPTS="${CFLAGS}" \
+ CC="$(tc-getCC)" \
+ NE_GLOBAL_DIR="/usr/share/ne" \
+ || die "emake failed"
+}
+
+src_install() {
+ dobin src/ne || die "dobin failed"
+
+ insinto /usr/share/ne/syntax
+ doins syntax/*.jsf || die "doins failed"
+
+ doman doc/ne.1 || die "doman failed"
+ dohtml -r doc/html/. || die "dohtml failed"
+ dodoc CHANGES README doc/*.{txt,pdf,texinfo} doc/default.* || die "dodoc failed"
+}