summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-12-21 15:36:04 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-12-21 15:36:04 +0000
commit1d7eebcd1077a0ad941cfc3b875a386af26936f2 (patch)
treef57491524464a5310c44e99d9e57177c866cf86a /app-editors/qxmledit
parentsparc stable wrt #281643 (diff)
downloadgentoo-2-1d7eebcd1077a0ad941cfc3b875a386af26936f2.tar.gz
gentoo-2-1d7eebcd1077a0ad941cfc3b875a386af26936f2.tar.bz2
gentoo-2-1d7eebcd1077a0ad941cfc3b875a386af26936f2.zip
Migrate to qt4-r2 eclass. Remove old ebuild
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/qxmledit')
-rw-r--r--app-editors/qxmledit/ChangeLog8
-rw-r--r--app-editors/qxmledit/qxmledit-0.3.0-r1.ebuild (renamed from app-editors/qxmledit/qxmledit-0.3.0.ebuild)19
2 files changed, 13 insertions, 14 deletions
diff --git a/app-editors/qxmledit/ChangeLog b/app-editors/qxmledit/ChangeLog
index d0b60473f7cf..e6f1a00fdc4e 100644
--- a/app-editors/qxmledit/ChangeLog
+++ b/app-editors/qxmledit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/qxmledit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.1 2009/06/09 23:29:28 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/ChangeLog,v 1.2 2009/12/21 15:36:04 hwoarang Exp $
+
+*qxmledit-0.3.0-r1 (21 Dec 2009)
+
+ 21 Dec 2009; <hwoarang@gentoo.org> -qxmledit-0.3.0.ebuild,
+ +qxmledit-0.3.0-r1.ebuild:
+ Migrate to qt4-r2 eclass. Remove old ebuild to 'force' testing
*qxmledit-0.3.0 (09 Jun 2009)
diff --git a/app-editors/qxmledit/qxmledit-0.3.0.ebuild b/app-editors/qxmledit/qxmledit-0.3.0-r1.ebuild
index ac941409831c..2404165316d4 100644
--- a/app-editors/qxmledit/qxmledit-0.3.0.ebuild
+++ b/app-editors/qxmledit/qxmledit-0.3.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/qxmledit-0.3.0.ebuild,v 1.1 2009/06/09 23:29:28 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qxmledit/qxmledit-0.3.0-r1.ebuild,v 1.1 2009/12/21 15:36:04 hwoarang Exp $
EAPI="2"
-inherit qt4
+inherit qt4-r2
MY_PN="${PN}-src"
MY_P="${MY_PN}-${PV}"
@@ -23,6 +23,9 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${P}/src/"
+DOCS="AUTHORS NEWS README TODO"
+DOCSDIR="${WORKDIR}/${P}/"
+
src_prepare(){
# fix installation path
sed -i "/^target.path/ s/\/opt\/${PN}/\/usr\/bin/" QXmlEdit.pro || \
@@ -30,15 +33,5 @@ src_prepare(){
# fix translations
sed -i "/^translations.path/ s/\/opt/\/usr\/share/" QXmlEdit.pro || \
die "failed to fix translations"
- qt4_src_prepare
-}
-
-src_configure(){
- eqmake4 QXmlEdit.pro
-}
-
-src_install(){
- emake INSTALL_ROOT="${D}" install || die "emake install failed"
- cd ../
- dodoc AUTHORS NEWS README TODO || die "dodoc failed"
+ qt4-r2_src_prepare
}