summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-04-21 18:02:15 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-04-21 18:02:15 +0000
commit94a41dc0c2d03735b52bf15db7e10a93e4c8a707 (patch)
treef0eba1203df5ad4e4bc4ab607190f9473df784bb /app-editors/scite
parentstable x86, bug 313821 (diff)
downloadgentoo-2-94a41dc0c2d03735b52bf15db7e10a93e4c8a707.tar.gz
gentoo-2-94a41dc0c2d03735b52bf15db7e10a93e4c8a707.tar.bz2
gentoo-2-94a41dc0c2d03735b52bf15db7e10a93e4c8a707.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/scite')
-rw-r--r--app-editors/scite/ChangeLog7
-rw-r--r--app-editors/scite/scite-2.11.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/app-editors/scite/ChangeLog b/app-editors/scite/ChangeLog
index 6f5f8da269c1..999539573b40 100644
--- a/app-editors/scite/ChangeLog
+++ b/app-editors/scite/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/scite
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.93 2010/04/18 17:25:21 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/ChangeLog,v 1.94 2010/04/21 18:02:15 nelchael Exp $
+
+*scite-2.11 (21 Apr 2010)
+
+ 21 Apr 2010; Krzysztof Pawlik <nelchael@gentoo.org> +scite-2.11.ebuild:
+ Version bump.
18 Apr 2010; <nixnut@gentoo.org> scite-2.03.ebuild:
ppc stable #312851
diff --git a/app-editors/scite/scite-2.11.ebuild b/app-editors/scite/scite-2.11.ebuild
new file mode 100644
index 000000000000..23dc85bad855
--- /dev/null
+++ b/app-editors/scite/scite-2.11.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-2.11.ebuild,v 1.1 2010/04/21 18:02:15 nelchael Exp $
+
+inherit toolchain-funcs eutils
+
+MY_PV=${PV//./}
+DESCRIPTION="A very powerful editor for programmers"
+HOMEPAGE="http://scintilla.sourceforge.net/SciTE.html"
+SRC_URI="mirror://sourceforge/scintilla/${PN}${MY_PV}.tgz"
+
+LICENSE="Scintilla"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="lua"
+
+RDEPEND=">=x11-libs/gtk+-2
+ lua? ( >=dev-lang/lua-5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}/gtk"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/scintilla/gtk"
+ sed -i makefile \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e "s#-Os##" \
+ || die "error patching makefile"
+
+ cd "${WORKDIR}/scite/gtk"
+ sed -i makefile \
+ -e "s#-rdynamic#-rdynamic ${LDFLAGS}#" \
+ || die "error patching makefile"
+
+ cd "${S}"
+ sed -i makefile \
+ -e 's#usr/local#usr#g' \
+ -e 's#/gnome/apps/Applications#/applications#' \
+ -e "s#^CXXFLAGS=#CXXFLAGS=${CXXFLAGS} #" \
+ -e "s#^\(CXXFLAGS=.*\)-Os#\1#" \
+ -e "s#^CC =\(.*\)#CC = $(tc-getCXX)#" \
+ -e 's#${D}##' \
+ -e 's#-g root#-g 0#' \
+ -e "s#-Os##" \
+ || die "error patching makefile"
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}/${PN}-1.79-install.patch"
+ epatch "${FILESDIR}/${PN}-1.79-no-lua.patch"
+}
+
+src_compile() {
+ make -C ../../scintilla/gtk || die "prep make failed"
+ if use lua; then
+ emake || die "make failed"
+ else
+ emake NO_LUA=1 || die "make failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/{pixmaps,applications}
+
+ make prefix="${D}/usr" install || die
+
+ # we have to keep this because otherwise it'll break upgrading
+ mv "${D}/usr/bin/SciTE" "${D}/usr/bin/scite"
+ dosym /usr/bin/scite /usr/bin/SciTE
+
+ # replace .desktop file with our own working version
+ insinto /usr/share/applications
+ rm -f "${D}/usr/share/applications/SciTE.desktop"
+ doins "${FILESDIR}/scite.desktop"
+
+ doman ../doc/scite.1
+ dodoc ../README
+}