summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-04-20 21:02:06 +0000
committerTim Harder <radhermit@gentoo.org>2011-04-20 21:02:06 +0000
commit126c0e39d6c7c8d29619a083ca9bbc4c12fafbe9 (patch)
treedc27376dbdec86ff1695609e41e0ebc9cf37e602 /app-editors/vile/vile-9.8e.ebuild
parentVersion bump to latest. Drop older. (diff)
downloadgentoo-2-126c0e39d6c7c8d29619a083ca9bbc4c12fafbe9.tar.gz
gentoo-2-126c0e39d6c7c8d29619a083ca9bbc4c12fafbe9.tar.bz2
gentoo-2-126c0e39d6c7c8d29619a083ca9bbc4c12fafbe9.zip
Version bump. Update to EAPI 4.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'app-editors/vile/vile-9.8e.ebuild')
-rw-r--r--app-editors/vile/vile-9.8e.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-editors/vile/vile-9.8e.ebuild b/app-editors/vile/vile-9.8e.ebuild
new file mode 100644
index 000000000000..fc4eb4d612cb
--- /dev/null
+++ b/app-editors/vile/vile-9.8e.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vile/vile-9.8e.ebuild,v 1.1 2011/04/20 21:02:06 radhermit Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+HOMEPAGE="http://invisible-island.net/vile/"
+SRC_URI="ftp://invisible-island.net/vile/current/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="perl"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ app-admin/eselect-vi"
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ $(use_with perl )
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc CHANGES* README doc/*.doc
+ dohtml doc/*.html
+}
+
+pkg_postinst() {
+ einfo "Setting /usr/bin/vi symlink"
+ eselect vi set "${PN}"
+}
+
+pkg_postrm() {
+ einfo "Updating /usr/bin/vi symlink"
+ eselect vi update
+}