summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-04-15 19:30:32 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-04-15 19:30:32 +0000
commite9efb6e9788465e688384f8dfe1455823c413ce2 (patch)
tree16b68f4fb56a3d114f1efef7c1bf2a05555310ad /app-editors/vim-core
parentMoved to new Python ABI stuff, #315459 (diff)
downloadgentoo-2-e9efb6e9788465e688384f8dfe1455823c413ce2.tar.gz
gentoo-2-e9efb6e9788465e688384f8dfe1455823c413ce2.tar.bz2
gentoo-2-e9efb6e9788465e688384f8dfe1455823c413ce2.zip
Import Gentoo Prefix changes, convert to EAPI3, add keywords. bug 310991
(Portage version: 2.1.8.3/cvs/Linux armv7l)
Diffstat (limited to 'app-editors/vim-core')
-rw-r--r--app-editors/vim-core/ChangeLog6
-rw-r--r--app-editors/vim-core/files/vimrc-r414
-rw-r--r--app-editors/vim-core/vim-core-7.2.402.ebuild4
3 files changed, 14 insertions, 10 deletions
diff --git a/app-editors/vim-core/ChangeLog b/app-editors/vim-core/ChangeLog
index 4ebe04a513d1..fe19cc35da6c 100644
--- a/app-editors/vim-core/ChangeLog
+++ b/app-editors/vim-core/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/vim-core
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.327 2010/03/17 22:00:16 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.328 2010/04/15 19:30:32 darkside Exp $
+
+ 15 Apr 2010; Jeremy Olexa <darkside@gentoo.org> vim-core-7.2.402.ebuild,
+ files/vimrc-r4:
+ Import Gentoo Prefix changes, convert to EAPI3, add keywords. bug 310991
*vim-core-7.2.402 (17 Mar 2010)
diff --git a/app-editors/vim-core/files/vimrc-r4 b/app-editors/vim-core/files/vimrc-r4
index 5273ff3248e2..f54e5a39f909 100644
--- a/app-editors/vim-core/files/vimrc-r4
+++ b/app-editors/vim-core/files/vimrc-r4
@@ -2,7 +2,7 @@ scriptencoding utf-8
" ^^ Please leave the above line at the start of the file.
" Default configuration file for Vim
-" $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/files/vimrc-r4,v 1.2 2010/03/09 18:47:21 lack Exp $
+" $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/files/vimrc-r4,v 1.3 2010/04/15 19:30:32 darkside Exp $
" Written by Aron Griffis <agriffis@gentoo.org>
" Modified by Ryan Phillips <rphillips@gentoo.org>
@@ -126,10 +126,10 @@ endif
" {{{ Fix &shell, see bug #101665.
if "" == &shell
- if executable("/bin/bash")
- set shell=/bin/bash
- elseif executable("/bin/sh")
- set shell=/bin/sh
+ if executable("@GENTOO_PORTAGE_EPREFIX@/bin/bash")
+ set shell=@GENTOO_PORTAGE_EPREFIX@/bin/bash
+ elseif executable("@GENTOO_PORTAGE_EPREFIX@/bin/sh")
+ set shell=@GENTOO_PORTAGE_EPREFIX@/bin/sh
endif
endif
"}}}
@@ -191,8 +191,8 @@ endif " has("autocmd")
" }}}
" {{{ vimrc.local
-if filereadable("/etc/vim/vimrc.local")
- source /etc/vim/vimrc.local
+if filereadable("@GENTOO_PORTAGE_EPREFIX@/etc/vim/vimrc.local")
+ source @GENTOO_PORTAGE_EPREFIX@/etc/vim/vimrc.local
endif
" }}}
diff --git a/app-editors/vim-core/vim-core-7.2.402.ebuild b/app-editors/vim-core/vim-core-7.2.402.ebuild
index 74871e749dd4..acab0751ada9 100644
--- a/app-editors/vim-core/vim-core-7.2.402.ebuild
+++ b/app-editors/vim-core/vim-core-7.2.402.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-7.2.402.ebuild,v 1.1 2010/03/17 22:00:16 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-7.2.402.ebuild,v 1.2 2010/04/15 19:30:32 darkside Exp $
-EAPI=2
+EAPI=3
inherit vim
VIM_VERSION="7.2"