summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-12-22 18:34:03 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-12-22 18:34:03 +0000
commit76a3c1ffb6265c0b551c685c5912f17b577fed4c (patch)
tree3efcfccc8da1622b627d58bd5d30789a72cfec55 /app-editors/xvile
parentnew version; obey USE="-ssl" (diff)
downloadgentoo-2-76a3c1ffb6265c0b551c685c5912f17b577fed4c.tar.gz
gentoo-2-76a3c1ffb6265c0b551c685c5912f17b577fed4c.tar.bz2
gentoo-2-76a3c1ffb6265c0b551c685c5912f17b577fed4c.zip
bug 12469 gets all the thanks - compiles with perl 5.8
Diffstat (limited to 'app-editors/xvile')
-rw-r--r--app-editors/xvile/ChangeLog11
-rw-r--r--app-editors/xvile/files/digest-xvile-9.3h9
-rw-r--r--app-editors/xvile/xvile-9.3h.ebuild59
3 files changed, 78 insertions, 1 deletions
diff --git a/app-editors/xvile/ChangeLog b/app-editors/xvile/ChangeLog
index 9fb24edff9c3..8df1e3efdc87 100644
--- a/app-editors/xvile/ChangeLog
+++ b/app-editors/xvile/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-editors/xvile
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.1 2002/02/01 21:53:01 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/ChangeLog,v 1.2 2002/12/22 18:34:03 mcummings Exp $
+
+*xvile-9.3h (22 Dec 2002)
+
+ 22 Dec 2002; Michael Cummings <mcummings@gentoo.org> xvile-9.3h.ebuild:
+
+ Many thanks go to jbooth (jbooth@uiuc.edu) in bug 12469 for this
+ ebuild. This version of vile will work with perl 5.8, where the
+ previous versions would not. Will unmask for x86 when perl 5.8 is
+ unmasked.
*xvile-9.2r (1 Feb 2002)
diff --git a/app-editors/xvile/files/digest-xvile-9.3h b/app-editors/xvile/files/digest-xvile-9.3h
new file mode 100644
index 000000000000..e0b58ffbfc4f
--- /dev/null
+++ b/app-editors/xvile/files/digest-xvile-9.3h
@@ -0,0 +1,9 @@
+MD5 9d8f396a936986d5a3542e40568886c8 vile-9.3.tgz 1474140
+MD5 e6d6c53a98b48119041053eb82ae6129 vile-9.3a.patch.gz 10571
+MD5 69a7ce690418fef171461bc170ba1471 vile-9.3b.patch.gz 9336
+MD5 a9d9b2223ae56a51310c2c0973129259 vile-9.3c.patch.gz 7697
+MD5 4b2b28900bd0035e9ca46d3be5e7dc9c vile-9.3d.patch.gz 40497
+MD5 c2241ad6e5a70d12d7415401aaec0b4f vile-9.3e.patch.gz 71499
+MD5 67bb75078e1ef009ee4b6928c396519a vile-9.3f.patch.gz 28732
+MD5 0231e8146ad6ff7ba6cec2635afa0c1f vile-9.3g.patch.gz 7645
+MD5 1e7d5a6dafb1223ae5e03917737f0096 vile-9.3h.patch.gz 47116
diff --git a/app-editors/xvile/xvile-9.3h.ebuild b/app-editors/xvile/xvile-9.3h.ebuild
new file mode 100644
index 000000000000..5b7dec63aad5
--- /dev/null
+++ b/app-editors/xvile/xvile-9.3h.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.3h.ebuild,v 1.1 2002/12/22 18:34:03 mcummings Exp $
+
+IUSE="perl"
+
+S=${WORKDIR}/vile-9.3
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+SRC_URI="ftp://ftp.phred.org/pub/vile/vile-9.3.tgz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3a.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3b.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3c.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3d.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3e.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3f.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3g.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3h.patch.gz"
+
+HOMEPAGE="http://www.clark.net/pub/dickey/vile/vile.html"
+
+DEPEND="virtual/glibc
+ sys-devel/flex
+ virtual/x11
+ =app-editors/vile-9.3h"
+
+RDEPEND="perl? ( sys-devel/perl )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+src_unpack() {
+ unpack vile-9.3.tgz
+
+ cd ${S}
+ local i
+ for i in a b c d e f g h
+ do
+ gunzip -c ${DISTDIR}/vile-9.3$i.patch.gz | patch -p1
+ done
+}
+
+src_compile() {
+ local myconf
+ use perl && myconf="--with-perl"
+
+ ./configure --prefix=/usr --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --with-x \
+ $myconf || die
+
+ emake || die
+}
+
+src_install () {
+ dobin xvile
+ make DESTDIR=${D} install || die
+ dodoc CHANGES* COPYING MANIFEST INSTALL README* doc/*
+}