summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-02-03 11:25:24 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-02-03 11:25:24 +0000
commit1ee45e71bcd45ad575c0067857cf068305d8eadd (patch)
treed275c02e30487b6f74941b23e114382e570c3850 /app-editors
parentdetermine compression suffix correctly and finally (diff)
downloadgentoo-2-1ee45e71bcd45ad575c0067857cf068305d8eadd.tar.gz
gentoo-2-1ee45e71bcd45ad575c0067857cf068305d8eadd.tar.bz2
gentoo-2-1ee45e71bcd45ad575c0067857cf068305d8eadd.zip
determine compression suffix correctly and finally
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs/ChangeLog5
-rw-r--r--app-editors/emacs/emacs-21.4-r6.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index 179e97a5f8dc..a6daf0d1a04e 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/emacs
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.115 2007/02/02 20:14:12 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.116 2007/02/03 11:25:24 opfer Exp $
+
+ 03 Feb 2007; Christian Faulhammer <opfer@gentoo.org> emacs-21.4-r6.ebuild:
+ determine compression suffix correctly and finally
02 Feb 2007; Christian Faulhammer <opfer@gentoo.org> emacs-21.4-r6.ebuild:
hopefully fix man page symlinks again, part II
diff --git a/app-editors/emacs/emacs-21.4-r6.ebuild b/app-editors/emacs/emacs-21.4-r6.ebuild
index 4491936c1a16..804fd2529cbc 100644
--- a/app-editors/emacs/emacs-21.4-r6.ebuild
+++ b/app-editors/emacs/emacs-21.4-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r6.ebuild,v 1.3 2007/02/02 20:14:12 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.4-r6.ebuild,v 1.4 2007/02/03 11:25:24 opfer Exp $
inherit flag-o-matic eutils alternatives toolchain-funcs
@@ -159,6 +159,9 @@ src_install() {
}
update-alternatives() {
+ # extract the suffix of the manpages to determine the correct compression program
+ local suffix=`ls /usr/share/man/man1/emacs.emacs-* |sed s/".*\."//g|tail -n 1`
+
# this creates symlinks for binaries and man pages, so the correct ones in a slotted
# environment can be accessed
for i in emacs emacsclient etags ctags b2m ebrowse \
@@ -168,7 +171,7 @@ update-alternatives() {
for j in emacs emacsclient etags ctags
do
- alternatives_auto_makesym "/usr/share/man/man1/$j.1.gz" "/usr/share/man/man1/$j.emacs-${SLOT}*"
+ alternatives_auto_makesym "/usr/share/man/man1/$j.1.${suffix}" "/usr/share/man/man1/$j.emacs-*"
done
}