summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2002-12-24 11:01:57 +0000
committerMartin Holzer <mholzer@gentoo.org>2002-12-24 11:01:57 +0000
commit22d6a292339d2cdc745050abf3d82a0f5617656a (patch)
tree0a602e259f61b71c1906796b05056e3a64f8c256 /app-editors
parentNew portage-2.0.47_pre2 (diff)
downloadgentoo-2-22d6a292339d2cdc745050abf3d82a0f5617656a.tar.gz
gentoo-2-22d6a292339d2cdc745050abf3d82a0f5617656a.tar.bz2
gentoo-2-22d6a292339d2cdc745050abf3d82a0f5617656a.zip
Version pump submitted by Mark Hollomon #12625.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ted/ChangeLog9
-rw-r--r--app-editors/ted/files/digest-ted-2.121
-rw-r--r--app-editors/ted/ted-2.12.ebuild66
3 files changed, 74 insertions, 2 deletions
diff --git a/app-editors/ted/ChangeLog b/app-editors/ted/ChangeLog
index 71e4120f6662..09bca7534f06 100644
--- a/app-editors/ted/ChangeLog
+++ b/app-editors/ted/ChangeLog
@@ -1,15 +1,20 @@
# ChangeLog for app-editors/ted
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+*ted-2.12 (24 Dec 2002)
+
+ 24 Dec 2002; Martin Holzer <mholzer@gentoo.org> : ted-2.11.ebuild files/digest-ted-2.12 ChangeLog :
+ Version pump submitted by Mark Hollomon #12625.
+
+
*ted-2.11 (09 Jul 2002)
+
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
06 Aug 2002; Mark Guertin <gerk@gentoo.org> :
Added ppc to keywords
09 Jul 2002; Phil Bordelon <sunflare@gentoo.org> ted-2.11.ebuild :
-
New package. Original ebuild submitted by Mark Hollomon
<markholloman@comcast.net>--see Bug #3668. Cleaned it up,
lintool'd and repoman'd.
diff --git a/app-editors/ted/files/digest-ted-2.12 b/app-editors/ted/files/digest-ted-2.12
new file mode 100644
index 000000000000..56e0df89a9b0
--- /dev/null
+++ b/app-editors/ted/files/digest-ted-2.12
@@ -0,0 +1 @@
+MD5 4587e3218dd8aa1b1bae8a97b3b9eef6 ted-2.12.src.tar.gz 2560159
diff --git a/app-editors/ted/ted-2.12.ebuild b/app-editors/ted/ted-2.12.ebuild
new file mode 100644
index 000000000000..0cfb774c5ff0
--- /dev/null
+++ b/app-editors/ted/ted-2.12.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ted/ted-2.12.ebuild,v 1.1 2002/12/24 11:01:57 mholzer Exp $
+
+DESCRIPTION="ted is an X-based rich text editor."
+HOMEPAGE="http://www.nllgg.nl/Ted"
+SRC_URI="ftp://ftp.nluug.nl/pub/editors/ted/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
+
+DEPEND=">=x11-libs/openmotif-2.1.30
+ >=media-libs/tiff-3.5.7
+ >=media-libs/jpeg-6b
+ >=media-libs/libpng-1.2.3
+ >=media-libs/xpm-3.4k"
+
+S="${WORKDIR}/Ted-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/Ted
+ mv makefile.in makefile.in.orig
+ sed 's@^CFLAGS=@CFLAGS= -DDOCUMENT_DIR=\\"/usr/share/doc/${PF}/Ted/\\"@' makefile.in.orig > makefile.in
+}
+
+src_compile() {
+ cd ${S} || die "where are we? `pwd`"
+
+ for dir in Ted tedPackage appFrame appUtil ind bitmap libreg; do
+ (
+ cd ${dir}
+ econf --cache-file=../config.cache
+ )
+ done
+
+ # The makefile doesn't really allow parallel make, but it does
+ # no harm either.
+ emake DEF_AFMDIR=-DAFMDIR=\\\"/usr/share/Ted/afm\\\" \
+ DEF_INDDIR=-DINDDIR=\\\"/usr/share/Ted/ind\\\" \
+ package.shared || die "couldnt emake"
+}
+
+src_install() {
+ cd ${BUILDDIR}
+
+ mkdir ${T}/pkg
+ cd ${T}/pkg || die "Couldn't cd to package"
+ tar --use=gzip -xvf ${S}/tedPackage/Ted*.tar.gz || die "couldnt unpack tedPackage/Ted*.tar.gz"
+
+ cd ${BUILDDIR}
+
+ dodir /usr/share/Ted
+ cp -R ${T}/pkg/afm ${D}/usr/share/Ted/afm || die "couldnt cp temp/pkg/afm"
+ cp -R ${T}/pkg/ind ${D}/usr/share/Ted/ind || die "couldnt cp temp/pkg/ind"
+
+ exeinto /usr/bin
+ doexe ${T}/pkg/bin/* || die "couldnt doexe temp/pkg/bin/*"
+
+ dodir /usr/share/doc/${P}
+ cp -R ${T}/pkg/Ted ${D}/usr/share/doc/${P} || die "couldnt cp temp/pkg/Ted"
+
+ rm -rf ${T}
+}
+