summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-27 08:37:57 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-27 08:37:57 +0000
commit2bd35c210795badd18feb28ac25a576fc23f063e (patch)
treec8b11586062ed842dbdca127591e8ca0b84e5d10 /app-editors
parentUpdate gtkmm dependency in accordance with real requirements, fixes #311421. (diff)
downloadgentoo-2-2bd35c210795badd18feb28ac25a576fc23f063e.tar.gz
gentoo-2-2bd35c210795badd18feb28ac25a576fc23f063e.tar.bz2
gentoo-2-2bd35c210795badd18feb28ac25a576fc23f063e.zip
Version bump wrt #311573 by Michael Weber.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mlview/ChangeLog8
-rw-r--r--app-editors/mlview/files/mlview-0.9.0-desktop.patch20
-rw-r--r--app-editors/mlview/files/mlview-0.9.0-gcc44.patch82
-rw-r--r--app-editors/mlview/mlview-0.9.0.ebuild51
4 files changed, 160 insertions, 1 deletions
diff --git a/app-editors/mlview/ChangeLog b/app-editors/mlview/ChangeLog
index acfbd5943463..3a7f017cbbda 100644
--- a/app-editors/mlview/ChangeLog
+++ b/app-editors/mlview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/mlview
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mlview/ChangeLog,v 1.24 2010/01/01 21:05:06 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mlview/ChangeLog,v 1.25 2010/03/27 08:37:57 ssuominen Exp $
+
+*mlview-0.9.0 (27 Mar 2010)
+
+ 27 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> +mlview-0.9.0.ebuild,
+ +files/mlview-0.9.0-desktop.patch, +files/mlview-0.9.0-gcc44.patch:
+ Version bump wrt #311573 by Michael Weber.
01 Jan 2010; Christian Faulhammer <fauli@gentoo.org> mlview-0.8-r1.ebuild:
Transfer Prefix keywords
diff --git a/app-editors/mlview/files/mlview-0.9.0-desktop.patch b/app-editors/mlview/files/mlview-0.9.0-desktop.patch
new file mode 100644
index 000000000000..3906e6f30c4a
--- /dev/null
+++ b/app-editors/mlview/files/mlview-0.9.0-desktop.patch
@@ -0,0 +1,20 @@
+--- mlview.desktop.in
++++ mlview.desktop.in
+@@ -1,13 +1,10 @@
+ [Desktop Entry]
+-Version=0.9.4
+-Encoding=UTF-8
+ Type=Application
+ Name=MlView XML Editor
+ GenericName=MlView Generic XML Editor
+-Categories=Application;Development;
++Categories=Development;
+ Comment=A generic simple XML editor for GNOME
+-Icon=mlview-app-icon.xpm
+-TryExec=mlv
+-Exec=@MLVIEW_EXE@ %F
++Icon=mlview-app-icon
++TryExec=mlview
++Exec=mlview %F
+ Terminal=false
+-
diff --git a/app-editors/mlview/files/mlview-0.9.0-gcc44.patch b/app-editors/mlview/files/mlview-0.9.0-gcc44.patch
new file mode 100644
index 000000000000..b82398f726d7
--- /dev/null
+++ b/app-editors/mlview/files/mlview-0.9.0-gcc44.patch
@@ -0,0 +1,82 @@
+http://bugs.gentoo.org/311573
+
+--- src/mlview-tree-view.h
++++ src/mlview-tree-view.h
+@@ -178,7 +178,7 @@
+
+ enum MlViewStatus build_app_edit_menu () ;
+
+- GtkDialog * TreeView::get_expand_tree_dialog () ;
++ GtkDialog * get_expand_tree_dialog () ;
+
+ void clear_completion_popup_submenus () ;
+
+--- src/mlview-source-view.h
++++ src/mlview-source-view.h
+@@ -53,7 +53,7 @@
+
+ enum MlViewStatus set_default_options () ;
+
+- MlViewXMLDocument* SourceView::get_document () ;
++ MlViewXMLDocument* get_document () ;
+
+ GtkUIManager * get_ui_manager () ;
+
+--- src/mlview-validator.cc
++++ src/mlview-validator.cc
+@@ -25,6 +25,7 @@
+
+ #include "mlview-validator.h"
+ #include "mlview-safe-ptr-utils.h"
++#include <memory>
+
+ #define MESSAGE_LINE_LENGTH 55
+ namespace mlview
+--- src/mlview-plugin.h
++++ src/mlview-plugin.h
+@@ -46,12 +46,12 @@
+
+ //forbid assignation/copy
+ Plugin& operator= (Plugin const&) ;
+- Plugin::Plugin (Plugin const&) ;
++ Plugin (Plugin const&) ;
+
+ public:
+ Plugin (const PluginDescriptor &a_descr) ;
+
+- Plugin::Plugin (const UString &a_url) ;
++ Plugin (const UString &a_url) ;
+
+ virtual ~Plugin () ;
+
+--- src/mlview-editor.cc
++++ src/mlview-editor.cc
+@@ -157,7 +157,7 @@
+ contextual_menu (NULL)
+ {}
+
+- static void EditorPriv::schemas_window_destroy_cb
++ static void schemas_window_destroy_cb
+ (GtkWidget *a_widget, struct DocumentWindowData *a_win) ;
+
+ static void validation_window_destroy_cb
+@@ -406,17 +406,13 @@
+ gtk_dialog_run (GTK_DIALOG (dialog));
+
+
+- switch (button) {
+- case GTK_RESPONSE_OK:
++ if (button == GTK_RESPONSE_OK) {
+ sel_menu_item = gtk_menu_get_active(GTK_MENU(menu));
+
+ result = (ViewDescriptor *)g_object_get_data
+ (G_OBJECT(sel_menu_item), "mlview_view_desc");
+- break;
+-
+- default:
++ } else {
+ result = NULL ;
+- break;
+ }
+ gtk_widget_destroy (dialog);
+ return result;
diff --git a/app-editors/mlview/mlview-0.9.0.ebuild b/app-editors/mlview/mlview-0.9.0.ebuild
new file mode 100644
index 000000000000..0873bf1c9211
--- /dev/null
+++ b/app-editors/mlview/mlview-0.9.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mlview/mlview-0.9.0.ebuild,v 1.1 2010/03/27 08:37:57 ssuominen Exp $
+
+EAPI=2
+inherit eutils gnome2
+
+DESCRIPTION="XML editor for the GNOME environment"
+HOMEPAGE="http://www.freespiders.org/projects/gmlview/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libxml2-2.6.11
+ >=dev-libs/libxslt-1.1.8
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ >=dev-cpp/gtkmm-2.4
+ >=gnome-base/libglade-2.4
+ >=dev-cpp/libglademm-2.6
+ >=gnome-base/libgnome-2.8.1
+ >=gnome-base/gnome-vfs-2.6
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/gconf-2.6.2
+ =x11-libs/gtksourceview-1*
+ >=x11-libs/vte-0.11.12
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ DOCS="AUTHORS BRANCHES ChangeLog NEWS README"
+ G2CONF="--disable-dependency-tracking
+ --disable-static
+ $(use_enable debug)"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-desktop.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ find "${D}" -name '*.la' -exec rm -f {} +
+}