summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-06-28 20:55:00 +0000
committerJeroen Roovers <jer@gentoo.org>2014-06-28 20:55:00 +0000
commit35bfd769e88995f0f6f8627ee6d24b860c6cef2c (patch)
tree488f937bc1153a16763f9c27c6408bfcd78ecfa1 /app-editors
parentalpha stable, bug #495376 (diff)
downloadgentoo-2-35bfd769e88995f0f6f8627ee6d24b860c6cef2c.tar.gz
gentoo-2-35bfd769e88995f0f6f8627ee6d24b860c6cef2c.tar.bz2
gentoo-2-35bfd769e88995f0f6f8627ee6d24b860c6cef2c.zip
Bump EAPI (bug #515622 by Jonas Stein).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/zoinks/ChangeLog7
-rw-r--r--app-editors/zoinks/zoinks-0.4.1.ebuild18
2 files changed, 14 insertions, 11 deletions
diff --git a/app-editors/zoinks/ChangeLog b/app-editors/zoinks/ChangeLog
index d972598a12ea..9989e2c1577b 100644
--- a/app-editors/zoinks/ChangeLog
+++ b/app-editors/zoinks/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/zoinks
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zoinks/ChangeLog,v 1.27 2009/07/23 22:42:10 vostorga Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zoinks/ChangeLog,v 1.28 2014/06/28 20:55:00 jer Exp $
+
+ 28 Jun 2014; Jeroen Roovers <jer@gentoo.org> zoinks-0.4.1.ebuild:
+ Bump EAPI (bug #515622 by Jonas Stein).
23 Jul 2009; Víctor Ostorga <vostorga@gentoo.org> zoinks-0.4.1.ebuild:
Fixing CXX variable, closes bug #243574
diff --git a/app-editors/zoinks/zoinks-0.4.1.ebuild b/app-editors/zoinks/zoinks-0.4.1.ebuild
index e1211ddaa567..769311de6465 100644
--- a/app-editors/zoinks/zoinks-0.4.1.ebuild
+++ b/app-editors/zoinks/zoinks-0.4.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/zoinks/zoinks-0.4.1.ebuild,v 1.7 2009/07/23 22:42:10 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/zoinks/zoinks-0.4.1.ebuild,v 1.8 2014/06/28 20:55:00 jer Exp $
-inherit eutils
+EAPI=5
+inherit eutils toolchain-funcs
DESCRIPTION="programmer's text editor and development environment"
HOMEPAGE="http://zoinks.mikelockwood.com"
@@ -20,18 +21,17 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-src_unpack() {
- unpack ${A}
- sed -i -e 's:-g -Werror::g' "${S}"/configure*
+src_prepare() {
+ sed -i -e 's:-g -Werror::g' configure* || die
+ tc-export CXX
}
-src_compile() {
+src_configure() {
econf $(use_enable nls) --disable-imlib
- emake CXX=$(tc-getCXX) || die "emake failed"
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ default
dodoc AUTHORS ChangeLog NEWS README
doicon ide/Pixmaps/${PN}.xpm
make_desktop_entry ${PN} "Zoinks!" ${PN} "Utility;TextEditor"