summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-27 22:22:00 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-27 22:22:00 +0000
commit3e332a62c7e50fcf435825ddb60322be03678f28 (patch)
treef63e73226d6099d94d47fb9e542889283db2f68f /app-editors
parenttouch the libc (Manifest recommit) (diff)
downloadgentoo-2-3e332a62c7e50fcf435825ddb60322be03678f28.tar.gz
gentoo-2-3e332a62c7e50fcf435825ddb60322be03678f28.tar.bz2
gentoo-2-3e332a62c7e50fcf435825ddb60322be03678f28.zip
touch the libc
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ng/ng-1.5_beta1.ebuild4
-rw-r--r--app-editors/nvi/nvi-1.81.5-r1.ebuild12
-rw-r--r--app-editors/nvi/nvi-1.81.5-r2.ebuild12
-rw-r--r--app-editors/pico/pico-0.0.1.ebuild10
-rw-r--r--app-editors/qe/qe-0.1.1.ebuild9
-rw-r--r--app-editors/scite/scite-1.4.9.ebuild4
-rw-r--r--app-editors/teco/teco-1.00-r2.ebuild6
-rw-r--r--app-editors/videoteco/videoteco-4.69.ebuild8
-rw-r--r--app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild23
-rw-r--r--app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild22
-rw-r--r--app-editors/xemacs/xemacs-21.4.12.ebuild30
-rw-r--r--app-editors/xemacs/xemacs-21.4.15.ebuild28
-rw-r--r--app-editors/xemacs/xemacs-21.4.9.ebuild25
-rw-r--r--app-editors/xvile/xvile-9.3h.ebuild4
14 files changed, 79 insertions, 118 deletions
diff --git a/app-editors/ng/ng-1.5_beta1.ebuild b/app-editors/ng/ng-1.5_beta1.ebuild
index dfee5192b146..f6fe5db1de62 100644
--- a/app-editors/ng/ng-1.5_beta1.ebuild
+++ b/app-editors/ng/ng-1.5_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/ng/ng-1.5_beta1.ebuild,v 1.4 2004/06/24 22:00:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ng/ng-1.5_beta1.ebuild,v 1.5 2004/06/27 22:17:25 vapier Exp $
inherit eutils
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~x86"
IUSE="canna"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
>=sys-libs/ncurses-5.0
canna? ( app-i18n/canna )"
DEPEND="${RDEPEND}
diff --git a/app-editors/nvi/nvi-1.81.5-r1.ebuild b/app-editors/nvi/nvi-1.81.5-r1.ebuild
index 4c98de193d85..e5c797d0e5fa 100644
--- a/app-editors/nvi/nvi-1.81.5-r1.ebuild
+++ b/app-editors/nvi/nvi-1.81.5-r1.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.5-r1.ebuild,v 1.7 2004/06/24 22:00:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.5-r1.ebuild,v 1.8 2004/06/27 22:17:46 vapier Exp $
DESCRIPTION="Vi clone"
HOMEPAGE="http://www.bostic.com/vi/"
SRC_URI="http://www.kotnet.org/~skimo/nvi/devel/${P}.tar.gz"
-SLOT="0"
LICENSE="Sleepycat"
-KEYWORDS="x86 ~ppc ~sparc hppa alpha ~mips"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~mips alpha hppa"
IUSE=""
-DEPEND="virtual/glibc
- =sys-libs/db-3.2*"
+DEPEND="virtual/libc
+ =sys-libs/db-3.2*"
PROVIDE="virtual/editor"
src_unpack() {
@@ -37,5 +37,5 @@ src_compile() {
src_install() {
cd ${S}/build.unix
- einstall
+ einstall || die
}
diff --git a/app-editors/nvi/nvi-1.81.5-r2.ebuild b/app-editors/nvi/nvi-1.81.5-r2.ebuild
index 223e4fb0849e..9e29c27b5bf7 100644
--- a/app-editors/nvi/nvi-1.81.5-r2.ebuild
+++ b/app-editors/nvi/nvi-1.81.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.5-r2.ebuild,v 1.6 2004/06/24 22:00:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nvi/nvi-1.81.5-r2.ebuild,v 1.7 2004/06/27 22:17:46 vapier Exp $
inherit eutils
@@ -8,13 +8,13 @@ DESCRIPTION="Vi clone"
HOMEPAGE="http://www.bostic.com/vi/"
SRC_URI="http://www.kotnet.org/~skimo/nvi/devel/${P}.tar.gz"
-SLOT="0"
LICENSE="Sleepycat"
-KEYWORDS="x86 ~ppc sparc hppa alpha ~mips amd64 ppc64"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc ~mips alpha hppa amd64 ppc64"
IUSE=""
-DEPEND="virtual/glibc
- =sys-libs/db-3.2*"
+DEPEND="virtual/libc
+ =sys-libs/db-3.2*"
PROVIDE="virtual/editor"
src_unpack() {
@@ -43,5 +43,5 @@ src_compile() {
src_install() {
cd ${S}/build.unix
- einstall
+ einstall || die
}
diff --git a/app-editors/pico/pico-0.0.1.ebuild b/app-editors/pico/pico-0.0.1.ebuild
index 4c60a1b5f47d..2e6b62ae60f7 100644
--- a/app-editors/pico/pico-0.0.1.ebuild
+++ b/app-editors/pico/pico-0.0.1.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/pico/pico-0.0.1.ebuild,v 1.11 2004/06/24 22:00:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/pico/pico-0.0.1.ebuild,v 1.12 2004/06/27 22:18:15 vapier Exp $
-HOMEPAGE="http://www.washington.edu/pine"
DESCRIPTION="Pico text editor"
+HOMEPAGE="http://www.washington.edu/pine"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
IUSE=""
-KEYWORDS="x86 ppc sparc "
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
PROVIDE="virtual/editor"
diff --git a/app-editors/qe/qe-0.1.1.ebuild b/app-editors/qe/qe-0.1.1.ebuild
index 8f4f224205cd..f0f8ac116342 100644
--- a/app-editors/qe/qe-0.1.1.ebuild
+++ b/app-editors/qe/qe-0.1.1.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qe/qe-0.1.1.ebuild,v 1.7 2004/06/24 22:01:07 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qe/qe-0.1.1.ebuild,v 1.8 2004/06/27 22:18:32 vapier Exp $
DESCRIPTION="PE2-like editor program under U*nix with Chinese support"
-HOMEPAGE="http://www.cc.ncu.edu.tw/~center5/product/qe/
- http://members.xoom.com/linux4tw/qe/"
+HOMEPAGE="http://www.cc.ncu.edu.tw/~center5/product/qe/ http://members.xoom.com/linux4tw/qe/"
SRC_URI="ftp://freebsd.sinica.edu.tw/pub/statue/qe/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
KEYWORDS="x86"
+IUSE=""
-DEPEND="virtual/glibc"
+DEPEND="virtual/libc"
src_compile() {
./configure --prefix=/usr || die
diff --git a/app-editors/scite/scite-1.4.9.ebuild b/app-editors/scite/scite-1.4.9.ebuild
index 25e57fcace8d..d9d5244acc2c 100644
--- a/app-editors/scite/scite-1.4.9.ebuild
+++ b/app-editors/scite/scite-1.4.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.4.9.ebuild,v 1.5 2004/06/24 22:01:39 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/scite/scite-1.4.9.ebuild,v 1.6 2004/06/27 22:19:08 vapier Exp $
S=${WORKDIR}/$PN/gtk
MY_PV=149
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="x86 ppc sparc"
IUSE=""
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
=x11-libs/gtk+-1.2*"
RDEPEND=""
diff --git a/app-editors/teco/teco-1.00-r2.ebuild b/app-editors/teco/teco-1.00-r2.ebuild
index e9b80ea359ba..ff29ed19eec4 100644
--- a/app-editors/teco/teco-1.00-r2.ebuild
+++ b/app-editors/teco/teco-1.00-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00-r2.ebuild,v 1.3 2004/06/24 22:02:00 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/teco/teco-1.00-r2.ebuild,v 1.4 2004/06/27 22:19:30 vapier Exp $
inherit ccc
@@ -17,10 +17,10 @@ SLOT="0"
KEYWORDS="alpha x86"
IUSE="doc"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-libs/libtermcap-compat
>=sys-apps/sed-4"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
sys-libs/libtermcap-compat"
PROVIDE="virtual/editor"
diff --git a/app-editors/videoteco/videoteco-4.69.ebuild b/app-editors/videoteco/videoteco-4.69.ebuild
index 7c08183ecf38..a4f037a69321 100644
--- a/app-editors/videoteco/videoteco-4.69.ebuild
+++ b/app-editors/videoteco/videoteco-4.69.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/videoteco/videoteco-4.69.ebuild,v 1.8 2004/06/24 22:02:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/videoteco/videoteco-4.69.ebuild,v 1.9 2004/06/27 22:20:00 vapier Exp $
inherit eutils
@@ -13,7 +13,8 @@ LICENSE="as-is"
SLOT="0"
KEYWORDS="alpha x86"
IUSE=""
-DEPEND="virtual/glibc
+
+DEPEND="virtual/libc
sys-libs/libtermcap-compat"
S=${WORKDIR}/teco_4_69
@@ -25,7 +26,6 @@ src_compile() {
}
src_install() {
- insinto /usr/bin
- dobin teco
+ dobin teco || die
dodoc README RELEASE_NOTES
}
diff --git a/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild b/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild
index 3ee9298491c5..d2ea272fac72 100644
--- a/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild
+++ b/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild
@@ -1,32 +1,31 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild,v 1.16 2004/06/24 22:04:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r2.ebuild,v 1.17 2004/06/27 22:21:35 vapier Exp $
inherit eutils
-IUSE="gpm postgres xface tiff gtk jpeg mule nas esd X png gnome"
-
# this is just TEMPORARY until we can get to the core of the problem
SANDBOX_DISABLED="1"
-
REAL_P=${P//-gtk/}
S="${WORKDIR}/${REAL_P}"
-DESCRIPTION="highly customizable text editor and application development system"
-
EFS=1.29
BASE=1.63
MULE=1.40
-
+DESCRIPTION="highly customizable text editor and application development system"
+HOMEPAGE="http://www.xemacs.org"
SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${REAL_P}.tar.gz
http://ftp.xemacs.org/pub/packages/efs-${EFS}-pkg.tar.gz
http://ftp.xemacs.org/pub/packages/xemacs-base-${BASE}-pkg.tar.gz
http://ftp.xemacs.org/packages/mule-base-${MULE}-pkg.tar.gz"
-HOMEPAGE="http://www.xemacs.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE="gpm postgres xface tiff gtk jpeg mule nas esd X png gnome"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/xemacs
>=sys-libs/gdbm-1.8.0
@@ -49,16 +48,10 @@ RDEPEND="virtual/glibc
jpeg? ( media-libs/jpeg )
X? ( virtual/x11 )"
-
DEPEND="${RDEPEND}
>=sys-libs/ncurses-5.2"
-
PROVIDE="virtual/xemacs"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
-
src_unpack() {
cd ${WORKDIR}
unpack ${REAL_P}.tar.gz
diff --git a/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild b/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild
index 6abc87fa6490..918a46288215 100644
--- a/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild
+++ b/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild
@@ -1,31 +1,31 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild,v 1.18 2004/06/24 22:04:01 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs-gtk/xemacs-gtk-21.4.8-r3.ebuild,v 1.19 2004/06/27 22:21:35 vapier Exp $
inherit eutils
-IUSE="gpm postgres xface tiff gtk jpeg mule nas esd X png gnome"
-
# this is just TEMPORARY until we can get to the core of the problem
SANDBOX_DISABLED="1"
REAL_P=${P//-gtk/}
S="${WORKDIR}/${REAL_P}"
-DESCRIPTION="highly customizable text editor and application development system"
-
EFS=1.29
BASE=1.66
MULE=1.42
-
+DESCRIPTION="highly customizable text editor and application development system"
+HOMEPAGE="http://www.xemacs.org/"
SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${REAL_P}.tar.gz
http://ftp.xemacs.org/pub/packages/efs-${EFS}-pkg.tar.gz
http://ftp.xemacs.org/pub/packages/xemacs-base-${BASE}-pkg.tar.gz
http://ftp.xemacs.org/packages/mule-base-${MULE}-pkg.tar.gz"
-HOMEPAGE="http://www.xemacs.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE="gpm postgres xface tiff gtk jpeg mule nas esd X png gnome"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/xemacs
>=sys-libs/gdbm-1.8.0
@@ -48,16 +48,10 @@ RDEPEND="virtual/glibc
jpeg? ( media-libs/jpeg )
X? ( virtual/x11 )"
-
DEPEND="${RDEPEND}
>=sys-libs/ncurses-5.2"
-
PROVIDE="virtual/xemacs"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 sparc "
-
src_unpack() {
cd ${WORKDIR}
unpack ${REAL_P}.tar.gz
diff --git a/app-editors/xemacs/xemacs-21.4.12.ebuild b/app-editors/xemacs/xemacs-21.4.12.ebuild
index 75ebbd9e27d7..96c3154dd7cf 100644
--- a/app-editors/xemacs/xemacs-21.4.12.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.12.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.12.ebuild,v 1.17 2004/06/24 22:03:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.12.ebuild,v 1.18 2004/06/27 22:21:15 vapier Exp $
inherit eutils
-IUSE="gpm postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn canna athena neXt Xaw3d"
-
-LICENSE="GPL-2"
-DESCRIPTION="XEmacs is a highly customizable open source text editor and application development system."
-
+DESCRIPTION="highly customizable open source text editor and application development system"
+HOMEPAGE="http://www.xemacs.org/"
SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${P}.tar.gz
- http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz"
+ http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz"
-HOMEPAGE="http://www.xemacs.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc alpha amd64"
+IUSE="gpm postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn canna athena neXt Xaw3d"
# esound is know to cause problems in XEmacs
#esd? ( media-sound/esound )
-
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/xemacs
>=sys-libs/gdbm-1.8.0
@@ -46,20 +45,13 @@ RDEPEND="virtual/glibc
canna? ( app-i18n/canna )
!amd64? ( freewnn? ( app-i18n/freewnn ) )"
-
DEPEND="${RDEPEND}
>=sys-libs/ncurses-5.2"
-
PDEPEND="app-xemacs/efs
- app-xemacs/xemacs-base
- mule? app-xemacs/mule-base"
-
+ app-xemacs/xemacs-base
+ mule? app-xemacs/mule-base"
PROVIDE="virtual/xemacs virtual/editor"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="amd64 x86 ~ppc alpha sparc"
-
src_unpack() {
unpack ${P}.tar.gz
unpack NeXT_XEmacs.tar.gz
diff --git a/app-editors/xemacs/xemacs-21.4.15.ebuild b/app-editors/xemacs/xemacs-21.4.15.ebuild
index 291b75ea5a47..ee67b1916661 100644
--- a/app-editors/xemacs/xemacs-21.4.15.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.15.ebuild
@@ -1,23 +1,22 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.15.ebuild,v 1.5 2004/06/24 22:03:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.15.ebuild,v 1.6 2004/06/27 22:21:15 vapier Exp $
inherit eutils
-IUSE="gpm postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn canna athena neXt Xaw3d berkdb"
-
-LICENSE="GPL-2"
-DESCRIPTION="XEmacs is a highly customizable open source text editor and application development system."
-
+DESCRIPTION="highly customizable open source text editor and application development system"
+HOMEPAGE="http://www.xemacs.org/"
SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${P}.tar.gz
- http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz"
+ http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz"
-HOMEPAGE="http://www.xemacs.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE="gpm postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn canna athena neXt Xaw3d berkdb"
# esound is know to cause problems in XEmacs
#esd? ( media-sound/esound )
-
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/xemacs
berkdb? ( =sys-libs/db-1* >=sys-libs/gdbm-1.8.0 )
@@ -46,19 +45,12 @@ RDEPEND="virtual/glibc
canna? ( app-i18n/canna )
!amd64? ( freewnn? ( app-i18n/freewnn ) )"
-
DEPEND="${RDEPEND}
>=sys-libs/ncurses-5.2"
-
PDEPEND="app-xemacs/xemacs-base
- mule? app-xemacs/mule-base"
-
+ mule? app-xemacs/mule-base"
PROVIDE="virtual/xemacs virtual/editor"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86 ~ppc ~alpha ~sparc"
-
src_unpack() {
unpack ${P}.tar.gz
unpack NeXT_XEmacs.tar.gz
diff --git a/app-editors/xemacs/xemacs-21.4.9.ebuild b/app-editors/xemacs/xemacs-21.4.9.ebuild
index c260d3ceeb79..fcca4fda2c68 100644
--- a/app-editors/xemacs/xemacs-21.4.9.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.9.ebuild
@@ -1,30 +1,28 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.9.ebuild,v 1.16 2004/06/24 22:03:50 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.9.ebuild,v 1.17 2004/06/27 22:21:15 vapier Exp $
inherit eutils
-IUSE="gpm esd postgres xface nas X jpeg tiff png mule"
-
# this is just TEMPORARY until we can get to the core of the problem
SANDBOX_DISABLED="1"
-LICENSE="GPL-2"
-
-DESCRIPTION="XEmacs is a highly customizable open source text editor and application development system."
EFS=1.29
BASE=1.68
MULE=1.42
-
+DESCRIPTION="highly customizable open source text editor and application development system"
+HOMEPAGE="http://www.xemacs.org/"
SRC_URI="http://ftp.xemacs.org/xemacs-21.4/${P}.tar.gz
http://ftp.xemacs.org/packages/efs-${EFS}-pkg.tar.gz
http://ftp.xemacs.org/packages/xemacs-base-${BASE}-pkg.tar.gz
mule? ( http://ftp.xemacs.org/packages/mule-base-${MULE}-pkg.tar.gz )"
-HOMEPAGE="http://www.xemacs.org"
-
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc"
+IUSE="gpm esd postgres xface nas X jpeg tiff png mule"
-RDEPEND="virtual/glibc
+RDEPEND="virtual/libc
!virtual/xemacs
>=sys-libs/gdbm-1.8.0
@@ -43,17 +41,10 @@ RDEPEND="virtual/glibc
tiff? ( media-libs/tiff )
png? ( =media-libs/libpng-1.2* )
jpeg? ( media-libs/jpeg )"
-
DEPEND="${RDEPEND}
>=sys-libs/ncurses-5.2"
-
PROVIDE="virtual/xemacs virtual/editor"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="x86 ppc sparc "
-
-
src_unpack() {
unpack ${P}.tar.gz
diff --git a/app-editors/xvile/xvile-9.3h.ebuild b/app-editors/xvile/xvile-9.3h.ebuild
index b18571f6c64a..88f56ffbae46 100644
--- a/app-editors/xvile/xvile-9.3h.ebuild
+++ b/app-editors/xvile/xvile-9.3h.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.3h.ebuild,v 1.9 2004/06/24 22:04:34 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.3h.ebuild,v 1.10 2004/06/27 22:22:00 vapier Exp $
S=${WORKDIR}/vile-9.3
DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
@@ -20,7 +20,7 @@ SLOT="0"
KEYWORDS="x86 ~ppc ~sparc alpha"
IUSE="perl"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
sys-devel/flex
virtual/x11
=app-editors/vile-9.3h"