summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-01-29 16:30:05 +0000
committerMike Frysinger <vapier@gentoo.org>2007-01-29 16:30:05 +0000
commit69ceddfb29c0bb657596d57545b786d5c71ee61b (patch)
tree62524bd819cfca637bedbb878bf1a126ca9ecdca /app-editors
parentarm/hppa/ia64/s390/sh stable (diff)
downloadgentoo-2-69ceddfb29c0bb657596d57545b786d5c71ee61b.tar.gz
gentoo-2-69ceddfb29c0bb657596d57545b786d5c71ee61b.tar.bz2
gentoo-2-69ceddfb29c0bb657596d57545b786d5c71ee61b.zip
Version bump.
(Portage version: 2.1.2-r5)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/nano/ChangeLog7
-rw-r--r--app-editors/nano/files/digest-nano-2.0.33
-rw-r--r--app-editors/nano/nano-2.0.3.ebuild76
3 files changed, 85 insertions, 1 deletions
diff --git a/app-editors/nano/ChangeLog b/app-editors/nano/ChangeLog
index 00790645f173..36e3d538edf1 100644
--- a/app-editors/nano/ChangeLog
+++ b/app-editors/nano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/nano
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.143 2007/01/24 02:43:53 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/ChangeLog,v 1.144 2007/01/29 16:30:05 vapier Exp $
+
+*nano-2.0.3 (29 Jan 2007)
+
+ 29 Jan 2007; Mike Frysinger <vapier@gentoo.org> +nano-2.0.3.ebuild:
+ Version bump.
24 Jan 2007; Marius Mauch <genone@gentoo.org> nano-1.3.11-r2.ebuild,
nano-1.3.12-r1.ebuild, nano-2.0.0.ebuild, nano-2.0.1.ebuild,
diff --git a/app-editors/nano/files/digest-nano-2.0.3 b/app-editors/nano/files/digest-nano-2.0.3
new file mode 100644
index 000000000000..15c6f6e9dcc4
--- /dev/null
+++ b/app-editors/nano/files/digest-nano-2.0.3
@@ -0,0 +1,3 @@
+MD5 b8e2c1450b36d21f9a82509da3e4d9b1 nano-2.0.3.tar.gz 1313437
+RMD160 8325e70c957ef84cae7a47ac78d893095e5128d2 nano-2.0.3.tar.gz 1313437
+SHA256 8c29569d0e1eb29cbd3580313b9796c4e6fd0830071ec885021f22be635f5297 nano-2.0.3.tar.gz 1313437
diff --git a/app-editors/nano/nano-2.0.3.ebuild b/app-editors/nano/nano-2.0.3.ebuild
new file mode 100644
index 000000000000..a9731b38fd80
--- /dev/null
+++ b/app-editors/nano/nano-2.0.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-2.0.3.ebuild,v 1.1 2007/01/29 16:30:05 vapier Exp $
+
+#ECVS_SERVER="savannah.gnu.org:/cvsroot/nano"
+#ECVS_MODULE="nano"
+#ECVS_AUTH="pserver"
+#ECVS_USER="anonymous"
+#inherit cvs
+
+MY_P=${PN}-${PV/_}
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+SRC_URI="http://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug justify minimal ncurses nls slang spell unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ !ncurses? ( slang? ( sys-libs/slang ) )"
+PROVIDE="virtual/editor"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if [[ ! -e configure ]] ; then
+ ./autogen.sh || die "autogen failed"
+ fi
+}
+
+src_compile() {
+ local myconf=""
+ use ncurses \
+ && myconf="--without-slang" \
+ || myconf="${myconf} $(use_with slang)"
+
+ econf \
+ --bindir=/bin \
+ --enable-color \
+ --enable-multibuffer \
+ --enable-nanorc \
+ --disable-wrapping-as-root \
+ $(use_enable spell) \
+ $(use_enable justify) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable unicode utf8) \
+ $(use_enable minimal tiny) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc ChangeLog README doc/nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins doc/nanorc.sample nanorc
+
+ insinto /usr/share/nano
+ doins "${FILESDIR}"/*.nanorc || die
+ echo $'\n''# include "/usr/share/nano/gentoo.nanorc"' >> "${D}"/etc/nanorc
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}
+
+pkg_postinst() {
+ elog "More helpful info about nano, visit the GDP page:"
+ elog "http://www.gentoo.org/doc/en/nano-basics-guide.xml"
+}