summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Huebel <jhuebel@gentoo.org>2004-03-12 08:06:49 +0000
committerJason Huebel <jhuebel@gentoo.org>2004-03-12 08:06:49 +0000
commit861fa0784537878fe01efc376c1892412e10b153 (patch)
tree33af1cda91c70535c4a0e6fe5d9a70cef0694141 /app-editors
parentadded patch for gnome-font-properties segfault issues (#38088) (diff)
downloadgentoo-2-861fa0784537878fe01efc376c1892412e10b153.tar.gz
gentoo-2-861fa0784537878fe01efc376c1892412e10b153.tar.bz2
gentoo-2-861fa0784537878fe01efc376c1892412e10b153.zip
added patch for amd64 segfault (#38091)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gedit/files/gedit-2.4.0-64bit-fix.patch12
-rw-r--r--app-editors/gedit/gedit-2.4.1.ebuild7
2 files changed, 18 insertions, 1 deletions
diff --git a/app-editors/gedit/files/gedit-2.4.0-64bit-fix.patch b/app-editors/gedit/files/gedit-2.4.0-64bit-fix.patch
new file mode 100644
index 000000000000..bd022e0a6b7c
--- /dev/null
+++ b/app-editors/gedit/files/gedit-2.4.0-64bit-fix.patch
@@ -0,0 +1,12 @@
+diff -ur gedit-2.4.0.orig/gedit/gedit-document.c gedit-2.4.0/gedit/gedit-document.c
+--- gedit-2.4.0.orig/gedit/gedit-document.c 2004-01-12 20:52:10.996091376 +0100
++++ gedit-2.4.0/gedit/gedit-document.c 2004-01-12 20:50:55.608592738 +0100
+@@ -725,7 +725,7 @@
+ {
+ char* file_contents;
+ GnomeVFSResult res;
+- gsize file_size;
++ int file_size;
+ GtkTextIter iter, end;
+
+ gedit_debug (DEBUG_DOCUMENT, "File to load: %s", uri);
diff --git a/app-editors/gedit/gedit-2.4.1.ebuild b/app-editors/gedit/gedit-2.4.1.ebuild
index 3fe1319dcd5d..588d10d29e6b 100644
--- a/app-editors/gedit/gedit-2.4.1.ebuild
+++ b/app-editors/gedit/gedit-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.4.1.ebuild,v 1.7 2004/02/10 06:29:34 darkspecter Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gedit/gedit-2.4.1.ebuild,v 1.8 2004/03/12 08:06:48 jhuebel Exp $
inherit gnome2
@@ -28,3 +28,8 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS BUGS ChangeLog COPYING INSTALL NEWS README THANKS TODO"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use amd64 && epatch ${FILESDIR}/gedit-2.4.0-64bit-fix.patch
+}