summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-08-03 13:25:44 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-08-03 13:25:44 +0000
commitade921fff1fc4d5b6da927a84557f5e019b893da (patch)
treefd9862776df3e3e27eb0c8b51bc82e96a4f4eac4 /app-editors
parentVersion bump (diff)
downloadgentoo-2-ade921fff1fc4d5b6da927a84557f5e019b893da.tar.gz
gentoo-2-ade921fff1fc4d5b6da927a84557f5e019b893da.tar.bz2
gentoo-2-ade921fff1fc4d5b6da927a84557f5e019b893da.zip
Version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 981CA6FC)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/moe/ChangeLog9
-rw-r--r--app-editors/moe/moe-1.7.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/app-editors/moe/ChangeLog b/app-editors/moe/ChangeLog
index 3e23dd97f372..1a887015fff7 100644
--- a/app-editors/moe/ChangeLog
+++ b/app-editors/moe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/moe
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/moe/ChangeLog,v 1.9 2014/12/06 08:21:12 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/moe/ChangeLog,v 1.10 2015/08/03 13:25:44 polynomial-c Exp $
+
+*moe-1.7 (03 Aug 2015)
+
+ 03 Aug 2015; Lars Wendler <polynomial-c@gentoo.org> +moe-1.7.ebuild:
+ Version bump.
06 Dec 2014; Jeroen Roovers <jer@gentoo.org> moe-1.6.ebuild,
files/moe-1.6-tinfo.patch:
diff --git a/app-editors/moe/moe-1.7.ebuild b/app-editors/moe/moe-1.7.ebuild
new file mode 100644
index 000000000000..af43a62edd0a
--- /dev/null
+++ b/app-editors/moe/moe-1.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/moe/moe-1.7.ebuild,v 1.1 2015/08/03 13:25:44 polynomial-c Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs unpacker
+
+DESCRIPTION="A powerful and user-friendly console text editor"
+HOMEPAGE="http://www.gnu.org/software/moe/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ sys-libs/ncurses
+"
+DEPEND="
+ $(unpacker_src_uri_depends)
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ tc-export CXX PKG_CONFIG
+ sed -i \
+ -e "/^CXXFLAGS=/d" \
+ -e "/^LDFLAGS=/d" \
+ -e "/^CXX=/d" \
+ configure || die "sed on configure failed"
+
+ epatch_user
+
+ epatch "${FILESDIR}/${PN}-1.6-tinfo.patch"
+}