summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-24 18:02:12 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-24 18:02:12 +0000
commite1ca37ce16eb35c1bb08438c9338470d8b971cf5 (patch)
tree616f24c635cd0eaa54ba91eff618ec3140cca9c2 /app-editors
parentdrop some useless comments, xfdesktop works fine with 4.7 now (diff)
downloadgentoo-2-e1ca37ce16eb35c1bb08438c9338470d8b971cf5.tar.gz
gentoo-2-e1ca37ce16eb35c1bb08438c9338470d8b971cf5.tar.bz2
gentoo-2-e1ca37ce16eb35c1bb08438c9338470d8b971cf5.zip
Use patch to fix implicit pointer conversion which lead to compilation failures in 64bit arches
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xemacs/ChangeLog8
-rw-r--r--app-editors/xemacs/files/xemacs-21.4.22-implicit-pointer-conversion.patch17
-rw-r--r--app-editors/xemacs/xemacs-21.4.22-r1.ebuild5
3 files changed, 28 insertions, 2 deletions
diff --git a/app-editors/xemacs/ChangeLog b/app-editors/xemacs/ChangeLog
index 8bb8a6141b72..248b0b81b465 100644
--- a/app-editors/xemacs/ChangeLog
+++ b/app-editors/xemacs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/xemacs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.137 2010/06/17 22:40:24 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/ChangeLog,v 1.138 2010/08/24 18:02:12 hwoarang Exp $
+
+ 24 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
+ xemacs-21.4.22-r1.ebuild,
+ +files/xemacs-21.4.22-implicit-pointer-conversion.patch:
+ Use patch to fix implicit pointer conversion which lead to compilation
+ failures in 64bit arches
17 Jun 2010; Patrick Lauer <patrick@gentoo.org> xemacs-21.4.22-r1.ebuild,
xemacs-21.5.29-r2.ebuild:
diff --git a/app-editors/xemacs/files/xemacs-21.4.22-implicit-pointer-conversion.patch b/app-editors/xemacs/files/xemacs-21.4.22-implicit-pointer-conversion.patch
new file mode 100644
index 000000000000..14fe615d0676
--- /dev/null
+++ b/app-editors/xemacs/files/xemacs-21.4.22-implicit-pointer-conversion.patch
@@ -0,0 +1,17 @@
+Index: xemacs-21.4.22/src/eldap.c
+===================================================================
+--- xemacs-21.4.22.orig/src/eldap.c
++++ xemacs-21.4.22/src/eldap.c
+@@ -57,7 +57,11 @@ static Lisp_Object Qnever, Qalways, Qfin
+ /* Modification types (Qdelete is defined in general.c) */
+ static Lisp_Object Qadd, Qreplace;
+
+-
++/* copied from /usr/include/ldap.h header */
++ldap_open LDAP_P(( /* deprecated, use ldap_create or ldap_initialize */
++ LDAP_CONST char *host,
++ int port ));
++
+ /************************************************************************/
+ /* Utility Functions */
+ /************************************************************************/
diff --git a/app-editors/xemacs/xemacs-21.4.22-r1.ebuild b/app-editors/xemacs/xemacs-21.4.22-r1.ebuild
index 48bef0389b39..50e1836ba2fc 100644
--- a/app-editors/xemacs/xemacs-21.4.22-r1.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.22-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.22-r1.ebuild,v 1.10 2010/06/27 09:58:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.22-r1.ebuild,v 1.11 2010/08/24 18:02:12 hwoarang Exp $
# Note: xemacs currently does not work with a hardened profile. If you
# want to use xemacs on a hardened profile then compile with the
@@ -69,6 +69,9 @@ src_unpack() {
# Security bug #275397
epatch "${FILESDIR}"/${P}-large-images.patch
+ # implicit pointer conversion patch to fix compilation problems
+ # on amd64 when using strict feature
+ epatch "${FILESDIR}"/${P}-implicit-pointer-conversion.patch
# Run autoconf. XEmacs tries to be smart by providing a stub
# configure.ac file for autoconf 2.59 but this throws our
# autotools eclass so it must be removed first.